[RESOLVED] Cannot discover MS Arc mouse - Ubuntu 22.04 & Framework 13 11th Gen

Hi all,
I have an issue which I am struggling to diagnose, and not sure if it’s an issue with the Bluetooth controller on the Framework. I would really appreciate the community’s help to diagnose. My linux ability is somewhere between novice and intermediate…

I have a new MS Surface Arc mouse, which will not show up as a device in the Bluetooth page of Settings.

I have done a bunch of Googling, but the only consistent issue which is shown up for the Arc and Ubuntu is turning bluetooth le mode on with command: “btmgmt le on” (which made no change), but those threads were old, and enough people have reported having the Arc working on Ubuntu to know it should be possible
I have tried some bluetoothctl commands to detect devices from the command line, but no devices are ever found.

The only other device I have connected via bloothtooth is a Tribit bluetooth speaker, which connects fine.

Can anyone help with any diagnosis commands to run, to see if I can identify where the issue is?
Finishing up with the obvious, but important confirmation - the mouse is in pairing mode when I power it on (blue indicator flashing underneath)

Thanks in advance

Just looking at this, you would not want to put the bluetooth connection into low energy mode. So we want to skip that. As aside, btmgmt is the BlueZ Bluetooth utility for managing bluetooth. Using bluetoothctl is in the same ballpark, be it some small differences.

Setting all that aside, here is what occurs to me:

  • Which kernel are you on by chance? Ideally, you should be on OEM C.

  • Please open a terminal, run rfkill unblock all - just in case something is being soft blocked with your bluetooth radio.

  • If everything looks right, bluetooth turns on in the indicator, but it’s not showing in the bluetooth search it is looking for devices, I suspect your mouse may not be entering pairing mode.

  • See if this pairs elsewhere. Triple check to make sure the batteries are good. If it confirms good elsewhere, we can then begin using bluetoothctl to test some things and make sure the mouse is being seen at all. Based on some Google queries, I suspect the issue is with the mouse.

1 Like

Hi Matt,
Thanks for responding to this. I followed a lead that it might be the version of Bluez in Ubuntu 22.04, but trying to upgrade has broken the Bluetooth :frowning:

Since then I tried Live booting Ubuntu 23.10 (which does happen to use a later version of Bluez) - when I did this I was able to pair and use the Arc mouse absolutely fine! So it is definitely an incompatibility somewhere in 22.04.

Due to the broken Bluetooth currently on my machine, I will likely just upgrade to 23.10 to get it working.

Delighted to hear the later version of Bluez helped iron out the issues with the Arc mouse.

With my own tested Bluetooth mice, I have not come across this. However, in the past (years ago), I have seen firmware changes solve these issues with later releases. If I was to hazard a guess, I would suspect there was new firmware that came along. Had a headset issue with A2DP switch to HSP where a sudden firmware fix solved an issue, years ago.

In your case, yes, 23.10 while not LTS, should be fine for its life span.

My advice however is to stick with it a bit before jumping to 24.04 in April - little secret, Ubuntu releases do best with a month to settle out their bugs before jumping over.

Marking this resolved.