[SOLVED] D3D11-compatible GPU error when running Valorant

I keep getting this Error when trying to run Valorant “A D3D11-compatible GPU (Feature Level 11.0, Shader Model 5.0) is required to run the engine”

I started a game one day and 50 seconds into the 1st round my game crashed, and I got the error, which is super weird because now I can’t even get the game to run now.

I’ve followed like 4 guide to help resolve the issue but nothing has worked! Reinstalled the game, restarted, updated all the basic things.

From what I’ve read online the onboard graphics should be able to handle it. I have the i5 version CPU installed on this laptop.

Any help is much appreciated, because I would like to play Valorant again :frowning:

1 Like

Do you have one or two sticks of ram? I believe that the graphics available are lower when using a single stick. That doesn’t answer why it ran the first time, though.


@lbkNhubert i have two sticks

1 Like

@John_Smith2 Did you run the Driver installer from Framework’s website?

@SlashFuture the framework drivers have been installed on this laptop before the error


@John_Smith2 Huh, okay um… Have you updated the Graphics drivers from Intel’s website? It could either be that or your game installation was faulty, and in that case I would uninstall and reinstall if you haven’t already…

@SlashFuture I want to thank you for fixing my problem!

I’ve learned a valuable lesson, don’t trust Windows to automatically install the correct drivers.
To fix my problem I downloaded intel’s driver & support and assistant and it automatically installed the right drivers to fix my issue. I then got VAN 81 error when trying to launch valo but that was a simple fix with a guide.

Thank you so much!!! :slight_smile: <3


@John_Smith2 You’re welcome, and no problem! :grinning: Glad to hear your game is fixed and you can enjoy it now! Glad that it was a software problem too, those are generally easier to fix!

1 Like

To anyone else here: I did all of the above, but it did not work (11th gen Intel on Windows 11).

I had to download Intel® Arc™ & Iris® Xe Graphics - WHQL - Windows* from the Intel page version

1 Like

@cybojanek to fix my problem I didn’t download any drivers manually. What you want to try is to download the Intel Driver & Support Assistant here this fixed my problem! Run through any updates it tells u about. Then u might get another error but try searching up the error and following a guide. Let me know if that fixed it!