[Solved] DIY Gen12 i5-1240P Batch 3: Missing USB Driver

I’ve been trying to figure out this missing USB Driver. I installed the latest Windows 10 OS and Framework Support tells this is supported. Also, installed the Framework Driver Pack for Gen 12 which is supported on Windows 10 BTW. I purchased several Port Expansion Cards modules: 2x USB C, 1x USB A, and 1x HDMI.

With NO USB devices plugged I attempted to have Windows Device Manager find the driver "The drivers for this device are not installed. (Code 28). There are no compatible drivers for this device. To find a driver for this device, click Update Driver. " then “PCI bus 0, device 13, function 2” plus “Device PCI\VEN_8086&DEV_463E&SUBSYS_0002F111&REV_02\
3&11583659&0&6A requires further installation.”. This decodes to Intel’s Thunderbolt onboard chip.

I’ve re-ran Framework’s Gen 12 Driver Pack, ran Windows Update plus Intel Driver & Support Assistant and no luck! An ideas?

Try this:

VEN 8086 is Intel. DEV 463E is the Thunderbolt controller.

…then did Framework Support also say what driver package (specifically, not the bundle) you need for this?

One odd thing I noticed from Intel…
In the following page, you can see that the TB controller is used on Intel® NUC M15 Laptop Kits - LAPRC510 & LAPRC710

But then, on this page the RC models only have Windows 11 driver pack:

+2 for @Second_Coming! Thanks so much for your reply!

The above referenced installer SOLVED my issue. This may not be the perfect installer as this is for a NUC M15 Laptop, however, I anticipated this was similar enough! I will post again if this causes any issues! Otherwise, so far so good with the Framework DIY!

Support did not HAVE a solution and I’ve been trying to educate them about this issue for some time – this so that is why I asked the community! I know just enough…

Support only referenced the Framework Laptop BIOS and Driver Releases 12th Gen Intel Core (Framework Laptop BIOS and Driver Releases (12th Gen Intel® Core™)). Again, while this implies Windows 11 its works for Windows 10 as well.

To Framework Support: Please work with Intel to add the required drivers to the Framework Driver Pack and/or Microsoft Windows Updates and/or Intel Driver & Support Assistant so that this is more automatic for everyone!

Also, please update your Product and Support Pages to indicate Gen 12 will work with Windows 10! A lot of folks seem to think this is a Windows 11 ONLY product!

Hi everyone,

Getting caught up on this thread. It is important to note that Windows 10 is not officially supported on the 12th Gen Intel Core Framework Laptop. All necessary drivers for our latest Framework Laptop are in the driver package for Windows 11 but as Windows 10 does not have proper support for Thunderbolt baked in, workarounds would be required in order to obtain drivers. This is just one potential workaround needed as there can also be other incompatibilities that a customer could run into on Windows 10. Also, drivers included in our Framework Driver Bundles will rarely be the latest from the component manufacturers as we confirm compatibility with testing at our manufacturing facility with Framework-specific hardware. We update the bundles over time, however, we have not yet authenticated or released a new bundle for 12th Gen Intel Core Framework Laptops since launch.

We’re glad this was resolved and that this workaround was able to get you unstuck, however, we still will be unable to officially support Windows 10 on our latest hardware. Windows 11 remains the only version officially tested/supported on the 12th Gen Intel Core Framework Laptop.


Thanks for the official info on this. Much appreciated.

I downloaded the bundle, unzipped it but did not run the installer. Then in the Device-Manager I right-clicked each of the USB-Controllers and chose “Update Driver” then search locally and point to the directory with the unzipped driver bundle.

The Device-Manager found the correct driver for each controller to install. I think this way you can avoid installing drivers for hardware which is not present.
So Thank you for the bundle link!

(For Reference: I am on a 12th Gen i7-1260P where the same issue with the missing “USB-Controller” driver appears)

1 Like