[SOLVED] F-keys - arch linux on framework


Just got arch running on my freshly arrived DIY Framework.

It’s all looking good except for the fact that I can’t seem to use the F-keys to control brightness, speakers etc.

Any ideas?

Many thanks


Just to clarify, hitting fn+f-keys doesn’t work? Have you tried an EC reboot (hold down the power button for ~30s until the lights flash green)?


Yup, that’s right! Been trying different key combinations, including fn+f keys.

Definitely rebooted a few times… not sure what the EC reboot is though? Holding the power button down for an extended period of time (> 30s) doesn’t make it flash green for me…


1 Like

12th Gen? This sounds like [RESPONDED] 12th gen not sending XF86MonBrightnessUp / Down. There’s a solution for it downthread.


Hi @Atomyka
The solution is on Arch Wiki here.
Make that file with the content and reboot. This should fix the problem until the issue is fixed in linux kernel at some point and we won’t need this workaround.


Hi @DHowett and @Cipher

Many thanks for your quick responses and sorry for the delay on my side.

I did try out the blacklisting option. I tried two versions of writing the file content, either

blacklist hid_sensor_hub
blacklist hid-sensor-hub

(found both versions in the links you referenced) and then restarted my laptop. However, the issues seems to persist.

So firstly, I wanted to check that I am indeed supposed to create framework-als-deactivate.conf as a new file? I.e. I’m not supposed to add the blacklist line to an exiting file?

Many thanks

1 Like

Yes @Atomyka make a new file at /etc/modprobe.d location named framework-als-deactivate.conf with blacklist hid_sensor_hub.
Do not add the above to any existing file.

if you’re comfortable with using terminal, all you need to do is
open a terminal run:
sudo nano /etc/modprobe.d/framework-als-deactivate.conf
copy & paste blacklist hid_sensor_hub
Save and that should be all.


Hmm… that’s exactly what I did (except for using vim :p) @Cipher

In case it helps, previously using fn + F7 led to a pop-up about enabling carnet browsing popping up. So maybe I have a setting somewhere that is defining shortcuts that override the basic F-key usage?


I tried it, got the same thing. Not certain but might be a feature in firefox?

1 Like

hello @Atomyka ,

just in case you need it, In firefox’s about:config there’s an entry there

accessibility.browsewithcaret_shortcut.enabled you can set it to false

Hi @Loell_Framework
Thanks for the info! I never actually knew about:config existed… great to know!

Unfortunately, even after turning the shortcut off, I still don’t seem to able to use the fn keys as intended…

I hope this thread can remain open, perhaps someone might come up with another idea? :slight_smile: (Or have an idea why @Cipher’s and @DHowett’s good sugestion isnt’working on my end…)


Hi @Atomyka , yes this thread will continue to be open, I see many threads here gets revived with new solutions.


@Atomyka have you tried running mkinitcpio -P after making the framework-als-deactivate.conf ?
Maybe the kernel images need to be rebuilt?
one more thing to try and test.

Quick question. Have you tried to turn press FN+ESC once?

Good news everyone! I went back to just checking my sway config file (which I was convinced I had done, but apparently I did not…)
Simply changing the key binding I still had from my old laptop (Librem 14 → XF86MonBrightnessUp/Down) to F7/8 did the trick!

Thanks to everyone for your suggestions in the meantime and happy it has sorted itself out now. Time to fully enjoy <Framework|arch> ! :smiley:


Thanks for getting back on this thread @Atomyka , glad to hear that it only boiled down to adjusting sway config. :slight_smile:

Delighted to hear this worked out, marking as solved.