[SOLVED] Fingerprint Reader is no longer detected

Hi…new user here!

I followed the steps in @Matt_Hartley 's very well written guide for updating the fingerprint reader firmware via LVFS on this Ryzen 22.04 system.

After the reboot (Secure Boot still disabled) the fingerprint reader is no longer is detected by Ubuntu. I see this for example:

Framework:~$ fwupdmgr get-devices 1e8c8470-a49c-571a-82fd-19c9fa32b8c3
failed to find any device providing 1e8c8470-a49c-571a-82fd-19c9fa32b8c3

And this:

Framework:~$ fwupdmgr get-updates
Devices with no available firmware updates: 
 • SSD 980 1TB
Devices with the latest available firmware version:
 • System Firmware
 • UEFI dbx
Devices that were not updated correctly:
 • Fingerprint Sensor (01000320 → 01000330)

So I’m not sure how to repair this. I looked for a firmware download I could possibly install via USB but was not immediately successful.

Thanks for any pointers!


Hi @Sam99 welcome to the community,

can we check if device is listed with fprintd-list?


sudo fprintd-list root

you can also replace root with current user

Hi @Loell_Framework thank you very much for getting back to me.

After I posted I continued to read the forums and one of the posts said reboot repeatedly. So I had been trying that with no change in symptoms.

But I just got the idea to fully power off the system (rather than just restarting it) and the fingerprint reader is now working and I enrolled a fingerprint.

Here is the command output you requested:

Framework:~$ sudo fprintd-list sam 
found 1 devices
Device at /net/reactivated/Fprint/Device/0
Using device /net/reactivated/Fprint/Device/0
Fingerprints for user sam on Goodix MOC Fingerprint Sensor (press):
 - #0: right-index-finger

So, thanks for letting me know about that command. Does “reactivated” in the output imply that the system recovered the firmware somehow on its own? Because it now appears to be at version 330:

Framework:~$ fwupdmgr get-devices 1e8c8470-a49c-571a-82fd-19c9fa32b8c3
Selected device: Fingerprint Sensor
Framework Laptop 13 (AMD Ryzen 7040Series)
└─Fingerprint Sensor:
      Device ID:          23ec719b6aabc2d2dac5176c232f0da7a21881b0
      Summary:            Match-On-Chip fingerprint sensor
      Current version:    01000330
      Vendor:             Goodix (USB:0x27C6)
      Install Duration:   10 seconds
      Device Flags:       • Updatable
                          • Supported on remote server
                          • Needs a reboot after installation
                          • Device will not re-appear after update completes
                          • Device can recover flash failures
                          • Signed Payload

So thank you very much!! I’m happy to be a part of this community!

I had a couple of questions:

  1. Since one of the install steps was to “enable-remote lvfs-testing” do I have to revert that? I.E., if I don’t, does that mean I will only be offered beta firmware for everything from now on?

  2. I still have Secure Boot disabled. In order to use the fingerprint sensor does that have to be the case going forward?

Thanks again,


1 Like

Yes you can always revert.

Yeah should be fine to enable back secure boot, fingerprint authentication is used on OS level.

1 Like

Thank you Loell

1 Like

Thanks, @Sam99. After trying the upgrade four or five times with no results, I saw your message and powered-off my laptop. It worked like a charm.

@Loell_Framework, this guide should be updated recommending to power-off. BTW it worked on Debian Sid with the fwupd package from the distro.


@Coque very happy to hear that!