SOLVED: FW can't sustain 60Hz on attached monitor

tldr; FW with Ubuntu 21.04 can’t drive my external monitor at native 60HZ when plugged into dock - need to downgrade to 30HZ to prevent screen blanking.

Anyone see anything like this?

This setup works perfectly with an HP running Ubuntu 20.04, a Thinkpad X1 running Winderz and a MacBook Air 2020. It only fails with FW.

Connecting FW directly to the monitor also works (but defeats the purpose). Swapped out usb-c cables & DP cables. No change. Setup specs below.


OS: Ubuntu 21.04
CPU: Intel® Core™ i7-1165G7
Storage: 1TB - WD_BLACK™ SN750 NVMe™
WiFi: Intel® Wi-Fi 6E AX210 No vPro®
Memory: 32GB (1 x 32GB) DDR4-3200
USB-C/TBolt Dock: Belkin TB 3 Dock Pro (F4U097)
Monitor: Dell 43" U4320Q

I think is what is happening to me as well. Connected directly via DisplayPort the screen regularly goes completely black and the monitor will show the DisplayPort overlay when it reconnects. Using HDMI the same thing is happening but the black flash is much shorter and looks like a little blip. You can keep working but super annoying.

I thought it was a problem with the expansion card but the same things happens regardless of placement. Then I tested with software that might be using the GPU like Alacritty or Firefox but I can’t find anything that makes a difference.

I did try downgrading to 30HZ but couldn’t get the display too work.

Am going to see if I can reproduce on a different monitor.

OS: Xubuntu 21.10
CPU: Intel i7-1185G7 (12M Cache, up to 4.80 GHz)
Storage: 500GB - WD_BLACK™ SN850 NVMe™
WiFi: Intel® Wi-Fi 6E AX210 No vPro®
Memory: 32GB (1 x 32GB) DDR4-3200
Monitor: Samsung 32 inch curved 4K monitor (LU32R591CWNZA)

Update: Lowering refresh rate seems to have resolved the issue!

When using DisplayPort, only options for refresh rate are 60HZ and then 30HZ. 30HZ resulted in wonky display and visibly worse resolution. But on HDMI, the options are 60HZ, 59.9HZ, 50HZ, 30HZ etc. Switching to 50HZ and all flickering gone and no visible reduction in quality. Haven’t tried 59.9HZ but just so happy to have a work around.

Thanks to @CraigO as his post triggered some further investigation. This might work for others having issues.

1 Like

Just checked mine, also a Dell monitor (U3419W). My Dock is an Anker 13-in-1.

Works correctly at 3440x1440 and 60 Hz.

1 Like

I’m not running @ 4k but I am running at 143Hz w/o any issues through a thunderbolt 4 dock.

1 Like

I should have mentioned my external monitor is running 3840x2160 (8,294,400 pixels). @CraigO 's Dell U4320Q is capable of the same resolution. 3440x1440 is 4,953,600 pixels

1 Like

N.B. The solution is to upgrade GNOME from version 38

A shout out to @moderation @Carlos_Fernandez_San and @nomb85. I appreciate the help. My google-fu has been horrible lately but I did come across a (now forgotten) site that mentioned GNOME as a possible cause.

Since I have precious little free time currently and, since Ubuntu just released 21.10, I forced an upgrade which moved GNOME from 38 to 40 and, apparently, has solved the problem. The external monitor is happily chugging along at 60Hz.

BTW, @moderation, the 30/60 are indeed rounded. My monitor’s native frequency is 59.9-ish (forget now).

Good news @CraigO. Interesting that while I’m on 21.10, I’m using XFCE based Xubuntu and therefore not Gnome. Wondering if there is some issue with XFCE that is related?