[SOLVED] Issues enabling fprintd.service

Hi framework community!

So I just received my diy framework laptop and have a fresh install of fedora 37. I’m following the fedora guide to the letter, and I’m having trouble with enabling the fprintd.service (see below). Could anyone help me to fix/enable this? If I need to provide any more information, plz let me know.

So I run the command:
systemctl enable fprintd.service

This command returns the following:
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.

Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit’s
.wants/ or .requires/ directory.
• A unit’s purpose may be to act as a helper for some other unit which has
a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
D-Bus, udev, scripted systemctl call, …).
• In case of template units, the unit is meant to be enabled with some
instance name specified.

My diy config:
CPU: Intel® Core™ i5-1240P
Storage: 1TB - WD_BLACK™ SN850X NVMe™
Memory: 16GB (2 x 8GB) DDR4-3200

Just FYI, I have no experience with Linux aside from once installing arch on an old laptop and watching YouTube videos. I have been searching the forums and google for answers but have not found any.

I seem to have fixed it but the sensor is still acting up slightly.

Based on advice from the ubuntu and arch forums I edited /usr/lib/systemd/system/fprintd.service and added the following lines at the end of the file:


After which ran systemctl enable fprintd.service without troubles.

I continued with the fedora setup guide provided by framework. Trough the terminal I enrolled my fingerprint without issue. However when verifying the print it mismatched and deleted the enrolled fingerprint. (this has happened before) I did the same steps again, with succes this time. After which I finished with the next steps from the setup guide, rebooted and logged in using the print without problems.

After boot I enrolled two more prints (using the settings GUI), the 2nd one sprang an error. Sadly I wasn’t smart enough to write it down before rebooting, it was something along lines of the finger print sensor being in use already. After which it didn’t allow me to enroll any new prints.

I’ll leave this thread up in case anyone else has similar issues. I’m curious to hear from anybody experiencing the same, or any thoughts on my fix.

1 Like

Yep, op is correct. Updating guide now. This is a new thing as it used to just work…

1 Like

Hi @Matt_Hartley,

I received an email with a question from you but I cannot find the comment anywhere, so I will respond here. Your question was regarding the followed steps from the guide. To confirm; yes I followed the following steps, in the following order:

sudo dnf upgrade

Install the needed packages:

sudo dnf install fprintd fprintd-pam (though they were already installed)

systemctl enable fprintd.service
systemctl start fprintd.service

These steps created the error referenced in the first post. After tweaking /usr/lib/systemd/system/fprintd.service I reran the enable and start commands without error.

Something I left out in the post, is that I also tried a full fresh re-install from USB. As well as removing and reinstalling fprintd & fprintd-pam. This didn’t solve it.

The only issue that persisted after the added steps was the verify command removing all enrolled prints after a mismatch. Before enabling fprintd.service the same thing happened on the login a couple times. I have not tried the verify command since my successful verification, let me know if you want me to try to get a mismatch to reproduce the issue.

BTW: can you add a [SOLVED] tag to the title, if you deem it so? I don’t think I have the permissions.

If you have any other questions, let me know.

1 Like

Appreciate the update, I have updated the guide to reflect the following (left hand pane on the page). I’m going to leave verify on the guide for the time being as I was not able to replicate that issue per se. but the rest has been updated.

If others report verify creates issues for them, then I will be removing the verify option.

1 Like