[SOLVED] Linux booting and shutting down issues + i915 Intel graphics issues


Typically I triple boot NixOS, Fedora 37, and Windows 11 happily on my 12th gen Intel Batch 2 Framework laptop. However, overnight I was suddenly stuck and completely unable to boot into either NixOS or Fedora.

On NixOS it displayed the bootloader (systemd-boot), then hung after the first step of stage 1, as it was trying to load the i915 module (which is the Intel graphics driver). None of my other stored NixOS configurations that I could roll back to would boot either. It would sit there until I rebooted.

In Fedora, it again reached the bootloader but would show a single _ in the top left corner of an otherwise completely black screen, and hang until I rebooted.

I was successfully able to boot into Windows, however it is not my primary concern because I normally run Linux.


I tried booting into many different live Linux environments, none of them very successfully, including Ubuntu 22.04, Fedora 36, PopOS 22.04. With Ubuntu I was able to boot using “safe graphics” and could reach the live environment. I double checked many bios settings, secure boot was off for example and everything looked good. The strangest part is that this broke overnight, and every Linux distro that I had booted into before worked perfectly up until now.

After rebooting countless times I decided to go nuclear. I backed up all my data, then went into Ubuntu and cleared and installed Ubuntu 22.04 on the entire drive. I also followed this guide to clear any bios settings that I might have changed and didn’t remember, to hopefully get it back to the way it worked on day one. Unfortunately, nothing changed. I still have to use safe graphics to boot into Ubuntu.

After more troubleshooting I ended up installing Fedora 36 onto it and upgrading to Fedora 37. To get into the Fedora installer, I had to set “nomodeset” in GRUB, which as it turns out is what “safe graphics” does for Ubuntu. Now I can successfully boot into Fedora and currently have that installed as the only OS on my drive.

In Fedora (GNOME), the About page shows that I am using Software Rendering when it should say something about Mesa Intel Graphics.
Fedora seems to have detected to add “nomodeset” by default, in /etc/default/grub. When I remove “nomodeset” and increase the logging level, grub reports these messages:

[  OK  ] Started plymouth-start.service - Show Plymouth Boot Screen.
[  OK  ] Started systemd-ask-password-plymouth.path - Forward Password Requests to Plymouth Directory Watch.
[  OK  ] Reached target paths.target - Path Units.
[  OK  ] Reached target basic.target - Basic System.
[  OK  ] Found device ...
[  OK  ] Reached target initrd-root-device.target - Initrd Root Device.
[    2.948315] i915 0000:00:02.0: [drm] VT-d active for gfx access

Then it hangs, the fans spin up a lot, and I have to hold down the power button to reboot…

Additionally, when I shut down my computer via software, it seems to hit the systemd target for shutting down, then the fans begin to spin faster until I physically hold down the power button to shut it off. This happens consistently, as in it cannot shutdown on its own and the fans begin spinning very fast. When I exit the BIOS in any way, it also cannot boot, it just displays a single _ in the top left corner of an otherwise completely black screen. I have to hold the power button again to shut it down and turn it back on.

Speed info

Relevant output of lspci -k in Fedora with “nomodeset”:

00:02.0 VGA compatible controller: Intel Corporation Alder Lake-P Integrated Graphics Controller (rev 0c)
	Subsystem: Device f111:0002
	Kernel modules: i915

Output of inxi -G in Fedora with “nomodeset”:

[mbund@fedora ~]$ inxi -G
  Device-1: Intel Alder Lake-P Integrated Graphics driver: N/A
  Display: wayland server: X.Org v: 22.1.5 with: Xwayland v: 22.1.5
    compositor: gnome-shell v: 43.1 driver: N/A resolution: 2256x1504~60Hz
  API: OpenGL v: 4.5 Mesa 22.2.3 renderer: llvmpipe (LLVM 15.0.0 256 bits)

Output of uname -r in Fedora with “nomodeset”:


All default kernel params in Fedora

GRUB_CMDLINE_LINUX="nomodeset rhgb quiet module_blacklist=hid_sensor_hub"

I purchased my RAM from Framework themselves, but I have a third party SSD, the SK Hynix Platinum P41 1TB.

Final thoughts

I was not doing anything to the functionality of the system (like messing with the root filesystem) just before everything stopped working, and anyways that should be negated by me completely nuking the SSD. It is important to note that the night that it happened my battery completely drained so I had to plug it in before I learned that I wasn’t able to boot anymore.

My theory right now is that my integrated graphics are completely not responding, because only those distros that have fallbacks to software rendering work at all. Only thing is that I have no idea how that happens or how to fix it.

Update 1

I tried the following kernels in Fedora, unsetting “nomodeset” in GRUB before boot. Below each kernel version are any relevant messages, just before the system hangs and needs to be manually rebooted:

[    2.944679] i915 0000:00:02.0: Your graphics device 46a6 is not properly supported by the driver in this kernel version. To force driver probe anyway, use i915.force_probe=46a6


[    2.949502] i915 0000:00:02.0: [drm] VT-d active for gfx access
[    2.949522] fb0: switching to i915 from EFI VGA


[    2.949502] i915 0000:00:02.0: [drm] VT-d active for gfx access


[    2.949502] i915 0000:00:02.0: [drm] VT-d active for gfx access


[    2.949502] i915 0000:00:02.0: [drm] VT-d active for gfx access


[    2.949502] i915 0000:00:02.0: [drm] VT-d active for gfx access

If I set VT-d off in the BIOS, it hangs on

[  OK  ] Reached target initrd-root-device.target - Initrd Root Device.

Related articles


Any help would be appreciated!

I would reach out to support. This definitely smells like a hardware issue.

Fedora and Ubuntu work out of the box, this sounds like hardware. You should absolutely not need to do anything manual on Fedora or Ubuntu to get the graphics working without extra work. Please reach out to support, link them to this thread. Thanks.

Wanted to give an update. I contacted support and sent them a video of the issue. They sent me a new mainboard and RMA’d the old one. The new one is working well, and it seems to have been a hardware issue.


Fantastic! Glad to hear this is resolved.

Hey, I have a almost 1 to 1 of this issue, only I don’t have windows, ubuntu or fedora installed.
I accidentally left my laptop on over night and the battery died.
Just throwing this out there for future reference.
Also - Is there any known reason as to why this happens?

Since it is liekley a hardware issue if it is a one to one correlation. File a ticket with support to get it resolved. As to why hardware issues occur straight from the factory…well there are hundreds of potential reasons but they all boil down to human error, conincidental unexpected environmental factors, part flaws missed by previous QA from parts vendors, nearly undetectable materials flaws, mechanical issues in the production line, failure of QA on the ifnal vendors part, and potential unseen physical damage during shipping. These are just ones that leap to mind in a minute, and I already had a couple more come to mind while typing this sentence. Anyway not going to take up any more of my cpu cycles thinking about it :slight_smile: File a ticket.

1 Like

Exactly this. Please open a ticket.