Can only start Linux with option nomodeset

I just received my framework laptop and have tried to install Linux Mint 21 and Ubuntu 22.04.1 LTS.

Unfortunately I can only start a live usb system for both Ubuntu and Linux Mint using the grub option nomodeset, which according to most sources will lead to performance problems, e.g. in video playback.
The issue persists once the Linux Mint system is installed.
I have a 11th gen Intel system with the newest bios version installed.

Any help would be greatly appreciated

What happens when you omit that option and try to start normally?

It freezes at the splash screen, sometimes there is a big blue bar at the bottom.
If I remove the splash screen and show boot logs, it stops in the middle of the process. Not sure what the last output is, but it is not an error.

So I’ve tried out many different kernels, help page suggestions and distro versions and unfortunately nothing has worked. I guess I will have to give up and install Windows. :.(
Too bad, I would have thought the framework has good Linux compatibility.