[GUIDE] Linux Mint on Laptop 13 with AMD 7040

Wanted to pull my post the from general Linux on Laptop 13 thread and post it in a place more dedicated to Mint.

Got my AMD 13 an hour or so ago. I installed Mint 21.2 Edge and so far it’s worked great out of the box.
Will keep playing around and post if/when I see any major issues come up.

The fingerprint reader does not work out of the box, which seems to be a known issue. The firmware out of the box does not support it and fwupd fails to even start. It’s running version 1.7.9.

Edit 2:
Change the kernal 6.1.0-1023-oem as recommended. This does seem to make the system feel a bit more snapy. Ran geekbench for a baseline. Link below. But the numbers look great from what I see.
Also I was able to get fwupd running now as well. Will see if I can get the finger print reader working next when I get some time.

Edit 3:
Got the fingerprint read to work after a few steps. Looks like it is a new firmware for the fingerprint sensor itself. First needed to follow “If the devices is not detected” part of this framework guide.

Then I installed libpam with:
sudo apt install libpam-fprintd

I could then run fprintd-enroll to get my right finger added.
Finished up by running sudo pam-auth-update
Did a reboot and could now log in using my fingerprint.

Post on the kernal change (Mint 21.2 only):

[Matt_Hartley] (Profile - Matt_Hartley - Framework Community)Framework Linux Support Lead


Awesome. You will absolutely want to make some kernel adjustments on AMD. While unofficial, this should still apply as it’s still based on Ubuntu 22.04.

Sourced from here .

NOTE: This is NOT official and is done as I need folks on Mint using the correct kernel. 6.2 is not going to be amazing. The recommended, tested, supported OEM C kernel will be far, far better.

For ticketed support and official vetting, we ask users to run Ubuntu 22.04.3 over Mint.

If you need to use Mint and understand I provided no support here to this, here is your best experience below.

Install the recommended OEM kernel.

sudo apt install linux-oem-22.04c


sudo nano /etc/default/grub

Identify your OEM C kernel

Back up GRUB

sudo cp /etc/default/grub /etc/default/grub.bak

Right now, the AMD target kernel we want folks on is 6.1.0-1023-oem - but this may evolve in the future. 6.1.0-102x-oem in the future. We use a Zenity alert tool on Ubuntu for this. You will need to do this manually or customize it yourself .
Again, this mini-unofficial guide is for Linux Mint, not other distros.

Change the following.



GRUB_DEFAULT="Advanced options for Linux Mint 21.2 Cinnamon>Linux Mint 21.2 Cinnamon, with Linux 6.1.0-1023-oem""

Then run

sudo update-grub



Very limited dataset for now…but F39 seems to be winning in performance:

And here’s the numbers for the 7840u:

In both cases, the single core score reaches 2600+.

Wonder whose scores these are:

Remember folks, benchmarks at this point are based on soon to be replaced BIOS. Something to keep in mind. :wink:

1 Like

If you want to slide that BIOS firmware over to me sooner I would not complain :smiley:

All, for AMD 7040, please update to the latest BIOS beta:


I used the UEFI usb direction to upgrade the firmware. This worked without issues and only took 3 or 4 minutes.

I am now using kernel 6.2.0-34. Everything appears to be working without any problems. That said at the time everything was working for me on MInt so there were no real “problems” to solve. It may be updated drivers for the wifi nic in 6.2 but speed/latency tests have seemed a bit better. Battery life and performance were great before. I will report back if I see anything change.

Updated geekbench, the numbers are pretty simular to before.

Had an issue with my fingerprint reader in Mint 21.2 prior to the BIOS update, and afterwards it persists sadly.

Fingerprint registration works perfectly, and I can use the reader for sudo in the terminal and when locking the computer or logging in. However, it never properly works on first login after boot. It’ll successfully scan and then I’ll press enter to log in, but then I’ll be taken back to the login page. No errors. I’m forced to either wait for the fingerprint login option to time out, or attempt a bad read to get the password option to appear.

I ensured the reader is on the latest firmware, re-flashed it, reinstalled fprintd and libpam-fprintd multiple times, and moved to the 6.5.7-060507-generic kernel. No change in behavior.

Is anyone else dealing with this type of issue?

At first boot I get the prompted to use my finger print, but it does require me to hit “enter” afterwards to complete the sign in. I DO have have to try a finger print read to get the password prompt to come up which I think is the same issue you are having.
I use the laptop as a secondary device at the moment so it has not been much of an issue for me.
I will spend some time later today or tomorrow playing around to see if I can figure out what is going on. I am by no means an expert so can not promise anything.

After looking around it seems the way the reader is acting, for me at least, is standard. Having to press enter after scanning your finger is normal.
As for why you are getting a log in loop that is clearly something different.

I found another with the same issue on the Mint forms and it was tied to encyption of the /home folder. Its a bit dated:

I’ve encountered even stranger behavior with further testing. I installed the standard GNOME DE and it lets me in using just fingerprint when I have the Wayland-powered GNOME selected. However, settings/dash/tweaks customizations do not persist and many applications do not launch. Firefox claims that the profile is missing or corrupted.

I log out, log in with password, and everything is as I originally customized. No issues. It’s bizarre.

Read above you’re using Mint. Unfortunately I lack the available cycles to dig into the community releases like Mint to drill stuff like this. But if it’s working on on GNOME (as we test against Fedora and Ubuntu), GNOME will be your best bet for a speedy workaround.

Sadly it doesn’t work in GNOME. As mentioned, it lets me in but fails to load any user profile data, does not save customizations, and no apps are able to launch. It’s a “ghost” profile, nearly identical to behavior I’ve seen on other machines when Windows fails to load the user profile service. It only loads my user profile if I log in with my password. I don’t understand why, but given the reader works for anything within a user session as well as lock screen unlocks (once logged in) I think it’s more a Mint issue than a driver/firmware issue.

Just adding to success: Using 6.5 kernel (also works with 6.1) fixed my USB/HDMI connection and added OpenGP hardware acceleration instead of llvmpipe software renderer in the 5.x kernels.

Big change there is that therefore cinamon isn’t sitting there taking up lots of CPU resources.

I’m using linux mint 21.3 (2024) with kernel 6.5 and so far everything is working except that I have not tried/played with finger print scanner.

One thing to note - 6.5 does not work with Virtual PC - problem known in the drivers that is being fixed - but 6.1 seems to work well with Virtual PC and all my hardware.

I’m going to add my Mint experience here, just for searchability (since it took me a while to get here). My basic install went fine, but the laptop wasn’t sleeping properly: battery use with the lid closed seemed to be about the same as idle.

The results of running amd_s2idle.py (which is what I search for and didn’t find) were:

:white_check_mark: HSMP driver amd_hsmp not detected (blocked: False)
:x: PMC driver amd_pmc did not bind to any ACPI device
:white_check_mark: USB4 driver thunderbolt loaded
:x: GPU driver amdgpu not loaded
:white_check_mark: System is configured for s2idle
:white_check_mark: NVME Sandisk Corp is configured for s2idle in BIOS
:white_check_mark: GPIO driver pinctrl_amd available

I installed the linux-oem-22.04 package and now:

:white_check_mark: HSMP driver amd_hsmp not detected (blocked: False)
:white_check_mark: PMC driver amd_pmc loaded (Program 0 Firmware 76.70.0)
:white_check_mark: USB4 driver thunderbolt loaded
:white_check_mark: GPU driver amdgpu available
:white_check_mark: System is configured for s2idle
:white_check_mark: NVME Sandisk Corp is configured for s2idle in BIOS
:white_check_mark: GPIO driver pinctrl_amd available

Now it sleeps just fine (and likely having the graphics driver is helping too).

Hi all, any updates on the Linux Mint experience on FW13? I’m interesting in trying it.

I’m interested in running Linux Mint on my AMD FW 13. The most up to date thread I can find is for the FW 16:

It seems it’s been a while since people have posted about their experiences with it. It seems like in the 16 thread, people recommended Cinnamon EDGE over regular Cinnamon, would that still be the case?

Hi Tam,
as you can see in my earlier post there, i started with plain Mint Cinnamon 21.3 with a Kernel 5.15.something, and it worked, after some jumping through hoops.
IMHO Edge just contains the newer Kernel IIRC, which i installed anyway.
As i believe, the mainboards are the same for FW13 and FW16, so i hope my experiences can still give you some hints.
Best regards, W_L

1 Like

Hi @Tam,

The reason you don’t see much about Mint is that it generally just works.

If you can get it to boot with the default 5.15 kernel (indications are you should be able to) and install the 6.5 kernel, it should work well. If you install the Edge version, you get the 6.5 kernel by default.

Even more advanced kernels are coming to Mint 22, probably out in a month or two, but for now, 6.5 should be able to handle the FW13 Intel 11th gen, 12th gen and 13th gen, FW13 AMD 7040 and FW16s.

1 Like

I had to do the “completing setup” instructions for Ubuntu to get the last of the drivers etc working. But with that, my 13 inch Ryzen 7040 is working beautifully with Mint.