[SOLVED] Manjaro Battery Drain Issue - Intel 12th Gen (Redux)

Hey everyone,

I know this has been discussed extensively in other threads, but I’m still having serious offline battery drain issues on my framework 13 12th gen running manjaro. It loses roughly 30% overnight and dies after a few days even when completely shut down.

Is there something obvious I’m missing that I should try?

So far as I can tell, the original bios is still up-to-date, I’ve also tried tampering with various sleep settings in system to no effect (maybe something I’m missing here?).

Also, apologies again if this is redundant and the answer is somewhere in the mega-battery thread.

  • Jack

What expansion cards are you using?

Two type C, one type A, and HDMI.

Hi @Jack_Rametta , welcome to the community :slight_smile:

are you certain that only manjaro is exhibiting this issue, have you tried other distros? (ubuntu/fedora)


Hey! Thanks, I haven’t tried other distros - I’ll try vanilla arch and see if the problem persists.

So unfortunately I’m still having the same issue after a few days using simple arch instead. Not sure what I’m missing.

Hello @Jack_Rametta , btw what is your battery mileage when most expansion cards are removed?

1 Like

Try yanking that HDMI expansion card out. Multiple reports on the forums about simply strange behavior with the HDMI and dp cards. Extra power draw, shutdowns during sleep or suspend, etc.

1 Like

Thanks! These two were the correct answer. It’s the HDMI card in particular. I get basically no drain overnight now even without shutting down.