(SOLVED, sort of)Touchpad Not Working Fully

I admit I was a bit curious about what that PS2 Mouse setting in the BIOS meant, I thought maybe it was some sort of legacy setting included in whatever stock BIOS you started with. Nice to know the details.

Installing windows 10 and then reading the touchpad driver solutions article here then installing the driver solution from here did solve any problems when it comes to touchpad issues in windows for me. Like @Kieran_Levin said you can turn the PS2 setting on or off in the bios settings.

When it comes to newer Debian based distributions, after installing Pop!_OS 21.04, the way I have found to change the touchpad right click settings is in Gnome Tweaks, and for Ubuntu 21.04 right click is set that way as the default.

I’m facing a similar issue on Fedora 34. However, I’m running the KDE Plasma environment, so Gnome Tweaks won’t do much for me.

In my case, right click doesn’t work at all (tried two-finger clicking and clicking the right half and bottom right quadrant of my touchpad with no success).

Click and drag works but only with a single finger. I like being able to click and hold with my pointer finger in the bottom left quadrant of the touchpad, then use my middle finger to drag the window around. Attempting to do this does nothing except cause the cursor to change.

I’ll try disabling PS2 emulation in the morning to see if this helps anything.

@Foxtrek_64 Have you tried this one? FIXED: trackpad in linux - #6 by Stebalien .

This quirk has already been merged into the latest version of libinput, so I’m not sure if that would help me. I thought I’d try anyways but I don’t have an /etc/libinput folder, so I don’t know if that’ll work as expected.

After disabling PS2 emulation in BIOS, I don’t notice any immediate differences in behavior. Right clicking still does not function at all and drag still requires one hand. Touchpad settings still look identical.

I should note that if I turn on tapping, two finger tapping does work to bring up the context (right click) menu. However, I would instead like this to be a two finger click, not a two finger tap. And this requires me to enable one finger tapping to click, which causes all sorts of unexpected behavior when I accidentally tap my trackpad.

I don’t think so. The PR to add the config of Framework Laptop was merged to the main branch on the upstream. But it’s not released yet.

Seeing Overview - rpms/libinput - src.fedoraproject.org , the normal Fedora 34’s latest libinput is libinput-1.18.0-2.fc34.x86_64.

Here is result in my local machine Lenovo.

$ cat /etc/fedora-release 
Fedora release 34 (Thirty Four)

$ rpm -q libinput
libinput-1.18.0-2.fc34.x86_64

$ rpm -ql libinput | grep quirks
/usr/share/libinput/10-generic-keyboard.quirks
/usr/share/libinput/10-generic-lid.quirks
...

But there is no /usr/share/libinput/50-framework.quirks in the RPM package.

Seeing the document Device quirks — libinput 1.20.0 documentation , you can add the file under the /usr/share/libinput directory. Also possibly you can check a list of config files by sudo libinput list-devices. I don’t have Framework Laptop to test yet.

2 Likes

In this case, a temporary quirks file is better as in the libinput next released version, the file path is occupied by the RPM package. You can create the file /etc/libinput/local-overrides.quirks by creating the directory /etc/libinput.

https://wayland.freedesktop.org/libinput/doc/latest/device-quirks.html#device-quirks-local

Installing temporary local device quirks

The model quirks are part of the source distribution and should never be modified. For temporary local workarounds, libinput reads the /etc/libinput/local-overrides.quirks file.

1 Like

@junaruga That seems to have gotten it. After adding that quirk and rebooting, drag behavior is now what I would expect. I can now click and hold with one finger and drag with another.

As for right clicking, clicking in the bottom right corner now functions as expected. I may look into changing this to being generally on the right side of the trackpad instead, but I’m happy to have the functionality at all for now.

Thanks for your help!

1 Like

As a note, the new version libinput 1.18.1 including the PR’s commit was released!

1 Like

Would anyone know why two finger scrolling works on Windows but right click does not?

Maybe check the Windows touchpad settings?


https://www.intowindows.com/how-to-enable-two-finger-tap-for-right-click-in-windows/

Yeah, I’m able to right click with the two finger gesture. However clicking with the bottom right doesn’t work for right click. In fact with physical clicking it doesn’t seem to register anything at all, I only get the tactile click feeling. I’m afraid it might be a hardware issue.

There is a known issue around this (Known issues on early Framework Laptops). Could you reach out to Support so that we can trade you a new Input Cover? We’re trying to get more samples of this issue so that we can root cause and resolve it.

2 Likes

Absolutely! Thank you for the rapid responses. Really shows the team going the extra mile to bring the right product to market.

1 Like

Chiming in here. I recently got a new input cover as my old input cover had a short/burnt on the board and connector.

I’ve installed the necessary drivers via the driver bundle. Device manager looks good no discrepancies noted. I am running Windows 10 fully updated. At first, the touchpad wouldn’t recognize my taps in order to click or “right click” into a menu not until I followed the advice to turn off the ps/2 emulator in BIOS. Now all my gestures work fine. As for the tactile, none of that works at all. I’m sure I get a good “click” everything seems to work fine mechanically but the OS doesn’t seem to detect it at all. Any suggestions would be really appreciated.

This is potentially the same hardware issue. If you could contact Support for a new Input Cover, that would be best. We’ll ask for the one you have back to analyze it.

tl;dr I think this workaround doesn’t work for me™; (distro=manjaro)

@junaruga thanks for figuring things out - I’m not having success, Can you (or anyone) LMK if maybe I’m incorrectly summarizing the solution below thus far?

exact steps: file manipulations, source links, etc.

summary of temporary-workaround steps junaruga found:

  1. copy the file contents from the libinput patch to clipboard/wherever eg
$ cat > upstream-file <<EOF
# manually set file contents, to fix two-finger detection of touchpad
# taken from:
# - https://gitlab.freedesktop.org/libinput/libinput/-/merge_requests/665/diffs
# - per https://wayland.freedesktop.org/libinput/doc/latest/device-quirks.html#device-quirks-local
# - per https://community.frame.work/t/solved-sort-of-touchpad-not-working-fully/3512/25
[Framework Laptop Touchpad]
MatchName=PIXA3854:00 093A:0274 Touchpad
MatchUdevType=touchpad
MatchDMIModalias=dmi:*svnFramework:pnLaptop:*
AttrEventCodeDisable=BTN_RIGHT
EOF
  1. sudo mkdir -p /etc/libinput
  2. sudo mv upstream-file /etc/libinput/local-overrides.quirks
  3. sudo systemctl reboot

Then, upon reboot, two-finger scroll/right-click just works? Or am I misunderstanding?


Total aside: interestingly pricedspacefan reports above Manjaro Xfce two-finger scroll works for them. No idea what’s different… maybe I’m hitting a hardware issue…

I had this issue but changing the PS2 mouse emulation setting as @Kieran_Levin suggested fixed it! Only had it for a day and so far its definitely the best laptop I’ve ever had.

The firm press thing from this guide fixed my problem, although I do seem to have to repeat the process every so often: My touchpad isn't working

Can we @Sensel and get them to collab w/ Framework for a high end trackpad experience.

2 Likes