(SOLVED, sort of)Touchpad Not Working Fully

Check whether nomodeset is present in your kernel cmdline:

cat /proc/cmdline

I’m running fedora and some touchpad gestures were not supported after fully installing, but started working once I edited /etc/default/grub and removed nomodeset from the GRUB_CMDLINE_LINUX line (followed by running grub-mkconfig and rebooting).

4 Likes

will try that then report back

Checking cat/proc/cmdline does not show anything about nomodeset

Pop!_Os is using systemdboot, so i attempted to look in there for more info.
Entering the command sudo nano /boot/efi/loader/loader.conf only showed
default Pop_OS-current

Thats it

on the plus note, right click is working, its just set as double click. however if thats the case for popos, i wonder whats its like for all other operating systems

1 Like

Okay after testing some operating systems with different desktop environments in live cd and being fully installed here is what I found, some work out of the box some do not work at all.

Windows 10 pro 21h1 did show some other devices in device manager. When I attempted to Install some of the drivers they gave a code 28 error
uninstalling them then reboot did not work.
A quick note that it did appear to work once then never again.
Windows 10 was fully installed.

Installed windows 11 and had the same amount of problems as windows 10.

For Pop!_OS, right click and multi-finger gestures did work, gnome tweaks were able to edit the right click to be in the bottom right area rather than double click anywhere on the trackpad.

In Ubuntu, right click works out the box in 21.04 and 20.4.2
two finger scrolling also works out of the box after being fully installed for me

Linux Mint Cinnamon 20.1, right click and two finger scrolling do not work out of the box
in the live environment for me

Manjaro Xfce 21.0-210318 seems to have the two finger scroll, and right click right out of the box out of the box after being fully installed for me

Elementary OS 5.1 stable has the options for two finger scroll and right click but they did not appear to work in the live cd

In Fedora 34, the touchpad double finger scrolling appears to be working out of the box,
switching workspaces with 3 fingers worked, right click is not working in live usb

most of these problems im assuming come from either driver implementation AND desktop environments in linux

thank you those who posted giving me ideas to research.

3 Likes

@pricedspacefan the touchpad needs drivers installed in windows to fully function as a windows PTP touchpad. And in Linux you will need a recent kernel that supports tigerlake SerialIO.

It is not super obvious, but we have an auto detection fallback in the laptop firmware that detects when the OS has no driver and is not communicating with the touchpad. In this case the touchpad will fall back into a basic legacy mode that routes touchpad events through the EC as an emulated PS2 mouse. This is so that DIY users can complete the windows installer without needing to plug in a mouse.

When this happens you will not have right click or 2 finger scroll.

If you are running an older kernel that does not support the tigerlake serialIO subsystem, you will end up with limited touchpad functionality.
You can force this compatibility fallback off in the bios in the advanced setting menu ->PS2 Mouse Emulation → Off.
This has caused some confusion and even a reviewer thinking our touchpad was not a precision touchpad which we need to improve the UX. But it does drastically improve the setup experience for the DIY system.

16 Likes

I admit I was a bit curious about what that PS2 Mouse setting in the BIOS meant, I thought maybe it was some sort of legacy setting included in whatever stock BIOS you started with. Nice to know the details.

Installing windows 10 and then reading the touchpad driver solutions article here then installing the driver solution from here did solve any problems when it comes to touchpad issues in windows for me. Like @Kieran_Levin said you can turn the PS2 setting on or off in the bios settings.

When it comes to newer Debian based distributions, after installing Pop!_OS 21.04, the way I have found to change the touchpad right click settings is in Gnome Tweaks, and for Ubuntu 21.04 right click is set that way as the default.

I’m facing a similar issue on Fedora 34. However, I’m running the KDE Plasma environment, so Gnome Tweaks won’t do much for me.

In my case, right click doesn’t work at all (tried two-finger clicking and clicking the right half and bottom right quadrant of my touchpad with no success).

Click and drag works but only with a single finger. I like being able to click and hold with my pointer finger in the bottom left quadrant of the touchpad, then use my middle finger to drag the window around. Attempting to do this does nothing except cause the cursor to change.

I’ll try disabling PS2 emulation in the morning to see if this helps anything.

@Foxtrek_64 Have you tried this one? FIXED: trackpad in linux - #6 by Steven_Allen .

This quirk has already been merged into the latest version of libinput, so I’m not sure if that would help me. I thought I’d try anyways but I don’t have an /etc/libinput folder, so I don’t know if that’ll work as expected.

After disabling PS2 emulation in BIOS, I don’t notice any immediate differences in behavior. Right clicking still does not function at all and drag still requires one hand. Touchpad settings still look identical.

I should note that if I turn on tapping, two finger tapping does work to bring up the context (right click) menu. However, I would instead like this to be a two finger click, not a two finger tap. And this requires me to enable one finger tapping to click, which causes all sorts of unexpected behavior when I accidentally tap my trackpad.

I don’t think so. The PR to add the config of Framework Laptop was merged to the main branch on the upstream. But it’s not released yet.

Seeing Overview - rpms/libinput - src.fedoraproject.org , the normal Fedora 34’s latest libinput is libinput-1.18.0-2.fc34.x86_64.

Here is result in my local machine Lenovo.

$ cat /etc/fedora-release 
Fedora release 34 (Thirty Four)

$ rpm -q libinput
libinput-1.18.0-2.fc34.x86_64

$ rpm -ql libinput | grep quirks
/usr/share/libinput/10-generic-keyboard.quirks
/usr/share/libinput/10-generic-lid.quirks
...

But there is no /usr/share/libinput/50-framework.quirks in the RPM package.

Seeing the document Device quirks — libinput 1.18.900 documentation , you can add the file under the /usr/share/libinput directory. Also possibly you can check a list of config files by sudo libinput list-devices. I don’t have Framework Laptop to test yet.

2 Likes

In this case, a temporary quirks file is better as in the libinput next released version, the file path is occupied by the RPM package. You can create the file /etc/libinput/local-overrides.quirks by creating the directory /etc/libinput.

https://wayland.freedesktop.org/libinput/doc/latest/device-quirks.html#device-quirks-local

Installing temporary local device quirks

The model quirks are part of the source distribution and should never be modified. For temporary local workarounds, libinput reads the /etc/libinput/local-overrides.quirks file.

1 Like

@junaruga That seems to have gotten it. After adding that quirk and rebooting, drag behavior is now what I would expect. I can now click and hold with one finger and drag with another.

As for right clicking, clicking in the bottom right corner now functions as expected. I may look into changing this to being generally on the right side of the trackpad instead, but I’m happy to have the functionality at all for now.

Thanks for your help!

1 Like

As a note, the new version libinput 1.18.1 including the PR’s commit was released!

1 Like

Would anyone know why two finger scrolling works on Windows but right click does not?

Maybe check the Windows touchpad settings?


https://www.intowindows.com/how-to-enable-two-finger-tap-for-right-click-in-windows/

Yeah, I’m able to right click with the two finger gesture. However clicking with the bottom right doesn’t work for right click. In fact with physical clicking it doesn’t seem to register anything at all, I only get the tactile click feeling. I’m afraid it might be a hardware issue.

There is a known issue around this (Known issues on early Framework Laptops). Could you reach out to Support so that we can trade you a new Input Cover? We’re trying to get more samples of this issue so that we can root cause and resolve it.

2 Likes

Absolutely! Thank you for the rapid responses. Really shows the team going the extra mile to bring the right product to market.

1 Like