Right click doesn't seem to work

Hello ! I received my framework last week and everything is excellent (especially the keyboard :smile: ) except my right click on my trackpad doesn’t work on Linux 6.0.7 (GNU Guix with nonfree kernel). I’ve tried the following things:

  • Disabled ps/2 emulation in UEFI interface
  • Installed and tried the X window system (instead of Wayland)
  • Tried Fedora 37 Workstation live (same result)
  • Tried Arch Linux with Gnome shell (same result)

Does somebody have a suggestion? Is my kernel too new?

I already down and upgraded libinput and might try an LTS kernel tomorrow. If that doesn’t work I might try Microsoft Windows to rule out a hardware issue, but that is my last resort (hate setting up windows)

Thanks!

Might be way off but on fedora 37 when installing right click wasn’t ‘working’ either…
But it was because you need two fingers for right-click, one for left click (or something like that not 100% sure).

1 Like

Default on most more popular Linux distros is two finger tap equals a right click.

1 Like

Thanks for confirming!

1 Like

Two finger right click wasn’t the default for me on Manjaro KDE on either X or Wayland, but it’s easy to change in the trackpad settings in KDE’s System Settings panel. Especially on wayland, try checking your window managers settings.

For completeness sake, the other option KDE provides is right click via clicking in the bottom right corner of the trackpad.

1 Like

I’m an idiot, two finger click is working indeed. I’ve never had a modern (post 2008 ish) laptop before so didn’t really know about gestures.

Thanks all!

Don’t feel bad, I have different settings on different laptops, it happens.

3 Likes