[SOLVED] TH3P4G3 eGPU not working standby light and both Thunderbolt ports not working

See reply for solution

  • 13 inch AMD 7640U laptop.
  • TH3P4G3.
  • 500W “be quiet!” working PSU and an RTX 2070 card connected to it.
  • Device manager shows I got Thunderbolt 3 and USB 4 Drivers but not Thunderbolt 4
  • Device manager “System Devices” does not show any Thunderbolt controllers

I have tried restarting the LapTop with both ports and the eGPU LEDs indicate STANDBY. Also have tried connecting to an intel laptop with thunderbolt 3 ports without luck.
A new Thunderbolt cable is on the way to rule that out.

When connecting the non-power delivery thunderbolt port to the laptop I hear a usb connection notification, the device-manager reloads but nothing appears. I have tried “Show hidden devices”.

When connecting the power delivery port to my laptop the connection notification sound does not play. The device manager is stuck in a loop reloading the items as if there was a hardware change.

Until now I haven’t been able to see anything under Display adapters.

More stuff I did:

  • Installed Thunderbolt Control Center (did not work)
  • The “about” page shows that I have no thunderbolt controller driver (did not work)
  • Tried installing Intels controller driver (did not work)
  • Can’t find a driver for AMD (there is none)

Any help would be nice. The only reason I got a Framework is because I could get the flexibility/upgradeability of a PC in a laptop, that includes gaming with a GPU.

Apparently it was a problem to do with the 8-pin “CPU” connector to enable power delivery through the eGPU which did not work.
Disconnected the 8-pin cable and connected the Thunderbolt cable to the non-power delivery port and everything works.
Also the power delivery port does not work. It gives me a green light and powers the GPU and PSU on and off in an endless loop.

Interesting. Under Linux I have no issue getting the TH3P4G3 working via its PD port - I get both power and a Thunderbolt link with any card working just fine - so it’s not an issue with the dock design itself.

1 Like

Are you on the beta bios?

While in my case the th3p4g3 did work on the power delivery port without it I am not sure I have ever tested it at less than full charge so the PD bug may not have triggered.

1 Like

Is this the beta BIOS?

Also my laptop does not start any USB devices. I have to disconnect and reconnect them after starting to get them to work. Any suggestions?