[Solved] TPM Interrupt on very startup

On startup booting (my Manjaro love) the no-splash text-lines says :
“TPM interrupt…”
How do I verify it ?
Am scare about a motherboard to change

I doing this
( Trusted Platform Module - ArchWiki )

$ journalctl -k --grep=tpm                                                                                                                       
DATE FrameworkPC kernel: efi: ACPI=0x43afe000 ACPI 2.0=0x43afe014 TPMFinalLog=0x43986000 SMBIOS=0x3f086000 MEMATTR=0x38dd9298 ESRT=0x38dda018 
DATE FrameworkPC kernel: ACPI: SSDT 0x0000000043ADC000 00077B (v02 INSYDE Tpm2Tabl 00001000 INTL 20200717)
DATE FrameworkPC kernel: ACPI: TPM2 0x0000000043ADB000 00004C (v04 INSYDE ADL-P-M  00000002 ACPI 00040000)
DATE FrameworkPC kernel: ACPI: Reserving TPM2 table memory at [mem 0x43adb000-0x43adb04b]
DATE FrameworkPC systemd[1]: systemd 251.8-1-manjaro running in system mode (+PAM +AUDIT -SELINUX -APPARMOR -IMA +SMACK +SECCOMP +GCRYPT +GNUTLS +OP>
DATE FrameworkPC kernel: tpm_tis NTC0702:00: 2.0 TPM (device-id 0xFC, rev-id 1)
DATE FrameworkPC kernel: tpm tpm0: [Firmware Bug]: TPM interrupt not working, polling instead

Do I need to do a BIOS thing ?

That log message is completely normal. You don’t need to do anything to fix it. All it means is that the TPM does not support “Interrupt Mode” (where it gives the computer information), so instead the computer needs to use “Polling Mode” (where the computer asks the TPM for new information every so often).

This is completely normal behavior and is not causing any problems. The post you quoted has nothing to do with this.


Ok, thanks for the advice and quick detailled answer.
I was searching on the web, dont finding any clue.
Thanks again
Thanks FW

PS : how do I close a Topic as “SOLVED” ? Do I need ? Thxs