[SOLVED] Unable to Install 3.17 BIOS update on Linux Mint 21.1

Framework Laptop: 11th Gen Intel, 13-inch
OS: Linux Mint 21.1

Hi all,

I am having some trouble with installing the latest 3.17 BIOS update on my Framework 11th Gen Intel. I’m on Linux Mint 21.1. I have followed the instructions for doing the Linux/Other/UEFI Shell update. However, upon booting up the USB it goes right to a GNU Grub Linux terminal and stops there. The instructions say the .nsh file will automatically start up, but this did not happen. Checking the message boards, I did see someone else had this issue and some people responding that their EFI partition may be full. I checked my EFI partition and I am only using about 2% of it, so it is not full. Any ideas on what I may be doing wrong?

As a sidenote: I did also try the Linux/LVFS method, but upon running the command (fwupdmgr enable-remote lvfs-testing) it went to a prompt to enter another command after it connected. Not sure if I was supposed to do anything after that. I also set the “DisableCapsule” update in the .conf file by removing the pound sign in front of it. Perhaps I needed to do something else.

I’m a Linux n00b, so forgive me.

Happy to help. Assuming we’re using the official guide: Framework Laptop BIOS and Driver Releases (11th Gen Intel® Core™)

Linux/Other/UEFI Shell update

3.17 BIOS EFI Shell Download

Instructions for EFI shell update:

  1. Extract contents of zip folder to a fat32 formatted usb drive.
  2. Disable secure boot in BIOS.
  3. Boot your system while (repeatedly) pressing F12 and boot from the thumb drive.
  4. Let startup.nsh run automatically.
  5. System will reboot, you can unplug the thumb drive.

Note, if it fails, reboot and keep trying in case of USB error.

Hi Matt,

Thanks so much for getting back to me. I have followed these instructions before, but I went through them again just to confirm.

  1. Confirmed. I have created a fat32 formatted USB Drive and then I have downloaded the zip file and extracted the contents to the fat32 formatted USB drive.
  2. Confirmed. I have checked this several times and it is listing as being Disabled when I go into Bios.
  3. With the USB plugged in I have turned on (or restarted – tried both) the computer, hit F12 multiple times, until I am greeted with the selection to either boot Linux Mint or to boot the USB. I choose the USB.
  4. There is no running of the .nsh file. Instead it takes me to a GNU Grub terminal where I can press TAB in order to see Grub commands.
  5. Have not gotten this far yet.

I’ve attempted this procedure before and after this post about 10 or so times at this point. My next thought was to try another USB drive, though my USB drive is fairly new and has not malfunctioned before.

Any other suggestions are appreciated! Thanks for the help.


Please post your contents of your drive ls /path/to/your/mounted/drive (for example ls /mnt/).

and please give us a lsblk -o NAME,FSTYPE /dev/<YourUsbDriveName> (for example lsblk -o NAME,FSTYPE /dev/sda)


Precisely, I think it is safe to double check the format of the USB drive. It might be better to just format the WHOLE thing and start from scratch. (this means ensuring there are no other partitions on it, as is the case when the drive was used as a Linux Live USB.) It seems like some kind of read failure is happening, and I would guess the drive is to blame.

It could also be the USB drive in question. Perhaps it is failing. If you have another to try out, that might be helpful.

1 Like

Success! I did a deeper formatting of the USB drive (as opposed to just right-clicking on it and formatting it). After that was done I followed the instructions and was successful in updating. Thanks for the help everyone!