Support for LG Ultrafine 5K monitor

I wonder if the display will work with the new AMD mainboard; I’m not planning on upgrading to it though.

@software_developer for getting your laptop to work with the monitor, disabling battery - did you do this in the bios? or in the bios and actual physical disconnect of the battery?

Also when the battery is disconnected, are you powering it through the display or do you have a larger power brick also connected? i.e. 100W or more.?

I am currently getting disconnects every day that I have to usually wait a few mins and reboot to fix.

Actual physical disconnect of the battery. No changes to the bios. (Can you do the disconnect just via the bios?)

Nope, I think I power with the standard Macbook Air USB-C charger which I believe is 35W.

Is this with a BIOS battery disconnect, or with physical battery disconnect, or without any BIOS changes. Without disconnecting the battery my connection is completely unreliable. I can even use a 95W charger but it’s still the same issue.

I have not tried, but there is an option in the bios with the new firmware that was meant for allowing you to run the motherboard by itself without the battery, but it may require a physical disconnect as well, I haven’t tried it.

The disconnect I mentioned was the USB-C losing connection to my LG 27 5k monitor, and it just keeps trying, cycles through the lights blink red on the side of the laptop and go off and on again, the only way to fix is for me to physically disconnect the USB-C cable to my monitor, wait a few mintues, reboot and try again, sometimes a few tries before it stabalizes.

I use my laptop occasionally as a laptop i.e. no monitor connected so a physical battery disconnect would be a pain to do every time, but I might give it a go.

It has been a frustrating process, that makes me just want to call it quits get a 4k monitor instead that I connect via DP or HDMI.

I understand, that’s why I haven’t been using my 5k monitor because I switch between using laptop as a laptop and using laptop with an external monitor at my desk.

But it would be cool to get another data point to see if the physical battery disconnect solves the unreliability/flakey problems when connecting to the LG UltraFine 5K. I think @oxplot said he tried disconnecting the battery and it didn’t do anything for him.

I’ll also update the firmware and see if using the BIOS battery disconnect works.

Edit: looks like there’s no BIOS update for 12th gen framework.

Forgot to mention, I’m on the Gen 11.

I tried physical battery disconnect and using the “Battery Disconnect” in the BIOS.

Now my LG Ultrafine 5K is working unreliably with either of these options. I think kernel updates may have made the situation worse :/.

I did however have an old debug kernel that I was using to try and investigate the issue further. When I switched to that, the display was a bit more reliable, both physical disconnect xor BIOS disconnect. However I think it’s a little worse with BIOS disconnect.

I really wanted this monitor to work, but I think I’ve exhausted the solution space. I think the Intel developers don’t seem to know how to fix this and don’t have a 5k monitor to test with. I also don’t know if this is a Framework/BIOS/Firmware issue. I think in the coming weeks I’ll probably give this display to my uncle so he can use with his Macbook M1 Pro which will undoubtedly support this monitor.

Hi all,
there were different versions of the monitor across time (see SO answer).
Could you people who got it working @Kent_Brockman and people who are giving up (@SoundBytes, @ software_developer, …?) or get a faulty experience (@ B_Hellman, …?) share with us the exact model you have as printed on the back?

Maybe by correlating success / failure with monitor TB controller (e.g. Alpine ridge vs Titan ridge?) apart from cable and Framework generation/bios we will start to see more clear?


PS. Thinking of buying one myself and utterly confused by the diversity of reports here…

I haven’t given up completely, it is frustrating process when it does go down as sometimes it is a full on crash, cannot recover, without hard boot.

@Alvaro_Tejero_Canter my model number from the back is 27MD5KL - purchased from Apple in 2020

@software_developer unplugged my battery and so far has been 8 hours… and it is running flawless! no disconnect. NO need for reboot. So I have a glorified laptop that is a desktop.

Did you try “Battery Disconnect” in the BIOS? Just wondering if that is a different experience to a physical disconnect.

Also what OS/distrubtion?

Physical battery disconnect, and disconnect in bios… the bios didn’t seem to have a toggle in the menu item of disconnect battery.

Bios version 3.17
Running Fedora 37

1 Like

I don’t recommend buying the LG Ultrafine 5K (or even 4K) to use with Intel Gen 11. It’s a glitchy mess and 3.17 BIOS nor the latest linux kernel has made any difference.

1 Like

@nrp It does not work fine at all. I’m happy to help diagnose it but as it currently stands, 5K model is pretty much unusable and the 4K one decides to stop working here and there and takes a full shutdown to make it work again.

I’ve also had this issue the display 5k monitor and laptop combination never worked via USB-C. I’ve reached out to tech-support no solution, sent back my laptop immediately.


Here is the display model number I was using: 38WN95C-W
Display Product code: 38WN95C - WY.AUSOMPN

Framework laptop: 11th Gen i5-1135G7
Kernel: 6.2.6
Distro: Pop OS 22.04 LTS

Cable: [Intel Certified] Cable Matters 40Gbps USB4 Thunderbolt 4 Cable 2.6ft with 8K Video and 100W Charging - 0.8m - Backwards Compatible with Thunderbolt 3 Cable and USB-C

Something to note: when I was testing it just now on BIOS 3.10, the display was constantly blacking out and restarting. I just updated to 3.17 and it is stable again.

Just want to note, that there are even worse problems with this display on the AMD Ryzen 7 7840U mainboard.

I have not done a thorough analysis yet, but it also seems to be power related in that with “lowish” (60% and lower ) battery and no other power source connected the display and power source cannot be used (no flickering, only errors in the kernel log).

It works (without any flickering and instantly) at least this time with sufficient battery, charging and a connected framework power source.

As soon as it does not charge from the framework charger anymore (80% battery as per firmware as configured in my BIOS), the display does not work. It still charges via the display though.

Using this same display with Ryzen 7840U on BIOS 3.03 and Fedora 39 - works pretty well. Charging and USB work OK and I get full resolution @120Hz. Only issue to speak of is random display whiting out

Sometimes it is most of the screen like this;

Other times it is half the screen. It will often flicker as I move the mouse.

I’m not using the Ultrafine 5K, but I can confirm that the 7840U with Ubuntu 22.04.3 works with the Apple XDR 32" at full 6K resolution (and scaling to 200%).

This is passing through the Caldigit Element Hub. I’m controlling the brightness using the Gnome extension vividshade -

@Kent_Brockman that looks like graphics corruption talked about here: [TRACKING] Graphical corruption in Fedora 39 (AMD 3.03 BIOS)