[SUPPORT] Laptop Not Charging

I’m using a 65w PD charger for my laptop and it is not charging at all. The light indicator on the sides are not shining at all when plugged in. I have tried all ports, I have tried 2 different chargers, I borrowed an omni 20+ portable charger which shows no current on their display going through. I’m not sure what happened, everything was fine in the morning. I’m wondering if the motherboard is somehow fried or something? I would really appreciate any input, I’m stressing really hard because I have final exams tomorrow; thankfully my important projects and data is backed up and I’m able to borrow another laptop from the school. Thank you.

Edit: I did follow this guide a few days ago: Linux battery life tuning, I followed “Tuning Idle power usage” while on Pop_OS if that is anything. I mean after I did that I had no issues for days until this so I don’t that was the problem but I’m no expert so I cannot say for certain.

Got it to work. Good old unplug and re-plug the battery

1 Like

Which battery? The main one?

I unplugged the main one, I let it sit for a couple of minutes and I plugged it back in.

The issue I’m seeing now is that it just happened again. I am hoping this is not going to continue to be a recurring problem. If so should I replace the battery?

Sounds more like a poor connection so best to contact support officially to be on the safe side, and I’m not sure there is an easy option for the user to purchase a battery, though no doubt they have some for warranty repairs.

1 Like

This would be my recommendation.


Recommended contacting support previously, marking solved as this needs to be a support case.

1 Like