The Power Adapter

I’ve used Nekteck in the past and they are pretty good, though I’ve had one die on me after a couple years of abuse as my night stand charger getting all sorts of things plugged into it.

1 Like

@RandomUser I like that. Looks like it’s only a little bigger than the Framework one too. My only hesitation is that Ravpower was pulled from Amazon for paying for reviews. Doesn’t mean it’s not good equipment, but it is a little concerning. Haven’t had any issues with it?

@Fraoch and @Ethan_Spoelstra Thanks for the other recommendations. Will check them out.

1 Like

I recently got UGREEN 100W USB C Multiport Charger - 4 Port USB Charging Station GaN Fast Charger Power Adapter.

Been happy with the brand in the past.

(Sorry, I don’t know how to attach the links the way others have been doing it.)

1 Like

With help from @Fraoch, I can now attach the link. Note that there is currently a coupon discount available. What I like about it is that it has 3 USB-C.

https://www.amazon.com/gp/product/B091Z6JNX4/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

3 Likes

That looks really interesting @njf. Thanks for sharing it. Poking around, I found this novel option too:

https://www.hypershop.com/products/hyperjuice-stackable-gan-100w-usbc-charger

USB-C (3) plus USB-A, 100W total, PD, and a pass-through AC plug that can be used to plug something else into, or stack a second one (or more) on top. They also have a 65W version that’s a little smaller, with only 3 ports (2 -C and 1 -A).

I don’t know much about the brand, but it could be worth checking out.

1 Like

So I did a little experimenting today. I have one of these power adapters on my desk, providing power to a few USB devices (monitor lamp, charging headphones, etc.):

Nice little unit. It also happens to have a 30W PD USB-C port on it, so I figured, why not see if it’ll charge my FW. Plugged it in and got a curious notification:

audio_adapter_error

So it’s not charging the laptop. I wouldn’t expect to charge it fast, given the 30W output, but my understanding was that the FW should charge with a 30W adapater, based on @nrp’s note above:

and indeed down to a 15W adapter, based on @Kieran_Levin’s post on the USB-C charging thread:

Has anyone else run into this issue with a non-dedicated PD adapter (or any adapter for that matter)? Or am I missing some hidden audio functionality in my Anker power adapter? :upside_down_face:

1 Like

Since Volta came up. I am happy with the USB C cables and magnetic connector I use from them. Volta has this Indiegogo campaign happening these days (11 days left): GIGA: The Ultimate Universal GaN Charger | Indiegogo

2 Likes

@mvw would this note on the product page for your charger help?

“If a port is not working properly, it may be because your device’s internal safely switch has been toggled. To reset, unplug all cables (including the power cable) for 5 minutes and try again.”

1 Like

Great find! Hopefully this fixes it for him.

This was an issue with the older Volta XL cables too, which lead to a lot of replacements because they didn’t have a resettable fuse. I think I have 4 or 5 that even my low draw phone thinks is an audio device due to a MacBook or Chromebook or something drawing too much power or an off spec charger doing something funky. The newer Volta Spark has been much better but I haven’t tried abusing it with as many different chargers since the pandemic started.

1 Like

Thanks @Frosty. I hadn’t seen that before. Unfortunately, that doesn’t seem to have helped. I had the system shut down and unplugged overnight, and just tried again. Same error. Also, no charging light when it’s not powered on. I’ve also tried with each different port, and different USB-C expansion cards, to no avail. Oh, and I’m using the USB-C cable provided with the Framework.

The Framework charger continues to work just fine, of course. I wonder if there’s something weird with the Anker one. Maybe the PD implementation isn’t to spec? I’ll also have to find another USB-C to USB-C cable to try.

1 Like

So… reading comprehension fail. I blame lack of sleep due to two young kiddos. :slight_smile:

Anyway, I mistook what @Frosty quoted as pertaining to the Framework, and not to the charger. Just realized that mistake, and unplugged the charger for 5 minutes. Plugged it back in, hooked up the laptop, and, lo and behold, it’s charging. LED light came on, and when powered on it’s showing a charging status in Windows (albeit with a slow charging indicator, as expected due to the 30W limit on the Anker).

Mystery solved. I mean, mostly. Still don’t know why it was showing up as an audio device. Nevertheless, good to have an alternative for power when the laptop is on my desk.

Thanks for the help everyone.

7 Likes

Awesome! Glad it helped!

2 Likes

As a side question, what did Lenovo do to earn the coughs?

Possibly the fact that they invent a new docking connector every couple years and have also changed their power connector using non-barrel styles with different pinouts every couple of years as well.

Sure they were reversible… but I challenge you to try plugging in a barrel connector wrong in any orientation.

3 Likes

@Ethan_Spoelstra that makes sense, thank you.

After having my Framework for about a month, I’m starting to push it more and more and have recently been doing some gaming with it. I have been playing GTA V and I have noticed that the Framework power adapter doesn’t seem to provide enough juice to keep the battery from discharging.

The battery goes down to 95% after about an hour of gaming. I have the DIY edition with the i7 1165, 64GB of RAM and the 1TB WD850 SSD. I was also connected to a 4K display and a secondary 1080p.

I know this is a pretty extreme case, with the CPU and GPU at close to 100% utilization, an almost maxed out configuration and sending data to external displays, but I feel like the charger should have been designed to cope with this kind of scenario, right?

Best.

6 Likes

This slight discharge happens on Dell Precision laptops even with 130-180w power supplies because as your battery reaches close to 100% it is harder to “push” more charge in and the battery heats up, not to mention with the high usage you are subjecting it to the system is also adding additional heat, so it is possible that it is halting charging for a bit to let the battery cool down to safe levels before charging it again.

3 Likes

Got my right angle power plug in, and it works great. Less bulk in my bag.

I’m leaving the Framework power cord at my desk. Eventually I plan to have 2 bricks.

6 Likes

@ImaxinarDM Nice! I got one too. Works great. Like you, I think I’ll keep the FW adapter at home and grab one of the aforementioned (or similar) combo ones for travel

1 Like

No, eventually I am going to buy another Framework brick for travel. I want to support the company and the Marketplace as much as possible.

I really don’t need a combo unit as the laptop can be powered by the Framework brick and then my phone will charge from the laptop.

7 Likes