Touch-pad physical click not working

Hi Folks,

I just received the DIY version of the laptop, set it up, and the physical click doesn’t seem to work. Soft-touch clicks work (single taps), but if I press down for a physical click, nothing. I’ve re-seated all the wiring/cables going to the touch-pad, but no physical clicks register.

I’m running Debian, but I don’t think this is a software/OS issue.

Any ideas?




Here are a few threads about trackpad issues. You might find your answer in one of these -


I have this issue as well.

It was working fine but then it stopped working at some point.
Happens on both Linux and Windows, seems to be a hardware issue.
Their suggested fix (pushing down hard) seems to have worked sometimes for left click, but not right click. Also, it doesn’t work for left click always.


It was working fine but then it stopped working at some point.
Happens on both Linux and Windows, seems to be a hardware issue.
Their suggested fix (pushing down hard) seems to have worked sometimes for left click, but not right click. Also, it doesn’t work for left click always.

My laptop is behaving the exact same way, the left click was working fine before and now more recently it only works if I push incredibly hard. Is there a known way to fix this?

I am on Windows 10, not sure if this is a hardware or a software thing. But I’m guessing it’s hardware.

It’s hardware. My trackpad click/press has now stopped working in both Windows 10 and PopOS. Will have to ask support to send a replacement I guess.

1 Like

Update: I was able to get the physical click on the trackpad working again. I just pressed hard on the right side, and the middle again, and on the right side again. And this seems to have had an effect, because the physical click is now working everywhere on the pad. I’m guessing something was stuck under there.


yeah oddly enough it started working again for me just now.

i think it has something to do with how i pick it up. i picked it up with one hand on the right side with the laptop opened up and i felt a mouse like click. after that it started working again.

i’d love to understand what’s going on better in case it happens again in the future.

1 Like

Running into the same problem myself. It’s really unfortunate.

The hard presses mentioned above helped, but the touch pad still intermittently shorts out.

@Demiurge You may try to re-align the touch pad. You may follow this guide.

Link: Touchpad Rubbing Fix Guide - Framework Guides

My right click is not working. Is it Brents idea that i should do?

It turned out that the cable was not correctly inserted in the motherboard.

Now it’s working fine.

1 Like

I’m not sure if this is the exact same issue as other have been having here, but I’ve been having some problems with the touch pad lately. For some time now, two finger scrolling with just stop working. A simple reboot always fixes it but it’d be nice to know what’s causing it and find a permanent solution. Most recently I’ve been having intermittent issues with physical single click, double click and right click lagging terribly. Any idea of what could be causing these issues?

Having a similar issue myself. Ubuntu Budgie 22.04. Trackpad works fine for scrolling, gestures, and tap-to-click (both left and right click). Physical left click seems to work fine, but physical right click does not. I’ve disabled PS/2 mode in BIOS, and tried the suggested firm presses. Everything works fine in Windows, just not in Linux. Strangely, if I turn off tap-to-click in settings, physical right click works. But I really like tap-to-click, so I don’t want to do that. Seems odd that it all works except physical right click.

I was also completely unable to get physical clicks to register, whether pressing middle, left, right, etc. However, I was able to partially fix it:

Hi Support Team -

The no physical click issue was observed on both BIOS 3.09 and BIOS 3.10.

No change in behavior with PS/2 Emulation on versus off.

I did follow the touchpad rubbing guide here: Touchpad Rubbing Fix Guide - Framework Guides

At step 5, instead of adjusting the touchpad toward the keyboard, I simply tightened the two screws holding the bracket. Each was able to move about 5/6 of a turn towards tighter. This created some improvement, where I could physically click at the very middle of the clickpad only, with about an 80% recognition rate.

So I went back into the input cover, and looked more carefully at this bracket. I noted the following defects: the right hand alignment post appears to be poorly formed compared to the left hand one. The lefthand one is a crisp, sharp cross shape. The bracket goes easily over the lefthand alignment post, but fits poorly over the righthand one. The right hand one tries to force the bracket to be too close to the keyboard, and not well vertically captured to the clickpad itself. By very carefully holding the bracket both down and away from the keyboard, I was able to get the right hand side of the bracket much more vertically captured. In this configuration, I could physically click the middle 2/3rds of the clickpad with about 90% capture rate, but only about 10% of the time would physical clicks outside of this area be registered.

Third attempt, I bent forward the two small tabs on the bracket, as I had seen suggested by Framework Community members, but dis-recommended by Framework staff. However, bending these tabs up meant that physical clicks are now registered all the way out to the touchpad edges, but with a huge amount of slop/play still. Click register is rate is nearly 100% in the middle, and maybe 60% beyond 2/3rds from the middle.

Asking support to sent a replacement input cover due to the mis-manufactured alignment post. We will see what they say.

1 Like

yeah i’ve been having these issues as well and its the single biggest flaw in this laptop which is otherwise amazing. Its quite aggregating though as i prefer using a touchpad mechanically clicking versus tapping. I’ve done the rubbing guide as well which did help but hasn’t fully solved the issue and the mechanical click flaw randomly decides to register which is very annoying. I know this is a company just getting off the ground but they honestly should look at fixing this issue for customers rather than kicking the can down the road with “fixes” that don’t fully solve the problem.

Last night, after repeatedly exchanging expansion cards, I saw the touchpad physical click didn’t work completely.

My environment is

  • Intel 11th Gen Batch 2
  • BIOS: 3.10
  • OS: Fedora 36.

I rebooted OS a few times and upgraded the software by sudo dnf upgrade --refresh (now the kernel version is 6.0.5-200.fc36.x86_64). But it didn’t work even after that at that time. However, this morning, after waking up the laptop from sleep mode: s2idle, the touchpad physical click started working again at 100% now. I really don’t know what’s the cause and what happened.

That’s very similar to what I saw with my 11th Gen Batch 2. I ran Linux on it from the very beginning, and when the touchpad was flaky, I thought it was Linux’s fault. Sometimes the physical click completely stopped working … But I would reboot or time would pass and it would start working again.

I bought a new Trackpad because Framework’s “support” said I was not eligible for a replacement since I about 40 days past 1 year warranty. The new trackpad is awesome, it’s better in everyway… seriously, it’s buttery smooth in Linux and Windows.

But Framework’s communication on this issue has been quite poor. I’m only commenting in this thread because all the threads I saw seemed like this one … Gosh, maybe there is a BIOS setting? Maybe it’s a Gnome tweak?? Maybe it’s trackpad screws???

Maybe that was true … But some of the first trackpads were crappy, that’s all.


I m using a 3-year-old Lenovo Thinkpad, It was working perfectly but for 3 days right click is not working properly, just three days back I updated the window so I don’t know if it’s a hardware issue or a software issue.
Please help it out.

Device specifications are:

Core i5 6200U / 2.3 GHz.
Win 10 Pro-64-bit.
128 GB SSD.

You meant you bought this one: Framework | Touchpad Kit or you bought an external trackpad from 3rd party company?

I bought the kit from Framework.

1 Like