Touchpad clicking issues - how to disable physical click

Hi everyone, I just got my new Framework 13, having ordered it as soon as orders opened in Italy and I love it.
The keyboard is stunning, far exceeding my expectations, BUT the touchpad is already giving me more than a headache.

I find that it registers clicks with the slightest increase of pressure even without ever lifting my fingers from it. Otherwise it does its job with swiping, gestures and taps.

It works much better avoiding physical clicks completely, so I was wondering if there is a software fix in order to disable them, since it is possible to disable taps as clicks in Windows 11 settings (but I need the other way around, so I want to disable physical clicks and rely instead on taps).

I already tried the firm pressure on the bottom center part of the touchpad, but this only temporarily fixes the problem.

not sure about a software solution, but to get rid of the physical click I stuck small bits of paper between the trackpad and the PCB with the button that is the “physical click” the trackpad no longer physical clicks unless I press on it REALLY hard.


The clicks of my touchpad were always inserted because the lower body is slightly curved (see photo) so I inserted a small piece of pastica, cut out of a yogurt pot, between the touchpad and the metal plate that fixes it. I also had to bend the metal plate a bit before mounting it. Now it works.

1 Like

I have the opposite issue. My touchpad sometimes resists all my attempts to click.

I cannot tell if it is a hardware or configuration issue. (fyi: Ubuntu 22.04.3 LTS) I occasionally switch the trackpad behavior (using Tweaks) to play minecraft. Clicking on different places in the trackpad seems to be at least part of the problem. Sometimes I can get a left-click only on the extreme left edge. Or is it that when I press the fifth time, I am pushing harder?


Update: the solution proposed by @Corrado worked like a charm. Now there are no clicks that are accidentally registered and the touchpad works really well overall now.

Thanks to @Corrado for bringing up this solution and for explaining it very precisely.