[TRACKING] Charger connect and disconnect in a 2second Loop after wake up from sleep | GaN adaptative mini power

It started with my 14 month Ugreen Gan adaptative mini power 65W charger that I used without a problem with thinkpad E590.
It started to unconnect then reconnect, which is normal behaviour when you plug two device to the multi USB power supply.
Also it does it One time , I guess to adapt the power but then it does it in a LOOP every 2 seconds it disconnect and connect power !
So I ordered an Anker power supply and it does the same thing after wakeup from sleep when I open the lead of my laptop.
It goes away with the anker when I disconnect physically the cable and reconnect, so easy workaround! But I am concerned it might end like the Ugree not working anymore

Previous Ugreen not working anymore with FW but still working with thinkpad E590


Check the video.
For the first time I waited 20 seconds while snapping the video and after doing on/off 15 times it stops and just charges ! Usually my workaround is to unplug the power.

Update 30 minutes later it came again, so this time I unplugged the usb C from the laptop and replugged as usuall. I suppose that it will work as every morning now :wink:

1 Like

I still have this power connexion loop in the morning, when back from stanby mode (closing the lead).
I tried to switsh from one port to the other side directely on the motherboard (no dongle) I have the exact same behaviour :

  • power loop on the top left
  • after 15 secondes change to bottom right mother board usb c = power loop too

This morning after trying this I couldn t even get the computer to stop looping. Normally plugging unplugging get it back.
I had to do a complet reboot, now its back.

I have to confirm that but this morning the problem is gone for the first time in 2 monthes !
I updated to kernel 6.0.7 on ubuntu mate 22.04

Still buging. Suprised no one else has this on ubuntu 22.04.
I feel like the HDMI module might increase the phenomenone… I had 5o shutdown the computer to get it to charge lately.
Looki g forward to the BIOS update

Hi @Iann_C, this might be tricky to diagnose as I am using the charger provided by Framework exclusively. I tried looking at the video, but it does not appear to be available.

Three questions:

  • Is this to power the Framework only or are you also powering other devices at the same time?

  • Which expansion cards are in use and have you tried all but USB C only?

  • Both of these after market plugs have USB C and USB A connections. At the plug(s), are they connected USB C or with the USB A end?

Hi @Matt_Hartley ,
I didn t get notice , sorry for the late reply.
It s now 3 monthes that I have the issue, none of the high end chargers on the market work for me.
Please read my answers inline :

Three questions:

  • Is this to power the Framework only or are you also powering other devices at the same time?
    =>When powering only the framework it does exactely the same.

  • Which expansion cards are in use and have you tried all but USB C only?
    => I have only USB C and USB A dongle and it does the same. Have not tried to remove them all.

  • Both of these after market plugs have USB C and USB A connections. At the plug(s), are they connected USB C or with the USB A end?
    => I am using USB C to USB C ugreen 60W cable (I have another white 30W for phone that I never use with the FW) directely plugged to the Computer icone power output:



  • kernel 6.0.9 doesn t improve anything
  • ANKER and UGREEN are the charger with the better quality on the market. Those are not low end chargers and most users are very happy with them in reviews
  • Again this ONLY happen when coming back from suspend.
  • It is very consistent, every morning I get it when opening the lid of my laptop. I then have to:
    change USB port,
    try removing the dongles…kinda black magic…
    or sometimes to reboot the computer.
  • Even if the lid is not open, if I plug the power while asleep it will loop( I see the light on / off)
  • It has to bee in deep sleep for some time… like ti does it in the morning or after lunch :wink:
    To me it looks like some kind of firmeware bug in FW. Where it is not 100% compatible with USB C charger protocols… a little glitch in comunication between charger and laptop in the protocol negociation and it loop in trying to negociat proper power delivery. Like OK lets do it 60W …o no lets do it 30W o no lets do it 60W …

Thanks for getting back to me with the details. Absolutely agree, they are quality chargers (I’ve owned both brands in the past, excellent stuff).

I want to verify a few things with our hardware guys (adapters and output are not my strongest area), so I’m going to take your details and check on a few things.

Specifically, we know it appears to meet the minimum wattage (60), but does it meet these requirements across the board?

So I’m going to double check with our hardware team.


I think I might have found it…
I am not sure at all , since it more like a ghost hunting.
For recall none of the charger ANKER and UGREEN that work with my thinkpad E590 work with Frawemwork laptop… I doubt that both charger are faulty…but might happen x)
To make things more clear my charger works 99% of the time including when playing a game for 2 hours…
But the FW laptop loop when back from suspend.

I can send you a video I just did in private message or email.

I always have the USB A and USB C plugged in not my HDMI.

I thought that there is no way the most simple dongle USB A would not make any problem…
Apparentely this morning after removing USB A it started to work again. But it might aswell be playing with the power button that make it work. Usually I get it back to work without unpluggin USB A… so USB A might be a part of the problem…but not the wall problem

Update :
I am now running only the USB C with kernel 5.15 it did exactely the same thing.
I am now running with NO expension card at all.
I have the power directely plugged in the motherboard.
I doubt its going to work.
Actually over time I believe it is getting worse, now I have disconnection more often it seems

Update 12/12/22:
I am in africa since 3 weeks. Its 30 degrees here…juste for info.
It now started to get worse , I have charger loop 10 times a day ! My anker charger is 3 month old.
So I tried everything I could think…I have no way to buy a new charger or new laptop!
I am just using a 35W 1M cable instead of the 2M UGREEN 60W…and it stopped for now the charger looping …for now ! to be continued :smiley:
removed this one :

1 Like

Just for the record while I am not experiencing as tight of a loop with my Anker 737 I am experiencing a case of the battery discharging while plugged in. It tends to show that it is not charging for a while and then the charger indicator comes back on. I am running Fedora 37 on the latest kernel (6.0.11), but it just started doing this after I performed some maintenance (applied Honeywell PTM7950 to the cpu/very nice easy to apply and while I had a near perfect paste job with Thermal Grizzly Kryonaut my idle temps are 3C lower now). I have observed similar behavior before beginning after anytime I would perform a battery disconnnect to perform maintenance (I have done so to replace the hinges with the 4.0KG ones previously). Last time it required a near complete battery drain for it to begin behaving properly again.

I have an all USB-C expansion card setup, this happens whether it is plugged into a dock or a charger, and whether it is under load or idle. This is not only happening after suspend. I also suspect this is firmware related and I am hopeful the new BIOS will fix this. It should not require a near complete drain to reset whatever internal mechanism this is buggering up. Also the Anker should satisfy the requirements posted as it does provide 20v charging.

I’m leaning toward firmware myself here as the provided charger works fine. If it’s a firmware issue, the best path forward would be to use the provided charger that is offered by Framework.

I’d definitely need this same set of chargers to replicate.

1 Like

Hi @Matt_Hartley ,
After 3 monthes I believe I found it.
It seems it is the 2m Ugree, cable that is somehow not recognized by framework.

I have used for 2 days a 1M cable that was shipped with my Pixel 4A, that shouldn t work by the way since it is not rated 60W… BUt the issue for now disapeared!
I will confirme later on this forum if it confirmes to work.

THe thing is now I have to be at 1M from a power plug :frowning:

It was the Ugreen 2m cable that was dying on me progressively after only 17 months.
It began to fail even charging my phone.
Now on a 1m cable nor problem.
Cannot change the title of this thread to closed :frowning:
Case closed :wink:

1 Like

Glad to hear this, marked solved.

Hi! Unfortunately I have the same problem, with Anker 735 charger and Anker 765 cable, charging a Framework 13" with AMD Ryzen™ 7 7840U. Latest BIOS version, firmware upgraded to latest version.

Hi Tommi,

This may be a compatibility issue with the power supplies being used. Do you have access to a Framework power charger as a comparison?

Thanks for your reply, @Matt_Hartley!

Unfortunately, this is the only charging equipment I have. I did not expect this kind of compatibility issues, or I would have considered getting it!

Ah, understood. Let’s get you into a ticket. We can drill down on this from there.

1 Like

Done! Thanks.

1 Like

Sorry @Matt_Hartley, I got no feedback about this ticket… could you confirm you received it successfully?