[TRACKING] Fingerprint reader failing to register on 13th gen

:white_check_mark: Done, still getting same error & state.

Using the approach found here, did you try reinstalling the cab?

sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab

I have updated the echo to quirks command for those who inadvertently ran it multiple times, thus, spamming the quirks file.

file="/usr/share/fwupd/quirks.d/goodixmoc.quirk"; sudo sed -i '/\[USB\\VID_27C6&PID_609C\]/d' "$file"; sudo sed -i '/Plugin = goodixmoc/d' "$file"; echo -e '[USB\VID_27C6&PID_609C]\nPlugin = goodixmoc' | sudo tee -a "$file" > /dev/null

The above command will put your quirks file to the correct state and deletes anything in that file at all, putting it to the correct state with an empty space, then the two correct lines only - this for those of you on Ubuntu and those with your fwupdmgr --version is older than 1.8.8.

If you suspect you’ve run into this, run the above command to correct the quirks file, then reboot, then run

sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab


After the first time I tried to install the firmware with the sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab command, I got the transfer error, and when I checked the version it still said that there was no device found. But inmediatly trying a second time (without restarting or using another line) it completed succesfully and when I checked the version got the correct version.

After that I restarted and the fingerprint reader is now working correctly!

Okay folks, I have news on this front (good news) here soon, so watch this forum as I will be linking to the new post.

If you are have not been able to update your reader yet, please see this post.

1 Like

@Matt_Hartley Oy vey! Ran the updated quirks file replacement command (and confirmed with cat after), and also re-installed the cab file. Reboot. Still no dice.

With the update essentially do the same thing, or will that have additional pieces that may solve my issues?

Does the placement of the cab file matter? If so, is there a particular location that you’d recommend?

Boy, at this point as we cannot replicate this failure for it cooperating, I’d try the above linked beta for LVFS.

Hi @Matt_Hartley,

Been waiting for a fix for while. Thanks for all your efforts. So I’ve tried following the steps for LVFS and manual update but my Goodix reader is no longer recognised. Never tried a fw update before and never booted Windows. Yes, tried rebooting - but no joy. Any next step troubleshooting ideas??? (Yes was recognised previously and not opened the 13th gen DIY body since).

sudo fwupdtool get-devices --plugins goodixmoc                                                                   23:52:36
Loading…                 [***************************************]
No detected devices

Did you reboot afterwards and this was with a 13th Gen Intel Framework?

Thanks - a Goodix device doesn’t even show up in fwupdmgr get-devices, before or after reboot so there’s nothing for the fw fix to update… And yes, 13th Gen Intel DIY, UK, arrived in June I think.

Goodix info was previously obtained here back in July. (Not opened the laptop since): [TRACKING] Fingerprint reader failing to register on 13th gen - #86 by Garfo


Thanks to Juan_Andres instructions here I managed to get it to finally work ([TRACKING] Fingerprint reader failing to register on 13th gen - #165 by juan_andres). <3

TBH feels like you’re shooting in the dark as the feedback from the terminal leads you to beleive that devices are either 1). Not available (when in fact they are!), and 2). Devices are not applying the update (when in fact they are!!). Frankly bonkers - but for those reading this - pls don’t give up and perservere even with eyes closed!.. :slight_smile: (Hopefully Framework can make this process feedback a little more intuative and friendly in time, and/or choose a better, and quite reasonably - less buggy, fingerprint hardware vendor… And then give the old proverbial “Finger” to good-ole Goodix!). :wink:

1 Like

Does it show up in lsusb?

lsusb | grep Goodix

I don’t know too much about computers in general so it was hard to tell if there is a fix for the fingerprint reader on ubuntu. Can someone help me please?
Thank you!

Would need some more details from you to help:

1 Like

Fingerprint reader guides updated.

Emphasis has been placed on using the cab file approach as we are waiting for a verdict on the LVFS testing.


thank you so much, lifesaver!

I was unable to use the sensor for 1Password until running that update command to enable it.

If it’s possible, I think it could be worth making 1 document specifically for 7040 post ubuntu / fedora setup with all the common things instead of having to click into a lot of these different red notes and pages.

FWIW, the fingerprint firmware update guide needs to be updated: Secure Boot has to be turned off for fwupd to work.

For me, using Ubuntu 22.04 on a DIY AMD machine, fwupd would lock up and give me nothing using the guides linked above. When I reinstalled 22.04 with Secure Boot off, suddenly it all started acting similarly to what is shown in the guides. Still needed the reboots and I got an error message at one point, but it basically worked where it hadn’t before.

I didn’t try it in Windows or any other OS.

Corrected. Thanks for the heads up.

1 Like

Appreciate the feedback and it’s something that when things settle down, I am actively looking into finding a happy medium to address this. If it was me, I’d do the whole thing in markdown. But that is not how our guides work, so I had to get creative.

Our Guides platform is designed for words and pictures. Code however, not so much. While we can embed gist files, it isn’t easier to follow and historically, steps were being skipped entirely.

Instead we use a step by step process that if followed, provides for a relatively smooth setup experience. That said, we have unified our fingerprint guide into one unit at Step 8 for those with 13th gen and AMD 7040 series.

Step 9 has to cater to multiple platforms, therefore, code respecting guides on Github were linked in a simply bullet point layout. Also allows folks to submit their own changes vs random comments on the guides.

We tried a single guide early on and it was a problem as there were lots of non-formatted code bits and other elements that didn’t have a clear flow. It created problems vs solving them.