[TRACKING] Fingerprint reader failing to register on 13th gen

Thanks - a Goodix device doesn’t even show up in fwupdmgr get-devices, before or after reboot so there’s nothing for the fw fix to update… And yes, 13th Gen Intel DIY, UK, arrived in June I think.

Goodix info was previously obtained here back in July. (Not opened the laptop since): [TRACKING] Fingerprint reader failing to register on 13th gen - #86 by Garfo


Thanks to Juan_Andres instructions here I managed to get it to finally work ([TRACKING] Fingerprint reader failing to register on 13th gen - #165 by juan_andres). <3

TBH feels like you’re shooting in the dark as the feedback from the terminal leads you to beleive that devices are either 1). Not available (when in fact they are!), and 2). Devices are not applying the update (when in fact they are!!). Frankly bonkers - but for those reading this - pls don’t give up and perservere even with eyes closed!.. :slight_smile: (Hopefully Framework can make this process feedback a little more intuative and friendly in time, and/or choose a better, and quite reasonably - less buggy, fingerprint hardware vendor… And then give the old proverbial “Finger” to good-ole Goodix!). :wink:

1 Like

Does it show up in lsusb?

lsusb | grep Goodix

I don’t know too much about computers in general so it was hard to tell if there is a fix for the fingerprint reader on ubuntu. Can someone help me please?
Thank you!

Would need some more details from you to help:

1 Like

Fingerprint reader guides updated.

Emphasis has been placed on using the cab file approach as we are waiting for a verdict on the LVFS testing.


thank you so much, lifesaver!

I was unable to use the sensor for 1Password until running that update command to enable it.

If it’s possible, I think it could be worth making 1 document specifically for 7040 post ubuntu / fedora setup with all the common things instead of having to click into a lot of these different red notes and pages.

FWIW, the fingerprint firmware update guide needs to be updated: Secure Boot has to be turned off for fwupd to work.

For me, using Ubuntu 22.04 on a DIY AMD machine, fwupd would lock up and give me nothing using the guides linked above. When I reinstalled 22.04 with Secure Boot off, suddenly it all started acting similarly to what is shown in the guides. Still needed the reboots and I got an error message at one point, but it basically worked where it hadn’t before.

I didn’t try it in Windows or any other OS.

Corrected. Thanks for the heads up.

1 Like

Appreciate the feedback and it’s something that when things settle down, I am actively looking into finding a happy medium to address this. If it was me, I’d do the whole thing in markdown. But that is not how our guides work, so I had to get creative.

Our Guides platform is designed for words and pictures. Code however, not so much. While we can embed gist files, it isn’t easier to follow and historically, steps were being skipped entirely.

Instead we use a step by step process that if followed, provides for a relatively smooth setup experience. That said, we have unified our fingerprint guide into one unit at Step 8 for those with 13th gen and AMD 7040 series.

Step 9 has to cater to multiple platforms, therefore, code respecting guides on Github were linked in a simply bullet point layout. Also allows folks to submit their own changes vs random comments on the guides.

We tried a single guide early on and it was a problem as there were lots of non-formatted code bits and other elements that didn’t have a clear flow. It created problems vs solving them.


So step 8 never worked and I wasted hours and hours until installing windows, all because I had secure boot on.

According to some other users who had the fwupd stuff hang indefinitely, the other user tracked it down to us having that feature on… not sure if the docs mention not being able to use secure boot, if they did it’s something I missed.

It’s too bad the platform doesn’t let you tag sections, then you could have a device selector at the top that just shows / hides relevant stuff

This was an error I have resolved in the guide today, sorry for any confusion there.

I heart markdown for just this reason. :slight_smile: Yeah, I agree, room for improvement. It’s something I am noodling over while living within the confines of our existing platforms.

Note that updating-reader-firmware-ryzen-7040 - which I see as updated a mere 2h50m ago - has a simple typo in the cab download command (looks like a piece of markdown snuck into it) - FYI

1 Like

Welcome to the community!

Ugh, yes, excellent catch - going a million miles a minute, completely missed this. Corrected it: wget https://github.com/FrameworkComputer/linux-docs/raw/main/goodix-moc-609c-v01000330.cab

1 Like

BTW - this updated set worked: I had to run the fwupdtool install twice before it succeeded (I’m not sure if - the 2nd time - adding “./” pathing to the front of the cab filename was significant or not, but there you go).

I’ve just scanned fingertips (I’m on Ubuntu 22.04) - about to see if it works in practice. — Yes, works great (really fast response).

1 Like

Fantastic! Glad to hear it.

1 Like

I got a new Ryzen Framework, and can confirm running the firmware downgrade mentioned in this thread works.

When I tried following the Knowledgebase article on my AMD 13" , I ended up getting this as an error

 $ sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab        
Decompressing…           [ -                                     ]
generic GUID requires a CHID, child, parent or sibling requirement

Running get-details on the cab file results in:

 $ sudo fwupdtool get-details goodix-moc-609c-v01000330.cab                                      Decompressing…           [ -                                     ]
Framework Laptop 13 (AMD Ryzen 7040Series)
└─Fingerprint Sensor:
  │   Device ID:          23ec719b6aabc2d2dac5176c232f0da7a21881b0
  │   Summary:            Match-On-Chip fingerprint sensor
  │   Description:
  │   Updating the firmware on your fingerprint device improves performance and adds new features.
  │   Current version:    01000320
  │   Vendor:             Goodix (USB:0x27C6)
  │   Install Duration:   10 seconds
  │   Serial Number:      UIDXXXXXXXX_XXXX_MOC_B0
  │   Update Error:       generic GUID requires a CHID, child, parent or sibling requirement
  │   GUID:               1e8c8470-a49c-571a-82fd-19c9fa32b8c3 ← USB\VID_27C6&PID_609C
  │   Device Flags:       • Device can recover flash failures
  │                       • Updatable
  │                       • Signed Payload
  └─Fingerprint Sensor Upgrade Device Update:
        New version:      01000330
        Summary:          Firmware for the Goodix Fingerprint Print Moc Sensor
        License:          Proprietary
        Size:             193.4 kB
        Urgency:          Medium
        Vendor:           Goodix
        Release Flags:    • Trusted payload
                          • Trusted metadata
        Second version.
        Checksum:         dbad86a5f5d44968099f0ad633d0dab28b2d9eddbb2d1276dc5d958b155943b6

seems like my driver version is stuck on 01000320 no matter what I do

Following the KB worked for me on my AMD Framework 13: Updating Fingerprint Reader Firmware on Linux for 13th Gen and AMD Ryzen 7040 Series Laptops


Delighted to hear it, we revamped it a bit to make it clearer.