[TRACKING] Fingerprint reader failing to register on 13th gen

Also, those affected - can I verify if all those affected are on DIY configurations vs Windows pre-builts converted to Linux?

Thanks

Mine is a DIY configuration.

Windows conflicts with a security/privacy policy - And because of that, the Windows/VM resolution is not a viable resolution for me.

Understood, thank you.

Just to confirm several of us have had success using a VM in Boxes to save having to install in a USB or onto your disk and just passing the fingerprint reader through. This was super easy and I could just delete the VM and instantly setup my fingerprint in Linux, no reboot even required.

DIY for me as well

How is this supposed to work exactly? I am running Windows 11 in Boxes with USB passthrough enabled. I receive the following message in a cmd window:

Starting Driver Install
No Instances(s) Available.
"This Framework driver bundle is designed to run on 13th Gen Intel Core Mainboards only!"
Press any key to continue . . .

Am I missing something that allows the Boxes installation to pass this check?

Ah sorry, you want to run just the Goodix driver installer on it’s own. To do this you can just extract the bundle file with 7zip and it should be in the root.

2 Likes

This worked!

Unfortunately, I’m on Kubuntu which uses SDDM by default, and it looks like it won’t have proper support for both fingerprint and password until this PR #1220 is merged. I’ll either wait it out, or try another display manager. Maybe by the time SDDM is ready, a fix will be in for MK_EVK vs APP as well :sweat_smile:

I can confirm that @Matt_Hartley’s method worked for me using Gnome Boxes + Windows 11.

Following along as I also have:

  • Fedora 38
  • Brand new Framework 13 DIY edition, 13th gen Intel
  • Tested with GUI, CLI, etc
  • Have not downgraded the firmware yet using boxes

*** One More Note: I own no windows boxes, cannot create media that works to boot into windows(the ISO does not recognize the hard drives). And as far as I can tell you cannot run Windows 11 in Boxes?

├─Fingerprint Sensor:
│     Device ID:          4295296d98b3ba38c72f6baa33d24f03a1d428f6
│     Summary:            Match-On-Chip fingerprint sensor
│     Current version:    01000320
│     Vendor:             Goodix (USB:0x27C6)
│     Install Duration:   10 seconds
│     Serial Number:      UIDXXXXXXXX_XXXX_MOC_B0
│     GUIDs:              1e8c8470-a49c-571a-82fd-19c9fa32b8c3 ← USB\VID_27C6&PID_609C
│                         34def4c7-9461-5a32-a945-5dde0ca57d88 ← USB\VID_27C6&PID_609C&REV_0100
│     Device Flags:       • Updatable
│                         • Device can recover flash failures
│                         • Signed Payload

Bus 003 Device 003: ID 27c6:609c Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          239 Miscellaneous Device
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x27c6 Shenzhen Goodix Technology Co.,Ltd.
  idProduct          0x609c 
  bcdDevice            1.00
  iManufacturer           1 Goodix Technology Co., Ltd.
  iProduct                2 Goodix USB2.0 MISC
  iSerial                 3 UIDXXXXXXXX_XXXX_MOC_B0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0020
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          3 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 
      iInterface              4 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0

1 Like

Installed Windows 10 on Boxes from downloaded .iso
Connect the reader through USB Settings in Boxes
Download the windows drivers from framework
Extract them all with 7zip(open the .exe in 7zip, then hit extract)
Run the Goodix driver installation package(not the whole framework driver package, just the extracted goodix executable)
Reboot
Register fingerprints
Works

2 Likes

I was able to install Windows 11 in Boxes, though it took some work (mostly regedit). Glad to know Win10 works with the driver/firmware update as well.

1 Like

I just received my DIY Framework 13 installed the latest Ubuntu LTS OS and when I go to add my fingerprint in settings (it won’t even let me click on “Scan new fingerprint”), it tells me: “Failed to claim fingerprint device Goodix MOC Fingerprint Sensor. Failed to communicate with the fingerprint reader.” I haven’t seen any posts regarding this specific error message, so I would appreciate any help with this!

13th gen ONLY and those with older Framework 13 generations that have received input cover replacements only.

Greetings all,

We have identified the issue with this batch for fingerprint readers and the firmware team has informed me of a firmware update forthcoming via LVFS. We do not have specific dates on release because we’re testing everything, so I will be revisiting this ticket with updates next week.

Note, this is a very high priority for us and we are actively working on this asap while also making sure we test the update appropriately.

I appreciate your continued patience.

Let’s keep this topic here and not creating a ton of new threads. Makes it more challenging to share updates with everyone.

8 Likes

I’m not sure I entirely agree with re-naming this thread, as the same problem will occur if you replace the fingerprint ready on any FW13, not just with new 13th gen laptops. The thread was created before 13th gens even existed.

1 Like

As we have a solution in the works, the naming scheme is fine. The solution will be used for both 13th gen and input kit replacement.

2 Likes

Do we know how long the solution will take? I’ll jump through all the hoops if I need to, but it will be a while before I have time. If you want someone to test the fix I’ll volunteer since I haven’t fixed it (yet).

Hello! I just assembled my framework 13 (13th gen) DIY and have a few major issues.

  1. The trackpad doesn’t work at all. I’ve tried windows 11 (with the driver pack) and Ubuntu and both have the same result.

  2. The fingerprint reader isn’t recognized by Windows (haven’t tried Linux). The button also get’s extremely hot to the point I can’t even touch it. Something’s definitely off.

I’m waiting to hear back from support but I’m wondering if anyone has any DIY fixes for this?

Looking for testers for a firmware fix we have needing additional testing. We only need a few folks.

Those interested in helping us test, please reply below with:

(Indicate which)
Framework 13 (13th gen)
or
Replaced input cover from original in 11th/12th gen Framework 13.

May I reach out to you directly? (I would use the email account associated with your account, do not post email information here.)

You may not hear any from me immediately, but I will be gathering replies from those interested.

3 Likes

Framework 13, 13th gen (Kubuntu 22.04 it that helps). Happy to be contacted via email.

1 Like

@Erick_Ratamero Awesome, thank you and thanks to everyone else who is interested as well.