[TRACKING] Instant power loss

I’m having similar problems with crashes/lockups with my new framework laptop in both Windows11 and Fedora35. I’ve attempted to submit to support using multiple combinations of laptop/OS/browser, but have failed every time with Captcha failures. A friend had similar captcha failures but was successful with Chrome on a MacBookAir, that didn’t work for me. I have DIY i7 with SSD and RAM from a different vendor

Yeah, however she was able to submit the requests. it seems that the page is having issues now

I thought I had submitted a request successfully earlier in the week, but seeing the failures today, I’m not so sure.

I couldn’t help but notice that RAM and SSD came from Framework…

There is a known problem with Western Digital SN850 drives causing a problem that manifests like this, which requires a firmware update from Western Digital to resolve. Have you tried that?

Also, others have reported that this problem was solved once the Framework driver pack was fully installed and the Intel drivers updated using their own tool. It would be useful to know if you’ve done that too?

I ran into this a few weeks ago. I put it in my car as it was warming up and when I got back, it was off and wouldn’t turn back on. So I brought it back in and plugged it in, only for it to have most of a charge left in it. I’m guessing the temperature caused the battery to undervolt (it was something like -25C that day), but I haven’t had any issues running Manjaro and having it unexpectedly shutdown on me.

I am aware that there is a magnetic hall sensor on the left side of the unit (near the aux jack) that is used to perform an action when the lid closes, and I’ve set mine up to turn off the screen (or hibernate if the battery is low). This might be a case of a magnetic object being close enough to this sensor to trigger the lid close action. Maybe try placing a fridge magnet to the left side of the device and see if the computer shuts down completely? If it’s not that, then my best guess is that it’s a battery or power-related issue.

@andyk2 It’s actually the SN750 she has.

Framework support is currently getting a lot of requests, and are trying their best to work through them quickly, but are only human. If she sent a support ticket it will get handled, she just needs to be patient. I understand this is tough to not have a working laptop, but they are still a small team.

I believe that website issues today are due to the Heroku outage that Framework was dealing with (they posted about it to their twitter). If you had successful submits earlier this week, you are likely fine and just need to wait for support to get to your ticket in the queue!

edit: the Framework Team has also stated that certain adblockers and js-blockers can cause the ReCaptcha to fail

1 Like

I was getting Instant power loss until I did the Bios Update. I also had continuous blue screens of death for everything until I removed one stick of ram and poof, it works perfectly. I will include my equipment (minus a stick of ram). I also started using Intel Driver Support Assistant, but the ram seemed to be my issue. Intel® Driver & Support Assistant

DYI Intel i5-1135G7

Hard Drive:
XPG GAMMIX S50 Lite Series: 2TB Internal SSD 3D NAND PCIe Gen4x4 M.2 2280 (NVMe)

G.SKILL Ripjaws Series 64GB (2 x 32GB) 260-Pin DDR4 SO-DIMM DDR4 3200 (PC4 25600) Laptop Memory Model F4-3200C22D-64GRS

OP Sys
Windows 11

Joining the party quite late but if anyone on this thread is still experiencing this issue, please submit a support ticket so that our Support Team can ensure that your laptops are working as intended. We want to make sure you are taken are of. Here’s the link - Framework | Support

Are you aware of the significant problems people are having with reCAPTCHA on that page. It flat out refuses to send the support request very regularly and wipes out everything entered in the process. Last time I needed to get a support request, I had to try three times - all on the same machine with the same circumstances one after another, so it can’t possibly be my computer causing the problem!

Remove Adblock.
-20 chars-

I don’t have any adblocks…

@andyk2 Adblockers, pop-up blockers, js-blockers, and misc settings on your browser can cause the ReCaptcha check to not show. We receive many tickets every day through our forms so we know it isn’t widespread. We’re sorry you’re having an issue submitting a ticket, but you can always fall back to emailing support@frame.work if the form will not work for you. While emailing directly is not ideal as it does not get pre-routed based on the form submission selections, we’ll still get it and can respond without issue.


It has been 2 weeks and other than those 3 times it did it during the first 2 hours of unboxing and driver & windows updates it has never done it again. I suspect the BIOS+Drivers just aren’t robust enough to handle some states that can occur during a “driver swap” in windows. Seems to have settled & been a fantastic laptop ever since.


Well, unfortunately it just happened again. I unplugged a Thunderbolt 3 dock on the desk carried it over to the couch opened the lid. It woke from sleep, i moved the mouse a bit and then it just shut off. Only thing plugged in was a USB-A yubikey

So I have a DIY framework laptop with pop_os. I have had the laptop turn off a few times. no dialog no warning it just powers off. It is not a reset it just turns off. I have been trying to look through logs but have not found why this is happening. Is this happening to anyone else? Also does anyone know a good way to debug this?

I also have a DIY Framework, and am running Ubuntu 21.X. I’ve seen this happen twice over the span of about a month of usage. In both cases I couldn’t figure the cause either, but it looked very much like a complete loss of power. One time the device was on a power adapter, while the other it was not plugged in.

For me it’s been a relatively rare event that’s a very minor nuisance. Everything else about the Framework has been such a wonderful experience that I’m very much a happy customer. I’m interested to hear if others have observed similar things, or how we can go about gathering more data if/when it happens.

Just had this happen to me.

Windows 10 Pro
32 GB Ram
2 TB Sabrent Rocket

Opened a chrome tab and clicked to type a search and it just went black. Had to push the power button to turn it back on and it turned on as if it was a new reboot

I just recently had this happen on my i5 DIY. It’s only happened once, but my SO also has a framework and I have anecdotal reports from her it happens occasionally to her.

I was running off the battery, playing some casual game I had been playing for a few hours. The laptop just clicked off. I restarted, and battery was around 50%.
My laptop configuration:
i5 DIY
Windows 10 Pro 21H2
current driver and BIOS bundle
32 GB RAM (A-Tech 2 x 16GB DDR4 3200 CL22)
500GB SK hynix Gold P31 NVMe
2 x USB-C ports - both empty
2 x USB-A ports - one empty; one w/ Logitech receiver

I’ll try to use it more often (I typically only use it when travelling) and see if I can reproduce.

Happened to me 2 or 3 times. I think it happened only on BIOS 3.07 but I can’t be sure.

Ubuntu 20.04.4
i5 DIY
32GB Crucial RAM
1TB WD SN750
2x USB-C ports
2x USB-A ports