[TRACKING] Instant power loss

Happily typing along and suddenly framework lost power, like instantly just shut off as if pulling the battery.
I’m sure it was power off, not screen off, because it went to the default blue lock screen wallpaper after restarting, the power button had no light, and also the Chrome tabs I was typing in were “restored” when I logged back in. I was able to immediately power back on.
Is there any keyboard combo I could have mistakenly hit while typing? FN Lock is not on. If not, I hope it was a one-off fluke but a little worrisome!
Not plugged in, battery 79%, batch 6 i5 running Win11


Could be

[Solved, Magnets] Strange electrical behavior?

What’s your lid closed action?

1 Like

@aquaticDolphin interesting thought. Maybe it was hibernate. But I don’t have any magnets around, and it was on one of those plastic resin “Lifetime” folding tables I use for a temporary desk in my apartment. Might be some other reason the sensor “thought” the lid closed but I can’t think of any?

1 Like

Are you certain it wasn’t a freak software error? Has it happened again?

@Sam_Murray No I’m not sure of anything regarding the issue. Has not happened again, and I’ve used it hours more. Only got it 2 days ago so hoping it was a crazy fluke.

Hmmmm I had a similar issue happen a couple of days ago. No magnets near my computer, everything is set to sleep when lid closes. I was happily typing when it decided to randomly shut off. I had it happen twice, once in my Windows environment and once in my Ubuntu environment. When I went to power it back on, everything was as it was before powering off. Batch 6 i5 pre-built running Windows 10 and Ubuntu 21.04.

@Rawwjhee at least we can confirm each other’s experience, sounds identical. Unfortunately, it looks more like a real issue than a one time oddity.
We were both typing- has to be something there but I’m clueless rn. We could be pressing and causing stress on a particular spot under the keyboard?

Is there anything notable in the logs around the sudden shutdown?

Have you tried reseating the connector from the power button? I wonder if it’s activating erroneously.

@lbkNhubert I wouldn’t know what logs to check ha

@Sam_Murray i haven’t but wouldn’t an erroneous power button cause a normal shutdown? This was power cut instantly as if the battery was pulled. If anything I’m leaning more toward checking the battery connection.

@mjnz How to find Windows 10 crash logs, error logs, event logs the easy way


@Jason_Hottelet Thank you. I found this critical error right at the time of issue. Says “LongPowerButtonPressDetected”. @Sam_Murray So perhaps it is power button related? I was typing, certainly did not long press the button intentionally.
edit: well it also says could be from power loss, so… IDK

Log Name: System
Source: Microsoft-Windows-Kernel-Power
Date: 1/8/2022 9:32:56 AM
Event ID: 41
Task Category: (63)
Level: Critical
Keywords: (70368744177664),(2)
Computer: xxx
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.
Event Xml:





Could you try holding the backspace key for 10 seconds? It’s the only button I could think of that one would press for a longer period of time and that should be located near the mainboard power button (there is a physical one so the mainboard can be used on its own). I could be mistaken on the location of that button as I don’t have my Framework yet, but maybe you can reproduce the issue that way.

@Jason_Hottelet I tried holding backspace, and other areas around the button. I also just took it apart and poked around with it on, pressing areas near the battery and power button. I cannot duplicate it.
As far as the typing, I was mid sentence and definitely not pressing any place for more than a tap. I wouldn’t necessarily associate typing with it, but now that @Rawwjhee added that he was also typing mid sentence, it makes the problem that much stranger.

@mjnz I’ll make sure to log the date and time if the error happens for me again. I didn’t pay much attention to it at first but now I’ll remember to grab the error log. Good thing is that the error is not happening intermittently and so far has been a one time occurrence for us.

Edit: Found the critical error log, it is the same as mjnz. It happened shortly after I received my computer. Can’t remember if this was before I updated the BIOS/drivers or after.

Description: The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

@mjnz I imagine your post originally said something like


when you posted it.

When you post XML (or HTML or similar) to the forum you need to put it in a code block (using the button on the editor that looks like </>). If you don’t, all the text you paste in that’s between angle brackets will not actually show up.

If that’s the case, that it said false there, it’s Windows reporting that a long power button press was not detected. I don’t really know how that detection works exactly so it might not be reliable, but I’m not sure I’d think the power button itself is the most likely culprit.

This log entry logs when the system starts back up after unexpectedly powering off, so it often doesn’t itself really contain useful information. If you have any interesting-looking log entries that are instead right before the system turned off, they might be more helpful. But something like this that causes immediate shutdown might not be something that results in a log entry at all.

@John_Flatness Correct, I didn’t even notice it was “false”. Looks just like Rawwjhee’s screenshot. Also didn’t know about the code thing, thanks.
Not sure but to my limited knowledge, no other entries look like a concern but maybe they are and I don’t know it lol
@Rawwjhee I know mine was after updating bios to 3.07

1 Like

I haven’t yet (Knock, Knock) had my Framework just power down as described.
I have three or four Lenovo laptops that I do not trust on battery. They say around 40% and then moments later, shut down. When i Plug in the charger and restart, the battery percentage is 0% or very close to it.
This started happening even when they were < 6 months old.

I’m having the same problem. Batch 5 on Alpine Linux. Exact same problem; laptop is working fine and then it suddenly shuts down as if the power was pulled. I haven’t noticed any pattern for when this happens. Sometimes the laptop will stay on for over three days before shutting down, sometimes it only lasts a few hours or less. Sometimes it’s when the laptop is plugged in, other times it’s not. But the battery is always fine when it happens (and I’m able to immediately power it back on). The only real pattern is that it always happens while I’m actively using the laptop; it never happens when the laptop is idle (even if it’s open and not asleep). I’ve tried tweaking BIOS settings, and none of my changes have made a difference. The problem is quite frustrating; does anyone have any solutions or ideas on what the culprit may be? Thanks in advance.

(I’m willing to submit any logs if needed; I’m just not sure where to find them on Linux for such a problem. If it makes a difference, my init system is OpenRC, not systemd.)

@Sebastian wow you’ve had more than one, so this is looking serious. Probably time to get Framework folks looking into this