[TRACKING] Intel vs. AMD

Do you have this on all 4 sides or just one? I don’t see this on mine (FW13 7840u, Fedora 39 Sway, Kernel 6.8.7).

On the right side. It’s a Fedora 40 thing I think.
Didn’t have it before.

1 Like

Intel drivers are worse than radv imho. The problem in your case is Wayland, which is still not ready for primetime (granted - much closer than before). I’m still waiting for better screen capture and Barrier and the like support there before I switch. No problems here with 7840 and X11.

Edit: forgot to mention, yeah I agree that my problems are very likely Wayland related :slight_smile:.

Not in my experience. My previous laptop (i5 8250u) was more stable. I’m on wayland for over 2 years now I think. Intel also in general spends much more resources on linux support (but AMD has been improving a lot in that regard)

Anyway, I’m happy.

1 Like

Are you interested in VMs with gpu hw acceleration? Setting gpu pass-through aside, some guys online have been able to use multiple PCIE Virtual Functions with intel linux driver to split the igpu and give one part of it to the VM. With amd driver/gpus is not possible. Might be useful for someone that wants to run some 3d-rendering/cad/encoding software inside a windows guest under a linux host.
It’s not something common/easy in the consumer space, but as you cited both VMs and 3D-work I think it was worth a mention.

Agreed: those old intel igpu had the best drivers in my experience too. That said I run and amd r5 fw13 now with ubuntu 24.04 and is not that much worse anymore. It’s not 100% stable but it has improved a lot.

There are still thing working worse than on intel, for example:

  • TDP/power settings via RAPL not implemented
  • EC tools need a patched kernel (should be fixed in 6.10+) or portio driver
  • higher gpu hw decoding power consumption on linux when doing nothing but watching a video (some work is ongoing in compositor-land)

But I’d say those are minor things. Linux support is fine now and looks like still improving.

There are some topics about specific docks not working properly and also one about external usb ssd. Personally every usb-related problem I’ve previously experienced looks like is gone after last BIOS update, but someone still reports some issue.

I don’t know about last gen intel, but the amd version supports only S0i3/s2idle/“modern standby”, no suspend-to-ram. In my experience power consumption during sleep is around the 0.5%/hour (around 0.3W for last night doing some math FWIW).

Everything works fine.