[TRACKING] Issues with external display, Fedora 38, 13th Gen Framework 13

New Framework 13, with 13Gen Intel CPU
Fedora 38.
Dell 27" USB-C display

Plugging in an external monitor on HDMI or USB C is detected correctly BUT

  • the external display is distorted, left third is gray and detects the mouse cursor, but the right 2/3 have a distorted view of the correct background image.
  • when the mouse cursor is moved over the right 2/3 it leaves a trail of cursors as the mouse pointer moves around, which blink on and off, and no screen updates.
  • when I hit the Super key the screen preview of the external display looks correct with the correct background, with no trailing mouse curosr, but returns to distorted when back to full screen.
  • when I tried to take a screen shot for this topic to show the distorted screen, to my surprise, the screen looked correct, but returns to distored once the screen shot is dismissed.

This occurs when connecting from ports on the right side of the laptop.
If I try and coinnect using a USB-C connector on the left rear of the laptop, the LAPTOP display is blanked out with the same trailing cursor problem and the external display appears.

Is there some log that I can look at to help diagnose this issue?
Any help would be appreciated.

– Scott

Hi Scott,

I want to make sure I am following this correctly - you indicated that one set of issues presents itself on the right side and another issue on the left.

Curious, are you using a dock or a USB-C to HDMI type adapter by chance? You mentioned this is a Dell USB-C display, so my thinking is this must not be a direct HDMI to HDMI connection to a HDMI expansion card?

Let me clarify my setup.
I have a USB-C and HDMI port on the right hand side and a USB-C and USB-A port on the left hand side. I am connecting directly to the monitors without a dock. I have two Dell monitors, an older one that is HDMI and a newer one that is USB-C.
That is what I am using for my observations.

After modifying the display settings from the settings widget I have the following observations.
I should note that I have fractional scaling enabled.

When plugged into the rightside USB-C port, if I set my external monitor to 100% scale I see the phenomenon I described, However, if it it is any other scale (125%, 150%, etc.) I do not see the distortion. I tried this experiment with the HDMI port (on the rhs) and see the same thing. It only works when the external monitor scale is >100%

When I connect the external monitor on the left side USB-C port, I see the distortion on the laptop screen when it’s scale is 100%. When I change it to any other scale (125%, 150% etc.) the laptop display recovers.
As a last test, I moved the HDMI port to the lhs, and I see the external display be distorted at 100% scale. It recovers when the external display is set to something other than 100%

To summarize:
RHS: USB-C, HDMI external display is distorted when its scale is 100%
LHS: HDMI external display is distorted when its scale is 100%
LHS: USB-C laptop display is distored when its scale is 100%

Apparently there is an issue with these specific ports and some sort of screen synchronization.

I would have thought that it was purely a software issue, however with the different behavior between rhs and lhs USB-C ports, there must be something else going on.

Sorry for being so long winded, but it seems that I can work around this issue for now, but I would like to know if there is a way to resolve it at some point.

Thanks for your support,


I moved the USB-C port from the back on the lhs to the front on the lhs, and the external display behaves the same way as the other ports. So,

RHS: USB-C, HDMI external display is distorted when its scale is 100%
LHS: HDMI external display is distorted when its scale is 100%
LHS: USB-C rear port external display is distorted when its scale is 100%
LHS: USB-C front port laptop display is distored when its scale is 100%
There must be something special hardwarewise about the left rear USB-C port.


Sounds like you’re using Framework expansion cards, okay. Good so far. The port itself is different than the expansion cards themselves, so I wanted to make sure we were talking about the same thing. We have people forgetting to mention docks, adapter and other items…which makes this process more trickier - so I have to be explicit. :slight_smile:

Does the distortion take place with fractional scaling turned off? Absolutely should not matter, but curious if this changes the behavior.

The fact that this seem to affect USB-C expansion cards and HDMI expansion cards makes we wonder if there is anything happening on the software side of things. If these are known working cables and it’s working in one state, but distorting in another state - feels like software/OS big time.

What kernel are you on? I only have access to displays using HDMI and DisplayPort myself, but I will attempt to replicate.

I think that I finally understand what is happening and i believe that it is a software issue.
Apparently, in Linux each port (USB-C, HDMI) has a different remembered display configuration. Trying a variety of different display configurations I have found that the scale of the external display and its orientation, in software, with respect to the laptop display are critical.
If the eternal display is configured, in the display widget, to be to the right of the laptop display and is set at 100% scaling the external display is shifted with part of the display having the training cursor problem. Above 100% scaling it is fine.
When the external display is configured to be above the laptop display, this screen distortion extends to the laptop display, completely covering the windows and content underneath and also showing the training cursor and display refresh issue. Changing the external monitor scaling does not seem to fix this issue.
Because each port which is used to connect to the monitor can have a different remembered display setting, I saw different behavior when I tried different ports.
The only change that i made from the stock install was to enable fractional scaling and since I am on Fedora, I am using Wayland.
Now that I know the settings that can cause issues I can avoid them, hopefully a future update will resolve these issues,
I am curious to know whether other folks have seen these issues and if so if they have been noted as a bug in the distribution.

Thanks for your help with this issue,


1 Like

Appreciate this.

I am working very closely with the Fedora team and am building a list to get to the testing team to see if we can duplicate/resolve. This may also resolve itself in future updates, but I am tracking this nonetheless.


To confirm, the duplicatable step is to enable fractional scaling when you run through the list of examples you provided?

I have another data point however.
I installed the KDE Plasma Spin and I do not see any of these issues.
So it seems as if the problem is a GNOME problem and not a Framework or Wayland one.

1 Like

Okay, this is helpful. Adding this to my tracker sheet. What steps did you take to emulate the fractional scaling on Plasma? For my tracking sheet.

Fractional scaling on Plasma either inherited the setting from when it was set in GNOME in some way, or is enabled by default, as I did not have to do anything to have fractional scaling options. Hope this is helpful.

1 Like

This sounds like a potential bug derived from the move from a vertical orientation on workspaces to a horizontal orientation on workspaces. I think this started with Gnome 40, and it is entirely possible that this fell through the cracks so far.

Personally I have not seen any of these issues, but I don’t ever use my monitors as set above the external display they are simply to the right of the internal display in the settings. With these settings I experience no issues. I did test them in the configuration you describe and have not experienced the same issue…of course I may be misinterpreting your description of what is going. Uploading some images in this instance might be helpful.

I use Fedora 38 Gnome with Wayland fractional scaling enabled.

1 Like

This is extremely helpful. Yeah, I wasn’t seeing anything on my end, either and we have not seen it in our internal testing.

1 Like