[TRACKING] Lots of stuttering and lagging on AMD + Ubuntu 22.04

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
lshw is already the newest version (02.19.git.2021.06.19.996aaad9c7-2build1).
lshw set to manually installed.
dmidecode is already the newest version (3.3-3ubuntu0.1).
dmidecode set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
	Vendor: INSYDE Corp.
	Version: 03.02
	Release Date: 09/27/2023
	Address: 0xE0000
       product: AMD Ryzen 7 7840U w/ Radeon  780M Graphics
       vendor: Advanced Micro Devices [AMD]
       physical id: 4
       bus info: cpu@0
       version: 25.116.1
Kernel version: 6.1.0-1024-oem

I have very similar symptom, I also noticed that the stutter also happens when moving mouse cursor between monitors. Setting both monitor to the same screen scaling doesn’t remove the stutter.

with expansion card as (according to the picture in the guide)

  1. USB C
  2. USB A
  3. USB C
  4. HDMI

BIOS 3.03 is out, maybe give that a try and report back?

Thanks for pointing that out. I totally missed that.

After updated to 3.03, the stutter was gone with quick scrolling in Firefox or moving cursor between monitors. Starting Thunderbird also no longer freeze the system for a few seconds.

I’ll report back if the issue resurface again.

1 Like

Same for me: Upgraded to BIOS 3.03 and stuttering / freezing has disappeared as far as I can tell :+1:


Thank you for reporting back. Issue solved.

1 Like

For those here reading about the 3.03 BIOS, here is the link:

Once I hear back from @juchong, I think we’re able to mark this as solved. I’ve been on 3.03 for sometime (Ubuntu 22.04.3 and Fedora 39, running great here.

I just installed it on my machine this morning. I’ll report back tomorrow once I let the update soak for a bit. This is a tricky one since it didn’t always happen.

@Matt_Hartley Using 3.03 in Ubuntu 22.04.3 and the OEM kernel, I’m noticing that the laptop will ramp the fans up and down very quickly for no apparent reason. I’ve heard the laptop do this twice while I write this.

EDIT: There does not appear to be a way to easily monitor the fan speed in Ubuntu, so I’m not able to share any logs/data.

1 Like

Confirming that the stutter is gone after upgrading to BIOS 3.03, @Matt_Hartley

Great job, guys!

1 Like

Is the 3.02 Bios availiable anywhere for download in case something goes wrong ? This page seems the most obvious to me. But it doesn’t have a download link.

@Matt_Hartley I have more bad news to report:

  • The computer does not seem to enter sleep/suspend properly anymore. The display turned off as expected, but the laptop never entered S4/S5 automatically.
  • Forcing sleep mode and waking the laptop up will sometimes cause peripherals (WiFi card, fingerprint reader) to not initialize properly, forcing a reboot.

Screenshot from 2023-10-25 12-33-59

EDIT: However, the stuttering does seem to have disappeared!

Stuttering gone here as well with 3.03. Stable between Ubuntu 22.04, Pop_OS 22.04, and Fedora 39. This is the experience I was expecting out of this machine.

1 Like

My AMD 13" is also not going to sleep when closing the lid. It just stays awake.
Have to manually hit “suspend” first. Then it won’t wake up again, have to reboot it by hitting the power key long and hard.

@FlowWork Which BIOS version? Which kernel? Wayland or X11?

BIOS 3.03
Kernel 6.1.0-1024-oem

3.02 is not something we’re going to be supporting after we’ve taken 3.03 out of beta, so no. If something goes wrong and we need to revert you back for a second attempt with 3.03, that would be a support ticket.

Sounds like other oddness is afoot with your setup. At the airport, been using suspend all day on 22.04.3 without issue. This may become a ticket at this point as I have not been able to replicate any of it.

Try Wayland as is default with Ubuntu 22.04.3 for best results. That is what we’re testing against. We can take a look at X11 suspending when I return home, should still suspend unless something attached is preventing sleep.

@FlowWork seems to also be having similar issues.

My years of experience working on consumer devices has taught me that “it’s not happening to me” doesn’t mean there isn’t an issue. The latest firmware messed with power settings, so it stands to reason that some power-related stuff may also have been inadvertently broken. Have you had a chance to use your laptop in a quiet setting?