[TRACKING] RZ616 download problem


I received my Framework 13 7640u a couple of days ago and I have encountered one major issue.

The WiFi is simply terrible.

I get 65% of signal power in linux mint and all bars in windows (whatever that means) but I get at most 40Mb/s download in both OSs.
And it’s extremely unstable, with response latencies all over the place.

I do get 150Mb/s upload tough.

My desktop PC and macbook both get a snappy 300Mb/s download in the same spots.

On windows I tried forcing wifi AC, tried using 2.4 and 5Ghz bands only, no improvements.

When I get about 5m away from the AP I get 500Mb/s down and up on my macbook, whereas the framework I get 350Mb/s tops.

My SSD’s read/writes performance aren’t the problem, it’s not faulty.

The antenna’s are properly connected and do not appear to be damaged (And again I do get a nice signal according to windows and mint).

My WiFi AP is a TP-link eap-245.
The drivers used are :

Does anyone else experience bad wifi connection?
Is there a possible software solution or should I just get another card?

Thank you for any leads.

1 Like

mhm mine shows the same behaviour. Much faster upload then download. But it is interesting that the download is the same on windows. I just have thought it is a linux thing.

Welcome to the community!

For the best experience, we’d recommend Fedora 39 or Ubuntu 22.04.3 using the OEM C kernel, as described in the guides.

All of this said, there is an unofficial guide to get Mint into a better state for a Linux Mint installation.

If you still are not happy with the wireless after getting onto a tested, supported kernel as described above, installing an Intel card will work and we do have some users who have done this.

Thank you but the problem is exactly the same on Windows 11 build 226331.
I did install the driver package.

I used many laptops, new and old in my room, all had good WiFi performance here.

The confusing part being : the laptop sees a good signal but can’t make use of it.
I don’t know if it’s a weird driver problem or if the card is somehow half-dead.

Ah, gotcha. This is not something I have experienced myself. As this is happening on multiple OS’, it’s worth contacting support to see what we can do to remedy this.

Alright I’ll do that, thanks.

Are you able to test it on a different AP to see if you have the same issues? I have two 11th gen systems, one with a mediatek 7922, the other with an intel ax210, and they both have similar upload and download speeds to a server in my network as a macbook air m2. My router and APs are running the asus-merlin firmware.

I don’t really see why the AP would make a difference but I will try just to make sure.

And again I do believe that something’s wrong with my card, as you have mentioned most don’t have any problems.

1 Like

I am running Mint, and do not seem to have any wifi issues. As I am typing this, my connection shows 60% to my SSID, I use tp-link eap650’s and get reasonable speeds and latancy.

Just did a quick iperf3 to a server in my lab:

Connecting to host, port 5201
[  5] local port 55338 connected to port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  32.0 MBytes   269 Mbits/sec    0   1.18 MBytes       
[  5]   1.00-2.00   sec  31.2 MBytes   262 Mbits/sec    0   1.73 MBytes       
[  5]   2.00-3.00   sec  26.2 MBytes   220 Mbits/sec    0   2.17 MBytes       
[  5]   3.00-4.00   sec  35.0 MBytes   294 Mbits/sec    0   2.17 MBytes       
[  5]   4.00-5.00   sec  33.8 MBytes   283 Mbits/sec    0   2.57 MBytes       
[  5]   5.00-6.00   sec  35.0 MBytes   294 Mbits/sec    0   2.72 MBytes       
[  5]   6.00-7.00   sec  35.0 MBytes   294 Mbits/sec    0   2.86 MBytes       
[  5]   7.00-8.00   sec  35.0 MBytes   294 Mbits/sec    0   3.01 MBytes       
[  5]   8.00-9.00   sec  32.5 MBytes   273 Mbits/sec    0   3.01 MBytes       
[  5]   9.00-10.00  sec  32.5 MBytes   273 Mbits/sec    0   3.01 MBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   328 MBytes   275 Mbits/sec    0             sender
[  5]   0.00-10.05  sec   326 MBytes   272 Mbits/sec                  receiver

iperf Done.

I have a feeling that the problem might be the antenna design, it is very directional.

My AP is in the room above mine, when the computer is open, the screen faces a wall (30cm away but still) and I get 20Mb/s, closing it gets me twice the download and if I place it just right I get 80Mb/s (still the macbook never goes below 150Mb/s no matter the position).

This makes it more manageable but I suspect I will be forced to get some third party antennas.

Before that I will try to get an Intel WiFi card, too many people reported issues with this Mediatek one and I can’t even find a driver download page from the manufacturer - I find this very annoying - as if it’s some crappy OEM part.

I’m getting similar performance RZ616 performance issues on W11. 20 Mbps download/upload tops on any wifi network. My phone pulls 250 Mbps download and upload without a sweat (on the same network). It’s literally less than 10% of the performance I’m getting from other devices. Quite disappointing.


I updated my driver to this one (device manager was showing I was using an older version, sadly I didn’t take a screenshot): [DRIVERS] AMD|MediaTek WiFi/Bluetooth - Republic of Gamers Forum - 857576

My wifi speed instantly increased to 400 Mbps.

@Matt_Hartley please consider shipping the updated driver ( in the driver bundle. For the reference, I think the current driver bundle includes the driver.

1 Like

Damn it, my hopes were so high for those new driver but it made no improvements to my case (it actually got much worse for the download speed) :smiling_face_with_tear:

Thanks for the info though! I was finding it quite annoying that Windows never updated the WiFi card but given the messy drivers I should be glad I guess :joy:

I did test my framework on a Archer C6 rooter and the speed is generally better at around 80 Mbits/s download and it seemed to be more stable but then again the performance was still very bad compared to other laptops and smartphones in the same spots.

And I don’t want to replace my AP with a rooter just to get better performance on one struggling device.

I guess there isn’t much to do other than trying another WiFi card.

Will pass this onto those providing Windows support.

1 Like

Update on slow wi-fi with MediaTek.

Fedora has the update, Ubuntu LTS is next.

The change in question for everyone else.

1 Like