[TRACKING] Screen/display jumping/flickering and laptop briefly freezing

There seems to be a post length limit, so this is part 1/n…

I’ve install Debian 11 from scratch, and I’ve been configuring, and everything has been fine - until about ten minutes ago.

At that time, I did two things.

First, I viewed a PNG, having installed wine. Wine is bloody idiotic, and makes various apps in wine (such as IE) the default apps for a bunch of file types. As a result, the image opened up in Internet Explorer.

Second, immediately after I sorted that out, I installed arc-theme (which requires a GTK2 engine) and switched to arc-dark…

1 Like

Part 2/n…

…and now for whatever reason the laptop display is now “jumping”.

I see a visual flicker, of what’s on the screen jumping vertically, for a very brief moment, then there’s about two seconds after in which the laptop has frozen.

I uninstalled arc-theme, and the GTK2 engine, and went back to “default” - and this caused Debian to lock up!

I did a hard reboot, but the display jumping and then laptop freezing persists - it only happens if I’m actually doing something, say with the mouse pad.

(There’s a bit more to add, but I’m forbidding from posting more. Yay.)

(Maybe I can get in one more line - I have noticed on boot I’m getting “GPU failed to initialize, declaring it wedged”. Turning off PSR seems to have solved the problem, but I suspect it’s masking the real issue; why the GPU is now unhappy.)

1 Like

Ok here’s a reply that may allow you to post again.

By the way read other topics to raise your user status etc.


1 Like

Thankyou : -)

Just addding that I’m seeing the same thing with Fedora 36 (6.0.9-200.fc36) on a 12th gen DIY i5. For me it seems to happen most often on resume from suspend when on battery power – after opening the laptop, I can grab any window and move it around quickly in circles for a few seconds, and this will generally make the freeze/jump/flicker thing happen.

I’ve found that, when it happens, I can sometimes hit the power button to force a suspend, then hit it again to resume, and after this the problem seems less severe. But haven’t played enough with this to say for sure.

Some topics on the forums here seem to address this problem or similar ones, but not sure if my problems are the same as those (or the same as yours, but it definitely sounds similar). Haven’t yet contacted Framework support since I’m not sure what they’ll be able to do.

So, I reinstalled from scratch, and I’ve had it happen exactly once since then - it’s been two days. PSR is enabled. I don’t think I have it now; but i have no idea why not.

Sometimes starting off with a clean slate is the fastest approach to resolution. If it happens, check dmesg to see if anything interesting appears.

So, I can update with my experiences since posting.

By and large, flicker/jumping does not happen.

I go all day without it.

But I note when I resume from suspend, then it happens.

Sometimes it’s only for a little while, and it passes.

Other times the UI actually locks - the laptop is fine, it’s still doing stuff, but the mouse is frozen. Then I have to reboot via the power switch.

Next time this happens, reboot then:

journalctl --since="15 minutes ago" > ~/journal.log

Poke thru this and see if anything crops up. You can lengthen or shorten this to make it more helpful.

So - it is becoming clear that the problem (freezing up, screen glitching) occurs after a resume from suspend. The laptop is still working correctly behind the scenes - I had a VOIP call ongoing when the UI had frozen up completely for about a minute.

Sometimes - as today - the glitching and freezes in the end passes; other times, the UI will freeze up and not recover, and a reboot has to happen.

I checked dmesg and there was nothing. I didn’t check journalctl; I have made a note of the command and will try it next time.

The brief freezing sounds like it could be this issue if your machine is 12th gen - I’m currently seeing this issue too and also occasional glitching where the entire screen jumps up and down by about 1cm (although I’m on Fedora 37 Silverblue).

If you run dmesg | grep "GPU HANG" after experiencing a freeze, you should see something along the lines of GPU HANG: ecode 12:0:00000000 if it’s the same issue.

I had glitching earlier, checked dmesg - but no output with case insensitive grep for gpu. I think it could well be this, but not being logged. I’m on Debian 11, and there are no drivers installed for the GPU, maybe this is affecting logging.

I have found that shutting the laptop lid and re-opening it normally clears the problem I’ve described. Not always, but it looks like every time you do this, you have a very good chance of clearing the problem, and so if I repeat, then the problem is solved. I can’t think I’ve ever needed to try it three times.

Nothing at all like that in my dmesg either after an event.

The only thing even slightly wierd in my dmesg is something about the embedded controller (the lines containing cros_ec, when you google that, you find some kernel patches that even mention Framework laptop):
[219593.300525] cros_ec_lpcs cros_ec_lpcs.0: packet too long (30844 bytes, expected 24)
[223353.931715] input: WH-1000XM4 (AVRCP) as /devices/virtual/input/input52
[231175.485674] audit: type=1400 audit(1679889600.897:35): apparmor=“DENIED” operation=“capable” class=“cap” profile="/usr/sbin/cupsd" pid=368389 comm=“cupsd” capability=12 capname=“net_admin”
[232430.217568] vmstat_refresh: nr_file_hugepages -4
[251922.229109] cros_ec_lpcs cros_ec_lpcs.0: packet too long (30083 bytes, expected 0)
[252014.389734] cros_ec_lpcs cros_ec_lpcs.0: packet too long (31356 bytes, expected 0)
[253078.335210] cros_ec_lpcs cros_ec_lpcs.0: packet too long (31612 bytes, expected 24)

I don’t think these are related, I’m just showing that there’s nothing there. The messages before these I recognize from connecting and disconnecting my phone over an hour before the glitch happened, so no messages before that matter.

I think that fedora36 hard lock problem is something else. I do have the wd sn850 drive and updated firmware using the windows app, but I’ve never had a full system hard lock and the fans kicked up like they are describing. The machine keeps running just fine. playing youtube on other monitors, bluetooth keyboard and mouse keep working, bluetooth headphones keep working, network via gigabit on the tb3 dock, whatever other apps I’m using, etc all keep going without a blip.