[RESPONDED] Screen freezing/jumping, Pop!_OS 22.04

Hi everyone!

I’ve been having an issue with my display under linux (doesn’t seem to affect Windows, so probably not a HW problem per se). This happens with both Wayland and X.

Every few seconds, the display will freeze completely; then, within about a second, it’ll make a vertical ‘jump’, before un-freezing. This issue is intermittent (I’ve gone hours without it happening at all, then it’ll start happening again seemingly at random), and it only affects the laptop’s internal display (it’s frozen pretty badly once, while connected to an external display, and the external display was fine).

Has anyone else experienced this? How’d you solve it?

My specs are: i7-1260p, Samsung SSD 980 1TB, 16GB RAM. Running Pop!_OS 22.04 LTS, Gnome 42.5. No fractional scaling or HiDPI daemon activated.



I’m sure someone else has a better idea, but while you’re waiting, here’s the only one that comes to mind for me: what kernel version are you on? I heard that you need at least 5.18 for proper support for Alder Lake’s hybrid core architecture, and that Pop!_OS 22.04 uses a lower version by default. Perhaps take a look?


@Jacob_Padgett thanks for the tip, but I’m on kernel 6.0.6.

1 Like

Which applications are you running when this happens? Is Chrome one of the applications by chance? Also, are you comfortable with looking at dmesg from a terminal after an event and it corrects itself?

I installed Arch on my Framework and had the same issue. The default kernel for Arch at this time is 6.0.9. When I dropped back to the LTS kernel (5.15.79) the problem disappeared. I’ve had no problems whatever since.
Every time there is an update to the 6 kernel I try it again. So far no luck. I’m curious if anyone else has linked this problem to kernel 6.x

1 Like

@Matt_Hartley I’ve never been running Chrome when it’s happened (I’m normally a Firefox user). Applications have been Telegram Desktop, Discord, Firefox, VSCode… that’s about all I can remember. It does persist for a seemingly random time after I close every application though. Next time it happens I’ll have a look at dmesg and post the results (not sure how long it’ll take before it happens again). Thanks!

Please do. Also if you’ve made any kernel customization (blacklisting this, tweaking that, etc). Additionally, since you’re on Pop, I want to make sure you do NOT have TLP installed and ask what your power profile is set to? Battery Life, Balanced or Performance and is you’ve tried each of these?

I’ve been having similar issues under Manjaro, but I’m unable to reproduce. Also on 6 kernel, no notable tweaks.

I had similar glitching under Debian Testing when the kernel upgraded to 6.0.8. It resolved when an updated i915 firmware package came down (dated 9-Nov). If Pop hasn’t provided an updated package, you could try manually pulling the firmware down from the kernel archive into /lib/firmware and see if that resolves things.

I’m having this issue on Fedora 37 & 37, kernel 6.0.9. I use Brave browser.

The issue comes and goes - I can go a while without getting it at all, then it abruptly becomes a major issue.

If I sleep + wake it seems to temporarily resolve the issue.


I’ve received the Framework laptop last week. I run arch, gnome, kernel 6.0.11. And when I turn the nightlight on and off, the top of the display flickers white. Other issues seem similar.

I’ve made a post about it here, mentioning this post, among another. So far I’ve not received a reply.

Do you also see this behaviour regarding nightlight?

Running Fedora 37 on 12th gen, I also intermittently have screen freezing. It’s particularly common when I mouse over “Activities” to bring up the workspace view.

This is my first time with Fedora. I think I’ll use the -T parameter with dmesg next time it happens, to make sure any logs are correlated with the event. Any other dmesg tips for a newbie?

@Rubion yes, I do! The top ten or twenty pixels on my screen turn into whiteish garbage when I turn the nightlight on or off, for a few seconds.

I couldn’t see any dmesg activity around the time the flickering starts/stops. I have now uninstalled tlp, so I guess we’ll see if that changes anything. I’ve got the hid_sensor_hub blacklisted to get brightness keys working, and my power profile has always been set to Balanced.

@Joseph_Loveday I’ve in the meantime figured out that it is most likely related to a a gnome extension. I copied my old homefolder from my old SSD to my new one, which meant that everything was mostly configured as it was. It seems to be caused by the User Theme extension, and more precisely a little bit of css code that I made myself to make the black top shell bar dark grey. I now have the User Theme extension disabled and I’ve no longer had the ‘whiteish garbage’, as you call it.

I feel this has also greatly reduced the termporary freezing and screen jumping - but not entirely sure about that.

Do you have this or other extensions enabled?

I don’t have that extension, but I have several others (all the default Pop!_OS extensions). It might be that one of those is playing up.

It might be worth trying to first disable all extensions with the Extension application. If you then notice that the top of the screen no longer flickers worth, you could individually turn on all your used extensions and each time turn on and off the nightlight several times in order to see when it returns. Should you think you have found the Extension which causes this, reboot and see if the flickering has indeed disappeared. If so, you know what causes this.

I have found that shutting the laptop lid and re-opening it normally clears the problem I’ve described. Not always, but it looks like every time you do this, you have a very good chance of clearing the problem, and so if I repeat, then the problem is solved. I can’t think I’ve ever needed to try it three times.

(So, I need to add this to the end of this reply because the bloody forum software is getting in the way again and blocking this reply.)

For me, how I fixed mine was going to settings and changing the screen resolution to something else and back again and somehow the problem goes away until it randomly appears again.

To riterate:

  • Make sure Pop OS is fully up to date

  • Test this with no other displays attached

  • See if disabling Pop OS extensions (provided) changes the results.

  • Under Displays, try toggling off HiDPi Daemon; both Enabled and Mode toggles.