[TRACKING] Screen flashing partially white on Framework 13 AMD, Ubuntu 22.04


I’m having an intermittent issue with my Framework 13, AMD variant. I use it with a dock and two external monitors, and sometimes when I plug it in to the dock (and occasionally when I just wake it up from sleep, while it’s already plugged in) the screen starts going crazy. Sometimes I can get it to stop by unplugging/replugging it a couple of times, but some of the time that doesn’t work. However, what always seems to work is logging out and back in (assuming I can see enough of the screen to accomplish that), which leads me to believe that this is primarily a software issue rather than a hardware issue.

Here’s a video demonstrating the issue. This video is just of the built-in monitor but it looks the same on the external monitors when it occurs. Sometimes it’s just one monitor, sometimes it’s multiple.

So far I haven’t observed it just happening spontaneously - it always seems to require some change to the monitor configuration. Mostly it seems to happen when it starts sending picture to the external monitors. I can’t remember off the top of my head whether it’s started happening when I disconnected it from the external monitors, but I’ve certainly encountered it continuing to happen in that case (in the instance where I took the video, it had started happening while connected to the dock, and continued after I unplugged it.)

System details:

  • Framework Laptop 13" AMD, DIY edition
  • Ubuntu 22.04, pretty much completely stock (notably this means I’m using Wayland)
  • Kernel version: 6.2.0-37-generic
  • BIOS changes:
    • Set battery charge limit to 75%
    • Disabled secure boot in order to update fingerprint reader firmware as detailed on the Framework support site, the display issue has happened both before and after I did that

As far as peripherals go, I have two similar-but-different setups (home and work), so I’ll post the details separately.

Work: Laptop → dock → mouse/keyboard/monitors

  • Dock: Kensington SD2500T Thunderbolt 3 Dock
  • Monitors: 2x LG 4k monitors - I think they’re both 27UL550s, but one might be a 27UN850. With this setup I keep all 3 monitors scaled to 150%.
  • Mouse is a Razer Deathadder if that matters, and keyboard is a Glorious GMMK

Home: Laptop → dock → KVM switch → mouse/keyboard/monitors/etc

One last detail: So far I have only had the dock connected to one of the rear expansion ports, i.e. the ones closer to the hinge. It was pointed out to me by a coworker that those are the USB4 ports, which might be related somehow. I’ll try connecting the dock to one of the front ports and see if the issue continues.

I’ve seen a few other threads that are similar-ish, but none of them quite match what I’m seeing (I would link to them but it seems I’ve hit my limit for links in this post):

  • “Screen flickers after logging in and at random times” - My flicker looks very different, and also isn’t related to logging in as far as I can tell (except that logout/login fixes it)
  • “[SOLVED] My screen flickers sometimes” - looks like that issue was specific to Intel iGPUs
  • “Windows 11 - Screen Flicker” - I’m not on Windows, also that issue talks about the screen just turning off and then back on again, which is different from what I’m seeing.

At this point my top suspect is driver issues, but I don’t know how best to confirm that. I can’t even tell what driver and version I’m using, other than just whatever is baked into the kernel that I’m on. I’d be happy to try updating drivers, I’m just not sure what the best way is to do that.

Welcome to the community, @jfmonty2!

Officially, for the best experience, we best support hardware we control (HDMI/DP expansion cards). Docks fill this forum with video issues, unfortunately. So work, some don’t. I suggest docks for USB duties, but expansion cards for external display support.

Rationale is usually around how the signal or power is piped through the dock, which ventures out of our control. You may open a bug report with Ubuntu, but as there are a lot of docks out there, these things rarely get solved.

For the best experience, you will want to follow step 9 from our guide, which directs you here. You will not want to be on the generic kernel, you will want to be on OEM C. Ideally, using steps 1 and 2 from the github page.

If you are using supported/tested expansion cards and still see an issue, we can explore further to see if we can replicate.

Hi, your video looks too much like the [TRACKING] Graphical corruption in Fedora 39 (AMD 3.03 BIOS) thread and my own experience on Debian testing/unstable.

Can you try adding the amdgpu.sg_display=0 kernel parameter and see if it fixes the issue for you ?

@coucouf thanks! That looks like exactly the same problem I am having. I set that kernel param and so far have yet to see the issue recur.

@Matt_Hartley Thanks for your reply as well, I will definitely install the OEM kernel since I should be using that in any case. Guess that’s what I get for not reading the setup instructions fully.

1 Like

I’m having this exact issue, screen flashes, white blocks, sometimes just looks like a glitchy screen.

I thought that I damaged the cable or the screen somehow, but inspected everything looked fine and it would work great for a few minutes and then glitch out.

It was a bit beyond frustrating trying to figure out what went wrong. I saw this thread and tried the suggestions and nothing worked, I gave up and swapped out the board again for my gen 11, now I have a AMD board that is practically useless until this is resolved.

I’m on Fedora 39.

Hm, did you take a look at the other thread coucouf linked to? Looks like this exact same bug, but there’s a lot more discussion there so you might find additional things to try.

Yes that was a helpful thread, it helped me determine that it wasn’t my cable that was buggered up, however none of the options there worked for me, still kept getting those occasional flashes and glitches.

Just to confirm I’m getting the exact flashing shown in the OP vid on Ubuntu 24.04, without an external screen, so it isn’t dock related. I’ll try the kernel flag.

I’m also seeing resume from suspend problems pretty regularly which is disappointing. At one point I closed the machine while it was in what turns out to be “trying to resume from suspend mode” - black screen but power button flashing. I came back maybe 30 minutes and the whole computer was red hot, too hot to pick up, both the base and the lid - worrying! I’ve made a point of forcing shutdown by holding down the power button if it is flashing but doesn’t manage to come back up.

I’d need to see screenshots and confirm the output of:

cat /etc/default/grub

Please run the command and confirm that amdgpu.sg_display=0 is there.

I’d also as you to confirm you update your BIOS.

sudo dnf install lshw dmidecode -y && sudo dmidecode | grep -A3 'Vendor:\|Product:' && sudo lshw -C cpu | grep -A3 'product:\|vendor:'
1 Like

I’m on Ubuntu 23.10 and now see the white flashes (after not having seen them for a long time) after reviving the screen after it was locked for a while. Logging-out and logging-in again makes it go away again.

I’m also using Ubuntu 22.04, and I’m having the same problem. From my observation, it seems that the flash happens when I’m running a vm using virtual box. I also get these errors:

array-index-out-of-bounds in /tmp/vbox.0/SUPDrvGip.c:1465:16
index 1 is out of range for type ‘SUPGIPCPU [1]’

An update on my Ubuntu 23.04 white flashing screen issue: All new kernels have the issue, but if I boot into the (older) 6.5.0-15-generic kernel, I do not have the issue anymore.

I’ve been having a similar issue on Ubuntu 22.04. I’m currently on the 6.5.0-21-generic kernel, but this has been happening almost since I first set up the machine.

When I wake the laptop up by opening it, the built-in display is sometimes partially filled with white blocks, which flicker when I move the cursor. I can consistently get rid of the blocks by logging out and logging in again, and I can sometimes also get rid of them by closing the laptop, waiting a minute or so, and then opening it again.

Just a reminder for Ubuntu 22.04 users running the default kernel:

Ubuntu LTS - use the recommended kernel, not the default one.

To address the flashing, first try this, then if after rebooting afterward it persists, you would then:

sudo nano /etc/default/grub

add amdgpu.sg_display=0

to change it to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.sg_display=0"


sudo update-grub && reboot


Oh, looks like I missed the “completion guide” when I was setting up. I’m now running the OEM kernel installed by the linux-oem-22.04d package. I’ll see whether the display problems persist.

1 Like

Update: Switching to the kernel from the linux-oem-22.04d package (currently 6.5.0-1016-oem) seems to have resolved the issue for me. I didn’t need to make any other changes. (Whoops, I spoke too soon: I’m still having the issue.)

Thanks for being on top of this, @Matt_Hartley! With this fix, my laptop is finally totally usable.

This issue went away for me after upgrading to Ubuntu 24.04 LTS Alpha w/ 6.8 kernel. I had a whole host of other issues along with that and I can honestly say its infinitely more stable.

Usually the whole screen flickered, external displays too. So many other issues with hdmi, power. Beta bios and ubuntu update with 6.8 it’s all gone.

It looks a lot worse in person, but I had to convert to a gif since I can’t upload a video reply

I knew I couldn’t be the only one.


I can’t tell you how happy I am to finally have a laptop that works for the first time since early Nov… Unfortunately it developed one dead pixel right smack in the middle of the screen yesterday though, smh.

Edit: Spoke too soon. Doesn’t wake up after going into suspend.

Yep, Ubuntu 24.04 is a ways off before it’s ready to be used reliably yet. Even after its release, it will be bug patching season for at least a couple of weeks. (edited for clarification)

Just wanted to add that I have had this problem on both Fedora 39 and Ubuntu 22.04LTS on the FW13 AMD version with 64GB RAM both on the internal monitor and external displays.

I have done the ‘first’ fix above in terms of changing the iGPU setting in the BIOS and hope that that will fix it for now.

Had success fixing this issue when connecting my FW13 AMD to an LG monitor over USB-C. Using Fedora 39, ran the command sudo grubby --args="amdgpu.sg_display=0" --update-kernel=ALL and after a reboot, there was no more white flickering on screen!

1 Like