Ubuntu 21.04 on the Framework Laptop

You’re right! I was looking at the words and not which ones were in brackets. It was showing [s2idle] deep. Thanks for that!

1 Like

Updating with my findings: after disabling deep and letting it go back to s2idle, I no longer have issues with resume.

Unfortunately the battery drain issue is back when disabling [deep]. It sounds like I’ll just have to keep it plugged in while asleep until this bug is fixed.

Right, I got it backwards, and people were polite and helpful in correcting me. For the uninitiated, it’s not obvious how to interpret that string. Here’s how I understand it now:

example of deep sleep disabled:

[jeremy@fwfedora ~]$ cat /sys/power/mem_sleep
[s2idle] deep
[jeremy@fwfedora ~]$

example of deep sleep enabled:

[root@fwfedora ~]# cat /sys/power/mem_sleep 
s2idle [deep]
[root@fwfedora ~]# ```

Deep sleep does not seem to be working with encryption enabled.

Kubuntu 21.04 kernel 5.11.0-25 Wifi and Bluetooth worked out of the box. Although I was able to install libfprint and fprintd from source and register my fingerprint with fprintd-enroll, I could not get fingerprint auth to work for login. (I think this has something to do with lack of fingerprint auth support with KDE plasma?)

I’m also using Windows 10 as a guest OS in a VMWare virtual machine that’s working well so far.

1 Like

@tombo @nebkor On Mint xfce 20.2 I’ve noticed something a little odd about waking from suspend, that almost all of the time when I drag my finger across the touchpad while it is awakening there is some sort of random issue with it when it is awake (all the way from non-responsive to responsive but not registering multi-touch to wrong speed), but when I leave it untouched it comes back on with a normally functioning touchpad (hopefully this does not jinx it…). Maybe there is something about receiving input while coming back online that confuses it?

Hmmm, although I haven’t done more looking into this, I don’t think I was giving input while it was waking any time that I’ve run into this.

Agreed! It could be formatted better for sure.

Does it sleep with high battery drain or not sleep at all? I have encryption enabled on mine.

The system does not resume properly after sleep in my case, throwing endless errors about read-only file system.


systemd-journald[585]: Failed to write entry (22 items, 752 bytes), ignoring: Read-only file system

21.04 with kernel 5.11 and default partitioning? What SSD?

  1. Yes
  2. Yes (LVM with Encryption)
  3. Sabrent Rocket 4.0 Plus 1TB NVMe (PCIe 4.0)

The Phoronix review mentions a firmware update that improves Linux performance: https://www.phoronix.com/scan.php?page=article&item=sabrent-rocket4-plus&num=1

But you’ll need Windows to update the firmware.

It is running the latest v1.2.

That’s tricky then. I may be able to borrow a 2TB version of that drive, if I can I’ll test it.

Much appreciated. Not sure it is the drive that is the issue.

Here are simple steps to follow:

  1. Download the latest Ubuntu 21.04 image from https://releases.ubuntu.com
  2. Install and partition using LVM with encryption (encrypt free space too)
  3. Install all latest updates: sudo apt update && sudo apt dist-upgrade -y
  4. Reboot
  5. Enable deep sleep
  6. Reboot.
  7. Put computer to sleep
  8. Resume and give it a few minutes after logging in, try opening firefox or a terminal


@ezhik So got my hands on the drive and actually it’s a 1TB Rocket 4 Plus.

Did a clean install of 21.04, left everything at the default except LVM w/ encryption (including free space). Updated, rebooted, enabled deep sleep, rebooted, and put to sleep.

I did a few tests of 5-15 minutes each and it resumed with no obvious issues. Checking journalctl shows no “read-only” errors. Does it matter how long it is asleep for you?

@jeshikat , I think the key configuration here is LVM with Encryption. Your test is not a 1:1 repro at this point.

When doing the install, can you click on advanced and select LVM and encrypt the drive? It is really trivial to do.

NOTE: Genuinely appreciate your engagement, assistance and efforts here.

@ezhik Possibly, although I’m running ZFS on root with zfs native encryption. Totally different layout and underlying impl.

1 Like

@ezhik ah, I worded that badly. I meant that I changed from the default partitioning (Ext4 no encryption) to LVM with encryption (and erase full disk), but otherwise everything is at the default.


When you resumed, were you able to proceed as expected? Meaning open new applications such as firefox and terminal and go on ?

The issue I ran into, I was able to login back after resume, but everything else would barf a few mins after when I tried to open new applications.

1 Like