Ubuntu 21.04 on the Framework Laptop

I let it sleep 5-15 minutes, then resumed and logged in, waited 2-3 minutes, then opened Firefox and terminal. It has worked consistently, and I left it asleep overnight and it was working this morning.

I forgot to check the firmware revision so I’ll make sure it’s on 1.2 tonight and try again.

1 Like

Good stuff, I’ll give it a shot again. I’ll do a full re-install, I was originally on 1.1 firmware, then updated to 1.2. I ran into the same issues after the update.

I’ll test it again and record the experience so we can troubleshoot.

I have re-installed using ZFS with encryption, no issues so far with deep sleep enabled!


Great! That’s so weird though.

1 Like

Hello all, running fedora. Currently, I have my “Grub_CMDLINE_LINUX_DEFAULT” set to =“i915.enable.psr=0”. How can I have both settings be put in place?

For deep sleep on and panel self refresh off:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash mem_sleep_default=deep i915.enable.psr=0”

And you probably already know this, but update-grub doesn’t work on Fedora and requires an alternative: Fedora 34 on the Framework Laptop - #49 by Jeremy_Schneider

1 Like

Is this being tracked internally? Or is there a public issue tracker I should file a ticket against?

I also just realized, the HDMI module doesn’t work either. It seems to detect that it’s plugged in and even detects the model and supported resolution of my TV, but no signal.

I have an existing USB-C to HDMI dongle from my last computer that seems to be working well.

@tombo Maybe check if the HDMI module works when attached to a different slot in the laptop?

@tombo If you find that it works in a different bay, try out the instructions here: https://knowledgebase.frame.work/en_us/one-port-on-my-laptop-does-not-function-correctly-r1mqMnTet

Usage note:

I found that my screen was changing brightness in response to the ambient light level so rapidly that it was practically flickering. Turning off “Automatic Brightness” in Settings > Power fixed it.

(Thanks to @jeshikat for this tip!)


I tried upgrading to Linux kernel version 5.14.1 on Ubuntu 21.04:

Bad news: Laptop refuses to wake up from sleep. Black screen; no fan spin; no response to key presses; power button LED stays on. Ditto for deep and s2idle.
Good news: Wifi and BT were both working well.

Rolled back to 5.12. Sleep working again.

1 Like

So on 5.11-31 everything is working, but I do notice a behavior when resuming from deep sleep. The power LED is on when lifting the lid, but the screen is blank and everything is unresponsive for about 5 seconds. Then the screen comes on and everything is normal. This seems to happen ONLY when resuming from deep sleep.

It is consistent and reliable so I’m not too bothered by it, but I’m wondering if anyone else had this, and if they were able to fix it?

1 Like

@2disbetter Same experience here (kernel 5.12.0-051200). Takes ~5 seconds for the login screen to show up after I wake up from deep sleep. s2idle is almost instantaneous though.

1 Like

Is anyone else having issues with getting Ubuntu to recognize a headset with mic when plugged in? I have a TRRS headset and apparently it’s a TRRS port, but when I plug my headset in, it just recognizes the headphones but not the mic.

Edit: the mic works properly on other laptops, like my work Mac.

@Simon_Pratt ditto. I tried a couple of headsets with microphones built in but they don’t show up in the sound input devices list.

After digging around various stackexchange questions, I finally got my headset mic working on Ubuntu 21.04 kernel 5.12:

  1. I checked my codec version
    cat /proc/asound/card0/codec* | grep Codec
    This told me Realtek ALC295.

  2. Then I looked through the kernel documentation page here. In the ALC22x/23x/25x/269/27x/28x/29x section it lists dell-headset-multi for headsets that can also be used as mic-in.

  3. In /etc/modprobe.d/alsa-base.conf I added this line at the end:
    options snd-hda-intel model=dell-headset-multi

  4. Then restarted the laptop, plugged in my headset and now I see headset microphone and internal microphone as audio input device options in my sound settings.


Just installed Ubuntu 21.04.
The good: OS has automatically recognized my WiFi&BT.
The bad: the speedtest shows the same ping, same upload speed as the same test that I run on this laptop under Win10 with the latest drivers pack. But… the download speed is 2 times lower under Ubuntu( 64-67MBps) vs (148-150MBps) under Win10.
I have checked lib/firmware – and the latest Intel firmware for AX210 is not there. So I have downloaded the latest one, copied to lib/firmware and rebooted my Laptop. I have repeated test and now the download speed has been improved – I’ve got 75-77MBps for Ubuntu. So yes, the latest firmware brings some improvement, but still… 2 times slower than under Win10… :sob:

@KOSTYANTYN_RUKHLIS did you try updating to kernel 5.12 first?

No, it’s ~3AM here in ON, Canada, I’m done as for now, got only 4 hours to sleep before the business day start. :joy: Will play later with the different kernel. Thanks for the hint.