Unable to recognize USB as bootable device

I am having zero luck in attempting to get windows 10 installed via a bootable USB. I already installed Ubuntu via bootable USB with no issues using balenaEtcher, but now I swapped out the NVMe drive and want to install windows 10 on this 2nd NVMe. I have attempted to make a bootable USB via the windows creation tool as well as Rufus, with no luck. I can get the BIOS to see the USB device under “devices”, but when I change boot order it isn’t listed. Same goes if I go right to boot order using F12 on start. It only shows the NVMe drive and not the USB device.

Anyone have any advice? I’m fairly certain the USB device is still fine since I installed Ubuntu using it recently, but I may grab a new one from the store tomorrow and see if that makes any difference. I have tried multiple expansion slots with the same results. Secure boot/fast boot don’t seem to make any difference.

I should note that the USB works fine on an existing windows install, and I can boot into the install menu no problem. It’s only on the framework laptop where I have issues.

1 Like

I’d suggest you try a “Ventoy” installation boot disk with your current USB stick. After preparing your USB stick with Ventoy the Windows (or a Linux) ISO file is just copied to the disk. If your USB stick is >8GB it should be enough though if you want to use it to install other systems, including from Linux ISOs, a stick of 16GB or more would probably be better.

My current Ventoy USB stick is 32 GB and I use it to store the Ubuntu 22.04 and Xubuntu 22.04 ISO installers. I don’t use it with Windows but have read it can be used, even with Windows 11. I have read that the Windows ISO is about 5 to 5.5 GB which is pretty large.

Ventoy creates 2 partitions, an exfat boot/storage partition and a fat16 “esp (EFI system partition)” partition. I don’t know if etcher creates an EFI partition or if it just unpacks the contents of an installer to the whole USB stick. Edit: please ignore comments re etcher, I misread your post regarding it.
With an EFI partition I’d be surprised if your UEFI (BIOS) didn’t register the USB drive as a bootable drive. It may be worth checking out in my opinion.

Ventoy home page.

Ventoy on Github Look under “Assets” for the Windows zip file.

My Ventoy USB stick in gparted …

1 Like

Tried Ventoy and no joy. Gonna try a new stick tomorrow and see what the deal is.


Question, by USB you mean a flash drive right? USB SD readers have known issues for installing, at least, some Linux distros. That may apply to Windows as well.

This thread has some details and user experiences with Ventoy+Windows.

I really doubt a different USB flash drive would make a difference if yours seems to function fine in all other cases.

I am going to reboot my Framework and take a look in BIOS to see if any ideas come to me!

Edit: So I saw some interesting things in the BIOS. First of all, my two USB-C expansion cards (one used for power, one unused) did not show up in BIOS, although my USB-A card (w/ mouse receiver) and HDMI card (unused) did.

Also, my 1TB 850 drive is displaying twice. What’s up with that? Both in the BIOS and the boot menu.

Do you have USB boot enabled in the BIOS menu?


I also noticed this recently, I just reinstalled Fedora 37 and now there are 2 entries where there was 1 before. What version of firmware are you running? I have a theory that it is a newer firmware thing (I’m running 3.10).

Yeah, just a regular USB 3.0 64 gig flash drive. USB boot is toggled on. I reset my BIOS setting and no effect either.

Grabbed a new 16GB USB flash drive, and so far it’s installing fine. It was recognized on F12 boot right away.

Sometimes the the easiest fixes are the ones that work.


That’s funny! Very glad to hear it’s working for you now. I guess that drive needs a strip of red tap wrapped around it.

Interesting, just checked for the first time with sudo dmidecode --type bios and I’m on 3.05. I assumed it would be more up-to-date since the laptop is about a week old. I’ll have to update that and report back if the duplicate drives persist.

You must have a 12th gen (you state it’s a week old). 3.05 is the most recent BIOS for 12th gen. The 3.10 BIOS is for the 11th gen.


Yes, it’s a 12th gen, thanks @Fraoch for the confirmation! My mistake for not connecting those dots sooner.


Just didn’t want to see you go ahead and try to flash an 11th gen BIOS onto a 12th gen! Most likely, it just wouldn’t work, which would probably be for the best.