12th Gen Framework - Windows 11 Install

Background:

  • Which OS: Fedora 39
  • Which Framework laptop: 12th Gen

Hey guys. I did a lot of research before I posted this question, including reading threads here with people having similar problems, but none of the advice on the other threads seems to be working for me.

My problem: When I try to install Windows 11 from a bootable USB, I run into an error that says I’m missing media drivers.

After doing some research, my current theory is that my NVMe (500GB - WD_BLACK SN770 NVMe) isn’t being detected by the Windows 11 installation program. I downloaded both the Framework Driver Bundle (had problems with the self-extracting exe because I’m running Linux, but I figured it out) and several version of the Intel RST Drivers, and put all of that on an NTFS partition viewable from within the Windows Installation.

Doing so allowed me to select drivers to install during the Windows Installation, however, none of them are compatible according to the Windows Installation setup. Even if I deselect “Show only compatible drivers”, regardless of what drivers I select, I can’t get my hard drive to show up, so I can’t install Windows 11.

What should I do to install Windows 11? Have I diagnosed the problem correctly?

Thanks in advance.

An error like this is typically associated with the use of Ventoy, or other media emulation software, to boot the ISO directly.

Something about the media emulation masks the internal storage.

If you are using Ventoy, don’t.

If you aren’t, none of this is going to be helpful :slight_smile:

No, not using Ventoy. Thanks, though.

How did you create the media you’re booting from?

If you used dd to image a Windows ISO onto the drive, you may want to try instead using Rufus from another Windows machine (if you have one).

If you don’t have Rufus or access to another Windows machine, you should be able to produce a bootable drive that adhered better to Windows’ preferred convention.

  • Format the entire drive as FAT32 and mount it somewhere.
  • Mount the Windows ISO and copy everything to the newly-formatted drive, except…
  • install.wim will not fit, as it’s larger than 4GiB in size, so you need to split it:
    • Install the wimlib tools (on Debian and Ubuntu, that’s wimtools; on Fedora I think it’s wimlib-utils)
    • Run wimsplit path/to/ISO/sources/install.wim path/to/USB/sources/install.swm 4000 to produce “split WIM” (swm) images that are small enough to fit under FAT32’s file size limit.
2 Likes

I’m glad for this question because it sent me on another path, which eventually solved the problem. It turns it out it was an issue with how I made the bootable USB (I used Fedora Media Writer).

Instead, I followed this guide to make a bootable USB instead, and it worked perfectly.

Thank you!

1 Like