USB-C/Thunderbolt Dock Megathread

When my DIY batch 3 gets here, I’ll be using the Dell D6000 with DisplayLink. I have no reason to doubt that it will work due to the DisplayLink tech being solid. I’ve used it with Linux/Mac/Windows 10/11 flawlessly. Well, kinda… it killed the Mac to display 3 monitors but didn’t affect Linux or Win…

Belkin TB-3 Dock Pro Model F4U097 here - will report back but all indications w/current usage (win/linux/macos) are positive.

1 Like

@Reese_Borel I am using the D600, and have found that everything works as advertised with Windows running.

Edit - one weird glitch after I updated Windows. The battery doesn’t always display that it is charging when plugged into the dock, and I will get a low battery warning after a while. When I reboot, the battery immediately shows 100%.


Adding HP Elite 90W Thunderbolt 3 Dock (from work teehee). Tested on Windows 10.

This dock charges the PC as well.

There is an issue where it is not detected if plugged in when laptop is turned on. I need to restart if I forget to unplug. Might be a solution in the Thunderbolt software, but haven’t explored.

Those of you testing already - could you also test if it’s possible to wake up from sleep without having to open the lid? I always work in clamshell mode and to me being able to wake up from by pressing a button on the dock is essential.

My Dell TB16 for example comes with a power button and it’s able to wake up Dell laptops (yeah, Dell-Dell only I think, but well, it does work for my current situation).

BTW while the TB16 has been discontinued for a while it’s dirt cheap on eBay and they have lots.

To make things a bit harder on my case, I need a Dock and the mouse, keyboard and monitor are shared with another laptop using a KVM. This is likely to be a problem is wake up has to happen with a keypress for example (the KVM disconnects the device if it’s powered off, so now you can’t use the keyboard to power it on).

1 Like

@Carlos_Fernandez_San - welcome to the forum!

I asked a very similar question a couple of days ago - take a look and see if those replies are helpful.

1 Like

At work I have a WD19TB with a Dell Ultra Sharp 25". At home I have a LG Ultrafine Ergo that will serve as a display and hub where the Framework will charge and be used in “desk mode”. I don’t foresee any issues, but we’ll see how things go. I’ll make sure to report back my findings.

Added the smaller Aukey (7 in 1) worked well straight out of the box. (Will travel with it)
I also added the Blitzwolf monster dock (My main desk dock now) which took some time to get working. Turned out it worked fine once I bought a ($$$) thunderbolt 3 certified cable. USBC cables (even PD 3, 100W cables) wouldnt work.

I connected both USB-C out (Which you HAVE to do to get multiple monitors per the documentation) initially to test but, I am only using 1 monitor so I just left “USB C 2” connected and everything else works.

I have a Dell WD19TB that I have done some preliminary testing with my DIY Batch 2 laptop and I have had no luck getting the dock to recognize in Windows. I so far have only tested with one of the USB-C ports on the laptop and installed the drivers for the WD19TB dock. I do get a slow charger message in windows to show that the dock is powering the laptop just not at full speed.

I have a Dell Dock WD15 that I tested with my i7-1165G7 laptop on Manjaro.
Product name: Dell Dock WD15
Model: WD15
Everything worked out of the box, without having to install additional drivers on Manjaro.

  • I could not test if the Gigabit RJ45 port works or not, since my setup is in a room where I don’t have such a port. However, when using lsusb, it is listed as a few different devices, including Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter (and it is the only device with ethernet connected to the laptop, so there shouldn’t be any mistakes on that).
  • I tested both HDMI and VGA display ports and they work as expected (although, on manjaro, we need to explicitly ask the OS to display something on them using arandr), but I don’t see why the mini DisplayPort port shouldn’t work, since both the HDMI and VGA are translated from a DisplayPort signal.
  • All the USB ports are working as advertised (Both USB 2.0 and USB 3.0 ports).
  • Both audio jack ports work as well and are detected by the OS.
  • None of the two indicator LEDs are lighting up (the one in the front of the device, and the one on the cable).
  • The laptop charges from the dock normally, and it is advertised as capable of 60W charging for the laptop. In my testing, the dock exceeds even slightly the charger in some cases. Here was my methodology. I used the /sys/class/power_supply/BAT1/voltage_now and /sys/class/power_supply/BAT1/current_now to calculate the power going to/from the battery. I had a test under a light load with a few softwares running in the background (a few terminals, 2 firefox-based browsers with 20+ tabs open on each, discord, and vscode) consuming 12W from the battery, as well as an other heavier test where I also ran glxspheres64 -n 5000 which caped the power consumption at 30W on the battery. Both tests were ran at a battery level of 70%, brightness at 100%. The FW charger was providing 38W to the battery under the light load, and 12W under the heavier load. The WD15 dock was providing 40W to the battery under light load, and 12W under the heavier load.

One thing I haven’t seen mentioned is none of these Dell docks will be able to have the firmware updated unless you attach them to a genuine Dell laptop.
Dell still supports the WD15, TB16. WD19, D6000 etc. and firmware is periodically released that personally, I like to keep current.


Note to self, don’t bother looking at Dell for my possible dock to buy.

Sheesh, Dell…


I’m also in the market to purchase a dock for my DIY edition. Excuse my lack of knowledge as I have not used Thunderbolt devices before but if I were to purchase a Thunderbolt4 dock (OWC Thunderbolt Hub), this uses iGPU acceleration and not the CPU? I only have a single 4k 60Hz monitor alongside another USB powered hub for my USB-A devices. I’m just worried about input lag or any performance issues.

I’m looking at this one for my use case. And wondering if anyone had any feedback about it.

[Docking Station Dual Monitor, 14 in 1 USB-C Laptop Docking Station USB Type C Hub Multiport Adapter Dongle with 2 HDMI VGA 5 USB SD/TF Audio for Dell/Surface/HP/Lenovo Laptops](Docking Station Dual Monitor, 14 in 1 USB-C Laptop Docking Station USB Type C Hub Multiport Adapter Dongle with 2 HDMI VGA 5 USB SD/TF Audio for Dell/Surface/HP/Lenovo Laptops

I don’t think so, I do a lot of programming and the type does not move around that fast. :grin:
And I don’t run 4k, I expect the lower resolution to be 60hz… We shall see.


Thanks, for the Framework I really only need it to work with 2-3 monitors, networking, and power… via USB-C. Unfortunately I have not found anything with that combo yet. So hopefully this will do for now.

If not Amazon returns to the rescue.

I have a couple others I am looking at, but everything seems to have a little bit of a quirk or missing something.

My current setup


Fully tested the WD19TB and can say that it doesn’t work for anything more than a Charging USB hub.

I did borrow a Lenovo USB-C dock from work and that works great with the Framework Laptop on first plug in (No Drivers needed).

I was using this UGREEN dock for a while as well and am pleased to say it works out of the box as well.

@ImaxinarDM you should check out the Plugable line of docks. I’ve found them to be widely compatible and their support staff when I’ve needed it have been top notch.


@Alec_Jurisch While I don’t discount the issues you are seeing with the Dell WD19TB, I can’t replicate that on my end. I was able to get this dock up and running very quickly. It may be that I was migrating from an Dell XPS 13 and I did a pretty thorough migration of data to the Framework laptop, which included drivers. I also updated all the available drivers for the dock (Realtek USB GBE Ethernet Controller, Realtek USB Audio DCH and Realtek USB Audio Legacy). I had one glitch which ended up to be user error. I had the volume down too low for the “Headset” inputs. Oops. Other than that, it was pretty straight forward.


I love plugable but ended giving mine up. They support Windows & Mac. Linux (deb distros at least) weren’t supported in the least.

ymmv, fwiw