USB-C/Thunderbolt Dock Megathread

One thing I haven’t seen mentioned is none of these Dell docks will be able to have the firmware updated unless you attach them to a genuine Dell laptop.
Dell still supports the WD15, TB16. WD19, D6000 etc. and firmware is periodically released that personally, I like to keep current.

4 Likes

Note to self, don’t bother looking at Dell for my possible dock to buy.

Sheesh, Dell…

7 Likes

I’m also in the market to purchase a dock for my DIY edition. Excuse my lack of knowledge as I have not used Thunderbolt devices before but if I were to purchase a Thunderbolt4 dock (OWC Thunderbolt Hub), this uses iGPU acceleration and not the CPU? I only have a single 4k 60Hz monitor alongside another USB powered hub for my USB-A devices. I’m just worried about input lag or any performance issues.

I’m looking at this one for my use case. And wondering if anyone had any feedback about it.

[Docking Station Dual Monitor, 14 in 1 USB-C Laptop Docking Station USB Type C Hub Multiport Adapter Dongle with 2 HDMI VGA 5 USB SD/TF Audio for Dell/Surface/HP/Lenovo Laptops Amazon.com](Docking Station Dual Monitor, 14 in 1 USB-C Laptop Docking Station USB Type C Hub Multiport Adapter Dongle with 2 HDMI VGA 5 USB SD/TF Audio for Dell/Surface/HP/Lenovo Laptops Amazon.com)

I don’t think so, I do a lot of programming and the type does not move around that fast. :grin:
And I don’t run 4k, I expect the lower resolution to be 60hz… We shall see.

2 Likes

Thanks, for the Framework I really only need it to work with 2-3 monitors, networking, and power… via USB-C. Unfortunately I have not found anything with that combo yet. So hopefully this will do for now.

If not Amazon returns to the rescue.

I have a couple others I am looking at, but everything seems to have a little bit of a quirk or missing something.

My current setup

3 Likes

Fully tested the WD19TB and can say that it doesn’t work for anything more than a Charging USB hub.

I did borrow a Lenovo USB-C dock from work and that works great with the Framework Laptop on first plug in (No Drivers needed).
Amazon: https://www.amazon.com/Lenovo-ThinkPad-USB-C-40AS0090-Warranty/dp/B082M4MVFG/ref=sr_1_4?dchild=1&keywords=lenovo+usb-c+dock+gen+2&qid=1631908815&sr=8-4

I was using this UGREEN dock for a while as well and am pleased to say it works out of the box as well.
https://www.amazon.com/UGREEN-Ethernet-Delivery-MacBook-Windows/dp/B082LPFM1X?ref_=ast_sto_dp

@ImaxinarDM you should check out the Plugable line of docks. I’ve found them to be widely compatible and their support staff when I’ve needed it have been top notch.

2 Likes

@Alec_Jurisch While I don’t discount the issues you are seeing with the Dell WD19TB, I can’t replicate that on my end. I was able to get this dock up and running very quickly. It may be that I was migrating from an Dell XPS 13 and I did a pretty thorough migration of data to the Framework laptop, which included drivers. I also updated all the available drivers for the dock (Realtek USB GBE Ethernet Controller, Realtek USB Audio DCH and Realtek USB Audio Legacy). I had one glitch which ended up to be user error. I had the volume down too low for the “Headset” inputs. Oops. Other than that, it was pretty straight forward.

2 Likes

I love plugable but ended giving mine up. They support Windows & Mac. Linux (deb distros at least) weren’t supported in the least.

ymmv, fwiw

Checking back in. Dell TB16 dock works out of the box with linux. No issues.

EDIT: Looks like it actually isn’t delivering power. Working on that now.
EDIT2: Same issue as reported by Kevin_Gilliatt. Must plug the dock in while the device is up and running to get it to charge.

Just received this Hub. It is running fine so far. But Windows behavior with direct connection HDMI’s vs through the hub is hilarious. Moving a screen around is a bit clunky if through the hub. Totally a MS issue.

The hub runs warm, charges the laptop fine, and I so far have Cat-6, 2 HDMI, 1 USB-A from a hub taking care of my external keyboard, mouse and trackball. I’ll get more plugged in later on.

Docking Station Dual Monitor, 14… Amazon.com

I have a Razer Thunderbolt 4 Chroma (Buy Razer Thunderbolt™ 4 Dock Chroma - Black | Gaming Pc Accessories | Razer.com). Everything works out of the box with the razer dock in Arch. It was especially impressive to see hotplugging 2 4k monitors work smoother in 2021 linux than with my work mac.

2 Likes

Much thanks for the valuable sitrep.

I think I’ll just hold out until Valve releases their official Steam Deck dock; seems reasonable to anticipate it’ll be turnkey-compatible and retain first-class support on Arch at a minimum.

Added my (albeit brief) experience with the Anker PowerExpand 13-in-1 and some confirmation on the WD19TB for @Alec_Jurisch.

The Anker might be worth looking at for some users, but for the price you can do better I think. If the lack of multi-display carries into Windows as well it’s definitely not worth it. They do explicitly say it doesn’t support Linux, so it was just a hope a prayer since I generally like Anker stuff.

On the WD19TB, I tried in both Ubuntu 21.04 and Windows 10, the Framework only drew power, no ethernet, USB, or display out. Worth noting, I definitely have up to date firmware, I use it daily with my work Dell Latitude 7390 and personal XPS 15, and regularly run Dell Command Update and Dell Assist to make sure things are up to date, and semi-regularly check against the dell.com support page since the 2 apps aren’t great about picking up updates immediately. It might work in Windows, but beyond the firmware Linux should either work or not, and that’s my personal’s main OS so if it doesn’t work… doesn’t work for me.

I’m tempted to look at the CalDigit TS3+, but I tried it previously and with my XPS and work laptop and the experience was terrible. Regularly dropped USB devices, had to replug in devices once an hour at least, and (at the time at least) you can only do firmware updates on Mac OS, and I’m not buying a computer just to perform firmware updates.

1 Like

I’ve tested 4 docking stations. 2 docks worked great and 2 did not. Below is my DIY laptop config:
CPU: Intel® Core™ i7-1165G7
Memory: 16GB (1 x 16GB) DDR4-3200
WiFi: Intel® Wi-Fi 6E AX210 No vPro®
Storage: 500GB - WD_BLACK™ SN750 NVMe™

Linux operating system:
Almalinux 8.4

Dell WDTB - Display port did not work. Keyboard, mouse, network worked fine.

Dell WDTB19 - Checked firmware version. Updated. It worked fine. The available USB-A ports not enough for me.

Cable Matters model number 201054: It did not work! External monitor display port work only once. After restart it no longer worked. Tested all Framework ports and it did not come back. Keyboard, mouse ethernet worked fine. It’s advertised compatible with Linux and Thunderbolt3. I believe it’s not.

Intpw Thunderbolt 3 - Everything worked great for me out of the box. Only 1 display port. 3 USB-C ports. 5 USB-A ports. 1 S/PDIF out connected to DAC. It’s advertised not compatible with Linux but it is in Framework. In gnome device settings dock is listed as “Intel Thunderbold3”.

1 Like

What kind of monitor(s) are you connecting?

The Cable Matters 201054 is a USB-C (not Thunderbolt dock) dock with a Display 1.2 MST Hub with upstream limited to two lanes of DisplayPort 1.2 + USB 3.0 when in HD mode, and four lanes of DisplayPort 1.2 + USB 2.0 when in 4K mode (the mode is selectable with a switch on the dock).

Does Linux support MST from the Tiger Lake GPU? What’s the kernel version?

Did you try Windows to see if it was an OS issue?

@joevt
I’m connecting to a HD monitor with Display Port 1.2.
Linux kernel 4.18. Almalinux is like CentOS not a bleeding edge distro.
I did not have a chance to test it in Windows. It could be an OS issue.

Technically this is true for Windows, but for Linux the fwupd utility can update these as well. Thanks to Project Sputnik aka Ubuntu from the factory on Dell systems (XPS and Precision so far) they’ve put effort into allowing most firmware updates from Linux as well.

3 Likes

Isn’t 4.18 old for Tiger Lake?
Intel Tiger Lake Gen12/Xe Graphics Driver Support Considered Stable With Linux 5.7 - Phoronix

What about the drm i915 driver?
Intel Submits Initial Batch Of Graphics Driver Updates Slated For Linux 5.12 - Phoronix

I’m not a Linux expert or user so I don’t know what the differences are or if updates will fix your problem. There’s probably some documentation somewhere that discusses these issues.

I suppose you could try something like Ubuntu 21.04 live USB installer to see if a newer distro would help.