USB-C/Thunderbolt Dock Megathread

I can confirm the Dell WD19TB dock works on my Batch 6 i5 unit, but for some reason I am unable to POST with the dock connected. I need to wait until at least GRUB is visible before I can connect, after which everything will work as intended. I have not tried the latest BIOS yet, nor have I confirmed if it’s a BIOS setting that I need to disable. I’ll see if I can investigate further. A handful of other issues are OS (Ubuntu 21.04) level ones, including an unknown program crash when I reconnect the dock and the occasional shuffling of active audio devices at random moments.

In the meantime, I have the dock almost fully loaded with an Ethernet connection, two displays (one HDMI, one DisplayPort), a USB hub for my 6+ total peripherals including an external hard drive, a headset, and a Lightning cable to connect my iPhone.

I just got a thunderbolt 3 dock from pluggable (Plugable Thunderbolt™ 3 and USB-C Dual Display Dock with 96W Host Char – Plugable Technologies) and it works great! I have it connected via HDMI to two 4K monitors and I’m able to run them both (although at 30Hz rather than the native 60, haven’t tried displayport yet)

I also have a number of USB devices and an ethernet cable pluged in and everything seems to be working great!

OS: elementary OS 6.1 with kernel 5.13

@asonix I have the very similar Cable Matters dock. I haven’t been able to get dual displays up on it yet under Windows. Thanks for letting us know that this one works - I’ll try and order this for myself when it goes on sale next.

I just got my Delock 87772 Dockingstation and tested it using Arch Linux. Everything works out of the box (Charging [separate USB-PD charger required], Ethernet, Audio, card reader, USB, HDMI).

The only problem I noticed is that I’m unable to get 4k@60 using HDMI for some reason, 4k@30 is maximum for my beamer. When I use a Framework USB to HDMI adapter 4k@60 is no problem. I contacted the vendor and will update the wiki post when I got more information.

1 Like

This smaller USB-C travel dock by Old World Computing is something I wanted to share my experience

The USB-c docking station supports two USB 3.2 Type-A ports, HDMI 2.0 port, SD card reader, Gigabit Ethernet port, and USB-C power pass through.

I was able to confirm it works with the Framework hardware (batch 6) using Debian/Ubuntu/Pop!_OS.

Hope to see this dock is added to the list.

1 Like

ThinkPad Thunderbolt 3 Dock Gen 2 tested with 135W power supply on Pop!_OS.

No problems with…

  • Second screen
  • Audio Interface
  • USB ports
  • Ethernet cable
  • Display Port
  • HDMI

I encountered a weird issue:

The laptop WILL NOT be powered if the USB-C expansion card is mounted on the right side. If mounted on the right side everything works fine except of the power supply. I do not know why that makes a difference but at least at works :slight_smile:

3 Likes

UNSUPPORTED

P/N: CADUAL4KDOCK
manufacturer: i-tec
name: USB 3.0 / USB-C / Thunderbolt 3 Dual Display Docking Station
link: CADUAL4KDOCK | i-tec USB 3.0 / USB-C / Thunderbolt 3 Dual Display Docking Station | i-tec

OS: Pop!_OS

Issues: power delivery does not work at all. USB hub does work, rest untested

edit: added to table

Also I’ll be using a macbook for work. Can somebody recommend a dock that works for both framework & mac?

We’ve got an ATEN UH7230 Thunderbolt 3 Multiport Dock that works with both a Framework laptop and Macbook Pro.

1 Like

I’ve tested the replacement unit for a while now and still notice some USB response issues, although it does seem better than the first unit.

I had some monitor problems (displays randomly swapping place) and found the solution to that here: Windows on second monitor moves to primary monitor after sleep/lock - Super User

Basically there are hidden monitors, likely from using different docks, and Windows 10 seems to get confused by them. Uninstalling all the hidden monitors in Device Manager and rebooting solves the problem.

I just came across to these two blogposts, which have a great list of USB-C and TB4 docks (no TB3 it seems, though), with summarized specs as well. I suspect these might be handy to anyone looking for a dock!

1 Like

Earlier in the thread I posted my experience with a hub very similar to the image in the first link.

It’s no longer available but there are many just like it - a greyish silver box with lots of ports. There are so many that are all very similar.

They’re much cheaper than the docks posted in this thread, some of which don’t appear to work all that well.

Seems to be a difference, “hub” vs. “dock”.

Mine still works perfectly.

Update on this Delock Dock after using it for some days: everything works fine, except for 4k@60Hz. Docking, undocking, suspending, starting up - no problems at all here.

Missing support for 4k@60Hz seems to be a problem with Linux DRM, I opened an issue for this: Docking station, no 4k@60Hz, intel(0): failed to set mode: No space left on device [28] (#5377) · Issues · drm / intel · GitLab

Sadly I have no Windows available here to check if it is a hardware fault.

I am currently testing out the Lenovo USB-C Gen 2 (40AS0090) with Arch Linux. While I’m not yet ready to share my findings, as I haven’t finished yet, a concern has formed. Generally it’s accepted that leaving your laptop plugged in like this for a long period of time is a bad move.

Does anyone have any thoughts on that? Any tools that might prevent issues? Or maybe this isn’t the right thread? It’s docking station adjacent.

I think the only directly affected part of the laptop is the battery. Make sure to limit its recharge in BIOS to about 75-85% to avoid degradation.

1 Like

Oh, perfect! I wasn’t aware of that setting. Thanks. :+1:

2 Likes

I think I bought the same hub, it’s branded as ZMUIPNG but looks identical. I’m yet to receive the laptop so I was wondering how the hub was holding up. Are you happy with it?

1 Like

YES, I have had it attached to the back edge of my desk and the cord is JUST long enough to connect to the laptop (do wish it was a few inches longer).

I have Cat-5, 2 HDMI, 1 VGA, my desk keyboard, mouse, trackball, Logitech C920, Audio for Speakers, Marine AIS receiver, and some other stuff all going through it.

I do route to a powered USB hub for the keyboard, mouse, trackball BTW (Not quite enough ports for my applications.)

It gets slightly warm to the touch, but doesn’t seem to be an issue. I am using the Framework 65w power adapter for it and pass though to the laptop. I do plan on getting a 100w for this at some point, but I am still able to charge the laptop fine.

1 Like

That’s great to here as my set up is similar (outside the trackball and AIS).

That puts my mind to rest, thanks.

1 Like

I have just bought and tested the Anker 575 (#3 on the list. Is there a reason the model numbers aren’t listed?). Running Fedora 35 with dual HDMI monitors and have also confirmed the USB ports, audio, ethernet, card readers, and charging all work without issue. Pretty much a perfect out-of-box Linux experience in my case.

1 Like