USB-C/Thunderbolt Dock Megathread

I wanted to add my dock to the wiki post, but got “you cannot mention more than 10 users in a post” when I tried to save it.

Here’s the table row, if someone else can add it to the post:

| Lenovo ThinkPad Universal Thunderbolt 4 Dock | 40B00135US, 40B00135EU, etc. | [B&H Photo Video](, [Lenovo]( | @kohenkatz | Ports: <br/><ul><li>Supports single 7680x4320@30Hz (HDMI only) + single 5120x2880@60Hz (Thunderbolt); or up to 4x 3840x2160@60Hz (all ports)</li><li>2 x DisplayPort 1.4 </li><li>1 x HDMI 2.1</li><li>1 x RJ45 1 GBit Ethernet</li><li>1 x 3.5mm audio jack (headphone/microphone)</li><li>4 x USB 3.1 Gen 2 (10 GBit; one on back is always on)</li><li>1 x USB-C Thunderbolt 4 (on back)</li><li>1 x USB-C 3.1 Gen 2 (on front; always on)</li><li>Uses ThinkPad "rectangular barrel" 135 W power supply, provides up to 100W power delivery. (Larger power supplies for greater power delivery require a laptop with a Lenovo-proprietary connector.)</li></ul>Notes:<br/><ul><li>Power button does not integrate with Framework Laptop</li>

Done, thank you!

I decided to spend the money on the CalDigit TS4 hub and a CalDigit USB-C to DisplayPort adapter today. The hardware is seems very solid, but unfortunately I don’t think my Framework is able to use it fully currently.

My Framework is a 12th Generation Intel running the factory BIOS of 3.04. When I plug the TS4 into my laptop, I don’t see any Thunderbolt controller in my Windows device manager. It looks like the connection is only using USB-C and not Thunderbolt. Because of this, the monitor plugged in to the hubs DisplayPort works fine at 4k 60hz, but the monitor plugged in to the DisplayPort adapter I have in the hubs USB-C will top out at 4k 30hz.

I saw the articles about the 3.06 BIOS introducing official Thunderbolt support, and I assume once I have that this hub will connect as Thunderbolt and everything will work fine. I’ve been reading the 3.06 BIOS beta thread and am hesitant to install it given all the problems people are reporting. I think I am going to just sit tight and wait for the final version to get released before updating it.

@kohenkatz I also have the ThinkPad Universal Thunderbolt 4 Dock. But It does not work on the 13` Framwork Intel i7-1360P. When I connect the dock, I get a “disconnected” sound after 1-2 seconds. If I first connect the external power supply to the laptop and then connect the dock, everything works.
Which bios and dock firmware version do you have?
Does anyone else have a idea what coud be the problem?

bios version: 03.04
dock firmware: 1.0.15
operating system: Ubuntu 22.04

@NF117 I have the i7-1280P, with BIOS version 03.05 and Windows 11 Pro.

Here is the report from the dock firmware utility:

=========== Version Check =================

Dock Name = ThinkPad Universal Thunderbolt 4 Dock (40B0)

Product = 40B0


Dock FW version = 1.0.13

MAC address = XX-XX-XX-XX-XX-XX
Checking current Dock FW version:
bcdVersion = 1.0.13
DMC FW version = 0.1.92
PD FW version = 12.5.37
TBT4 FW version = 38.00.06
DP5 FW version = 5.06.004
DP6 FW version = 6.05.000
USB3.0 FW version = 5533
USB HUB2 FW version = V1003
Audio FW version = 49-0E-41
I225 FW version = 1.73
MCU FW version = 21.10

I did originally have a defective dock that was constantly disconnecting and reconnecting every few seconds. I exchanged it, and the new one works fine. It also matters what cable you use - I’ve found that some cheaper cables are not reliable. I’ve been using this dock almost every day for the last 4 months with no trouble.

That sounds exactly like my problem. I will also try to exchange the dock and then I will report.

I tested the ThinkPad Universal Thunderbolt 4 Dock on a Lenovo laptop with a Thunderbolt 3 port. Everything works without problems there. Doesn’t appear to be defective.
So it can still be due to the different Bios version or the operating system.
Is it possible to update the bios yourself to 03.05?

Couple of older TB3 docks that seem to work fine with a Gen12 Framework 13:

  • “HP Elite ThunderBolt 3 Dock” - using this daily with Linux for a few months now, seems good. Button on the front is the only part that doesn’t work out of the box (not a Framework-specific limitation).

  • Lenovo DBB9003L1 Dock" - only tested this for an hour or so but it appears to work as well.

I have experienced some issues in Linux waking from sleep, that seem to be related to TB3 docking (either with sleep/wake while docked, or sleep while docked, disconnected while asleep, and then wake later.) Still figuring out the root cause for this, though - suspect it’s more Linux+Framework related than anything with these particular docks.

Is there a way to get the Framework to recognize a dock that is plugged in before the laptop is switched on? The dock charges the Framework just fine, but if I resume from hibernate on Windows 10 with the dock plugged in I need to unplug and replug the cable to get display and keyboard/mouse to switch after Windows boots up.

My HP Elitebook 830 G8 detects the connected displays just fine after similar resume with the same dock.

The dock in question is the Cable Matters 107044 Hybrid TB3 Dock mentioned earlier, with firmware updates as of September 2022. The Framework is on BIOS 3.07.

1 Like

I have the Cable matters TB4/3 dock and while all features work flawlessly out of the box , my connection occasionally drops… Like all plugged things. Don’t know what it may be; does this happen to you guys? I’ve tried it with a variety of Linux OSes,not sure if its a Linux thing…

1 Like

Is your battery charge limit set below 100%? A couple of us experience this and it has gone away for us by setting the battery charge limit back to 100%.

In terms of operating systems, it happens to me on FreeBSD and ellipot mentioned it happening on windows so its definitely not just a Linux thing.


Is your battery charge limit set below 100%? A couple of us experience this and it has gone away for us by setting the battery charge limit back to 100%

my limit is set to 80%

I had the same problem @Aniki_O . Try setting your battery charge limit back to 100%. I haven’t had a problem with it since doing that.

@ellipot @Tom1 Thanks, I did that, so far so good! :grinning:

UPDATE: about 4 days in and I have not encountered the random disconnect thing with the dock… Now i can confirm that this does indeed fixes it!


Removed the @'s before the usernames when I was adding the Anker 778, as when I tried to post the edit, the forum complained that the post had too many users mentioned to be able to post. Went ahead and made all the mentions just be the username, so things would be a bit more uniform.

1 Like

It’s not a dock, but the Monoprice USB-C to Dual 4K DisplayPort Adapter (which according to lsusb has a Chrontel CH7213 chipset inside) only works if the adapter is connected at time of power on. If connected after boot (or even if connected during a warm reboot), I get no DisplayPort output from it. (Interestingly if I sudo lsusb -d 0639:7213 -vvv in both the “working” and “nonworking” states the adapter thinks it has been configured in the TypeC->DP alt mode successfully.)

I do not seem to be able to edit the original thread. (Maybe intended as I am a new account.) But given the info contained here, could someone add a column for charging power? Could be useful considering we now have the FW16 to consider.

Also, I would love to know if any docks have been tested internally by framework for the framework 16 as I just placed my pre-order.

1 Like

Updated my with my HP 120w G5 dock that I recieved with my work laptop. It all works great and it’s a nice dock.

1 Like

I just tried an Anchor 555 hub which unfortunately does not work fully with our Framework 13 - with all power management disabled, the HDMI cuts out after a certain amount of time. re-plugging in the hub brings it back. We had been using the circular Dell hubs which have worked fine so will go back to that for now.

1 Like

I was using Anker 565 11-in-1 USB C Hub with my Framework 13 and it worked OKish, but when PD was used the screen would flicker and disconnect from time to time. So I had to plug laptop directly to power supply. Also - I needed to share my peripherals between Desktop and Framework Laptop, so I needed to use additional USB switch, which was lots of cables.

Recently I discovered Anker 553 USB C Docking Station, KVM Switch for a Desktop PC and a Laptop and I’ve just set it up. I’m happy to report that the flickering is gone and KVM switching works just fine.

However I’ve discovered that HDMI-OUT can only work with HDMI-IN, and DP-OUT only with DP-IN, and usb-c to laptop seems to expose HDMI port. When both PC and Laptop try to use HDMI and switch between each other, Framework Laptop seems to get into a state in which it can no longer communicate with the Docking Station until it’s rebooted. Weird, but oh well. I was hoping that I could share HDMI-OUT between both Desktop and Laptop. Still - eliminating flickering while on PD, and built-in KVM switching makes it well worth it for me.

Edit: Actually I spoke too soon. The flickering still happens, but just seems much less frequent. :person_shrugging: . Hopefully BIOS update will fix it completely then. If it ever happens.