USB-C/Thunderbolt Dock Megathread

This might not be a problem with the dock itself. Is your battery charge limit set below 100%? If so, you might be running into this issue: Thunderbolt disconnections on Arch Linux - #13 by real_or_random

Thanks, but I’ve seen this report and it wasn’t it. I actually switched from 100 to 60 after I’ve checked because seems like a good idea and I’m 99% working at my desk.

So I know that on the new Anker 553 USB C Docking Station, it works fine with 60% limit BTW.

Edit: Actually I spoke too soon. The flickering still happens, but just seems much less frequent. :person_shrugging: . Hopefully BIOS update will fix it completely then. If it ever happens.

I looked through the list but don’t see anything definite. Is it at all possible to get 3x1440p monitors out of any dock? It seems like the best they support is 2x4k. Is 3x"2k" just not feasible at all?

@stillinbeta

Seeing a similar issue. I have a 12th gen Framework running Ubuntu 22.10 and TB16 with two monitors connected, one to the full-size displayport and the other to the mini-dp via an adapter.
Unfortunately, only the mini-dp seems to actually be picked up when I connect it. Everything else seems to work fine (USB, Ethernet, Power), and I can switch monitor works by swapping their plugs. But seemingly nothing will cause the third monitor to flare to life, or even show up in Gnome Settings.

I have the exact same issue with the Dell TB16 and a 13th gen Framework (i5-1340P).

I can only ever get the mini-DP monitor output working in Linux, although both DP and mini-DP work during boot before modesetting (e.g. in setup). If I unplug the dock at any point, it no longer recognizes any external monitors. All other functions (USB, audio, Ethernet) work as expected though. Very disappointing.

Hi, I bought a Lenovo ThinkPad USB-C Dock Gen 2 (model number LDC-G2 revision A1) , but when the laptop is charging from it, it makes weird electrical noises and disconnects from the dock after a minute. I tested a dock built into a Dell monitor and got the same result (I tried the original USB-C cable on both docks and the one that came with the laptop. I also tried plugging the cable directly into the motherboard (through the USB-C expansion card), but to no avail. However, if I do not charge it from the dock (using the charger), everything is fine. But it kind of defeats the purpose of having a dock in the first place.

I have a Framework laptop 13, 12th gen with the i7-1260P and is less tan a year old

I have this dock but use it with a 13th gen Intel. I was occasionally having the dock disconnect/reconnect for no reason, so decided to try updating the dock firmware… We’ll see if that helps.

I updated the firmware using this: Firmware for Windows 11 (64-bit), 10 (64-bit) - ThinkPad USB-C Dock Gen 2 - Lenovo Support US

1 Like

Regarding the Lenovo ThinkPad USB-C Dock Gen 2:

I have the same issue and it has something to do with the power consumption and mode.
The Framework (12th) runs Linux and power consumption has been measured using powerstat.
When the laptop is in power save mode it will draw roughly 30W which is well below the advertised 60 W of this dock. I have never observed a disconnect in power save mode.
In the balanced mode and performance mode, the disconnect will happen almost instantaneous - of course your system needs to have enough load, use a stress test or compile something.
The consumption in both modes is well over 60 W, performance peaking in the 80-100 W range!
This means that the internal battery needs to supply some of this energy.

Now, I do not know which part is at fault, I haven’t looked into the embedded controller (EC) but I suspect it is the dock itself as after some disconnects it will be in a weird state where all data transmission does not work. This state can only be resolved by power-cycling the dock: unplugging the power adapter and plugging it again.

EDIT: I have now set battery charge limit to 80% and will see whether this has an impact.

1 Like

Unable to edit my previous post but wanted to post an update… The firmware update of the Lenovo USB-C Gen2 dock did not help. Still experiencing the dock disconnect multiple times throughout the day. Sometimes it reconnects automatically; while other times it disconnects, the light on laptop goes off, and only physical unplug/plug will re-establish the connection.

1 Like

I am having the same issue with the Lenovo USB-C Gen2 dock. It is driving me a little mad. It seems to happen especially when I am in a video call which is very jarring. I have run this same dock with a Lenovo T14, a HP X360, and an M2 Macbook pro without disconnect issues, so there is definitely something different about the Framework. The Lenovo and HP were both running Fedora also, so it isn’t a Linux problem. Hoping someone finds an answer, because I don’t really want to have to buy a new dock.

The company I work at had these docks when they first got released, and still have a few lying around. We replaced the vast majority of them though because we had a ton of issues with them on multiple Lenovo Models, Dells, and HP. I generally warn other people away from this specific Lenovo dock, we have not had any issues with the other USB-C/Thunderbolt Lenovo docks though.

1 Like

Not sure if this has already been covered (did a quick search but nothing conclusive) but are there any docks with known working power buttons? Having to open a docked laptop to turn it on is annoying, I miss that feature from my old laptop (though that’s about all I miss lol)

I know the first party stuff is proprietary nonsense, but I have seen some third party Thunderbolt 4 docks with power buttons… have they figured out the proprietary signals, is it sending a signal that’s part of the TB4 specification, does it turn on/off power to the laptop so that Wake on AC set in BIOS is triggered?

If it’s one of the latter two, I have a great excuse to upgrade my dock lol

Also, figuring out the proprietary signals and adding compatibility to the Framework laptops would be pretty cool, though that would probably have to be an aftermarket BIOS mod so FW doesn’t get sued :laughing:

@skylar I’ve got the following dock, and power-on using the dock power button works for me: https://www.amazon.ca/gp/product/B07PFFN219/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

Using Dell WD22TB4, so far everything I’ve tested (except for power button) works, but… dock stops working after hybernate or suspend, it doesn’t seem to be recognised anymore (connected monitors and USB-A devices not working). Wondering if there are any kernel modules of system services I could try restarting?

EDIT: Seems that the issue is with the Thunderbolt controller, disconnecting the dock while on suspend and reconnecting it after wake up seems to work (see this)

1 Like

Are you using 11th gen Intel? Something else?

11th gen. Adding to my previous post, while monitors work with the workaround described, Thunderbolt appears as “disconnected” in Gnome settings as well as in boltctl list.

1 Like

Thanks. I’m optimistic about the WD22TB4 for windows on the newer machines.

Follow up on the Lenovo USB-C Gen2 dock. I found if I plugged an external charger in first and then the dock in, I didn’t get these issue. I think it is clear that this dock can’t deliver enough power for the framework.
I gave in and bought a Lenovo Thunderbolt 4 Universal Dock (40B00135US) and so far it has been flawless, though it does take a second or two for everything to come online after plugging it in. Still, no more disconnect issues in the middle of meetings is great.

1 Like

Hey all, I just got the Plugable TBT3-UDZ which is on the “working docks” list in the first post.

I’m having an issue of a disconnect/reconnect cycle (somewhat randomly) every 10-15 min where the Framework 13 disconnects from the dock, and after about 10-15 seconds of trying, reconnects. My primary experience with this is both of my monitors turning off and then reconnecting.

I’m using the authentic thunderbolt cable from the dock, the back-left bay with a USB-C expansion card, Windows 11, and two 4K monitors @ 60Hz. Latest driver from Plugable is installed. It works great while it’s working, but it’s unlivable with the constant cycling.

Anybody have a similar experience with this dock or others, and any suggestions? This is my third experience with a thunderbolt dock doing this with the Framework laptop, I’ve not had a single successful dock experience yet…

Unfortunately this did not help. I also did a firmware update like @jackie_daytona but this did not change anything.

@Chuck_McAndrew : For me it’s everything that goes beyond the 60W power consumption, also video calls. If you want to make sure that the disconnects do not happen, switch to power save mode.

It’s quite annoying that I can only use the Framework with full performance when running on battery or with a simple USB charger. :confused:

Probably the best solution but also upsetting to ditch an otherwise working dock just because of the power delivery bug. I will try with a secondary charger like you suggested until I decide to upgrade :wink:

I can almost guarantee your dock is suspending. Check in device manager for any power settings for the dock. Make sure the laptop cannot control the power settings on the dock, i.e. the laptop cannot turn it off, disconnect the LAN etc to save power. You would think that having it plugged into AC would take care of it, but in many cases that is not the case.