USB-C/Thunderbolt Dock Megathread

Hey, I have a Dockcase 10-in-1 (the new one) and it worked really well the first time I used it, but now the two monitors (one DP 2600x1400, one HDMI 1920x1080) keep flickering on and off intermittently. Sometimes there are random lines across the screen which then devolve into the screens (either one both) disconnecting and then reconnecting from the hub (the hub recognizes they disconnected, Xorg does not.)

I’ve tried a new DP cable and that changed nothing, it seems like if I unplug everything from the dock, plug it in to my laptop, then plug everything else in, it works? It has a 100w power brick on it and the dock is set to use up to 24w of that.

13th gen Framework fwiw.

Figured out that it has to do with charging via the dock when my laptop hits the 90% battery charge cap I have set, it doesn’t have this issue if I charge my laptop not via the dock. I would be interested in having this fixed but tbh now that this is figured out it’s not nearly as big of a deal.

The dell WD19TB works great out of the box on my 11th gen!
Note: the non TB version of the dock doesn’t support dual 4k/60hz.

I’ve had the an issue with the TBT3-UDZ, TBT4-UDZ, and UD-4VPD. I’ll sometimes turn off my OLED monitor and disable it in windows settings when I’m not using it. Once the monitor goes to sleep, it will disconnect and then the dock will wake it up again and it will reconnect. Windows sees that is disabled, and this process repeats. Forever.

Usually turning the monitor completely off fixes the issue, but it is really annoying.

I’m experiencing similar with TB16, but I cannot get it to charge and connect at the same time ever. I have the AMD 13 Framework.

Dock works fine with my work machine and all my drivers in windows seem to be already up to date with the previously linked site for drivers. The only thing I cannot seem to check is the firmware of the dock.

FWIW, I can check the dock firmware on the WD 19 series with the firmware update application. Not sure if it is available for the 16 series.

Just wanted to let the thread readers know I bought the Anker PowerExpand 13-in-1 USB-C Dock on advice of this thread (Model A8392) and its working great out of the box on Framework 13 AMD with Ubuntu 22.04.3 OEM.

I also am using the UGREEN KVM Switch 2 in 1 Out (Model CM664) successfully with the Anker USB dock and Framework 13 AMD.


I did some initial testing on the AMD framework with a Lenovo 40AN dock (TB3 gen2 with the usb-c backwards compatible mode) that I got pretty cheap. It’s on the latest firmware and works fine with my t480s.

If I plug it into the dedicated device port on the dock, it seems to sometimes connect as a charger and in usb fallback mode, and often not at all.

However if I plug it into the tb3 output port it works fine, apart from the charging part. I tried networking, 2 1440p 60 displays and usb.

I am using the Lenovo ThinkPad Universal Thunderbolt 4 dock with my Framework 13 (AMD 7040U), and it is working great (no power button).

The main reason I am posting however is that given that there is no standard for docks to turn on laptops (lame), I wonder if Framework has thought about creating their own dock or partnering with a manufacturer so that their docks will also turn on Framework laptops. I would definitely buy such a dock in a heartbeat because a good clamshell experience is very important to me.

I have a MSI USB-C Docking Station Gen 2 that I have tested with my i7-1360p laptop on Fedora 39

Product Name: MSI USB-C Docking Station Gen 2
Model: 957-1P151E-010

  • Works for a random time. Can be 10 minutes or 2 hours. When it does, Display Port / HDMI / Charging 100w USB ports are working great. But it always crash after a certain amount of time. I need to unplug and replug the power to make it work. Was working well with my older windows laptop.

Not recommanded on Linux

1 Like

Laptop: Framework 13 AMD 7640U
USB4 Dock: Pluggable UD-4VPD
OS: Windows 11

Docking station has two HDMI 2.1 ports rated for 4k 120hz. I generally use one connected to an LG C2 42in monitor 4k@120hz. The expansion card will randomly disconnect, sometimes multiple times an hour and other times works fine for hours. The USB-C expansion card will blink red and then come back online in 5 seconds or so disconnecting the monitor, USB, and ethernet cable.

It especially doesn’t like Zoom meetings. I had it once where the screen never came back on my monitor or laptop even after unplugging the USB4 connection while I was in a meeting. Typically it does come back online, it’s like the expansion card crashes and restarts. I have tried 4k@60hz as well and different expansion cards on each side of the laptop with the same experience. I’d avoid it for now.

No issues with my Thinkpad Universal Thunderbolt 4 Dock, model 40B00135US


It won’t help you get your connection stable, but can you check what USB4 controller this is using (should show in Windows’ USB4 menu)? Because the specs do not fit with anything typical. If it was the Via VL830 Plugable would be lying in their specs. And if it was a classic Intel TB controller, it’d be extremely underutilized. Is it maybe an Intel Hoover Ridge?

I have 12th Gen DIY i7-1280P, Win11 23H2, normally with 1x USB-A & 3x USB-C modules installed.

I originally set up with a with j5create JCD375 for my USB-C PD dock with pass-through 100W power delivery, primarily to support HDMI & Ethernet while at my desk. It is sort of a nice feature that it has 2x USB-C modules - one for ethernet and one as an SDXC/micro-SD card reader. so when I’m away from my desk, I can carry either of these if I’m going to need them on the road.

Now the j5Create is only needed to provide ethernet & USB-A ports, but not power. Instead in the last month I have added a EXP GDC TH3P4G3 85W PD to support an MSI RTX 3090 ti 24GB vRAM card as an eGPU - primarilly for GPU compute tasks such as 6.2K edditing in DaVinci Resolve & DxO RAW noise reduction. So now the TH3P4G3 provides both PD, HDMI and a spare USB-C/Thunderbolt port that I have used for a Samsung 1TB SSD. I was concerned that the USB-C connection might throttle the 3090, but with a USB4 cable rated at 40Gbps/100w PD the connection has been very robust, and Task Manager shows the GPU humming along at 95-100% capacity while using ~20GB of its vRAM, and the performance increase is very significant :slight_smile:

The only eGPU configuration issue, was the need to configure BitLocker TPM so that it didn’t check for GPU configuration changes - described here on egpu forums - otherwise BitLocker prompts for the recovery key whenever switching from stand-alone notebook to desk use with the eGPU.

Before I found the j5create hub, I briefly tried a Feeltek 100W 8 in 1 USB-C PD Hub (PN HBC008ZZC201), but that didn’t cope with the computer going to sleep and waking up, so I returned it and swaped it for the j5create.

Otherwise everything is running sweetly.

Cable Matters 16-in-1 40Gbps Thunderbolt 4 Dock with Quad 4K Video

Works perfectly with Windows 11 on Framework 13 AMD

Monitor output does not seem to work on Ubuntu 22.04. The monitors show up in the display manager and I can set the correct resolution, but they never come on. I can probably get this working with a bit more troubleshooting…


Dell TB16 mostly works in Windows, but I get random disconnects of USB devices and sometimes the screens. Power and accessories just don’t work at the same time. I’d have to plug the power adapter in as well and just use this dock as a hub for monitors and USB.

This dock really doesn’t work with Ubuntu 22.04 and AMD 13. The dock and cable shows up as a device and that’s it.


HP usb-c dock g5 with Windows 11 mostly works, but none of the USB ports work. Seems like I get video output and ethernet though.

Did not test with Ubuntu 22.04

I’m having a weird issue using Thinkpad USB-C Gen 2 dock with FW13 AMD Ryzen (USB-C expansion card in front left), at first the external monitor was working however after a suspend and/or unplug (I need to confirm the exact reproducer) from the dock/replug the monitor no longer is detected. I haven’t seen any errors in the dmesg, resetting USB controllers on Linux, doesn’t change anything.

I am trying to use the same hub except with Linux (Fedora 39).

I have gotten it to work with only one monitor at a time(two different Acer 1080/1440) but only when using the front right port. Either back ports almost never(but have been able to just unreliably) show anything on the screen but do recognize the monitors as present. Both monitors are working perfectly when connected directly to the built in HDMI adapter or a different dongle(including both at the same time on the same side of the motherboard). When connecting to the Pluggable UD-4VPD the monitors are detected(although changes like unplugging/plugging in after the usb connection is established usually don’t get detected till replug) but nothing shows on the screens. I also have notices a “bebop” noise comes from the speakers(or my bluetooth headphones when connected) shortly but irregularly after connecting the USBC and after disconnecting which I believe might be caused by the charging activating.

Have a different dock arriving soon that I hope will work better but I had high hopes after this dock mostly worked on my old XPS laptop(second monitor was interlaced and it was bad).

This port doesn’t support desplays for AMD laptops(chip limitation), All the rest support displays although the front(closest to the touchpad) right is only USB 3.1. Not sure how you managed any screen activation from that port at all? Have you tried other Framework slots with your dock?


I believe you’re incorrect, see here :

In my case, 1 and 3 were USB-C expansion cards, and I was using 1 (it worked once) but seems to not work consistently, although I haven’t done enough testing yet to confirm exactly a reproducer.

And also this knowledgebase : Expansion Card Functionality on Framework Laptop 13 (AMD Ryzen™ 7040 Series)

You wrote front left, 1 and 3 are the back ports (on screen side)

You’re right, I’m sorry, I didn’t communicate properly, I’ll be more careful next time.

But it was, when you’re in front of the screen the two furthest ports (the one at the rear/closer to the back side) from the user.