USB-C/Thunderbolt Dock Megathread

I tried the Lenovo Thunderbolt 3 dock (SD20M70247) with my Framework 16 (Windows 11). All the ports work except the actual displays.

Tobenone dock usb-c with 87W rated power input bought and tried
Added on the chart above and it actually works with fedora 39 out of box

I have a KVM (TESmart Dual Monitor) and the display ports don’t work with it so I got the Cable Maters Triple Monitor USB-C Hub 201331

All seems to work on the laptop 16 running windows 11

I have the Dell WD-19 K20A001. Running Ubuntu 22.04 LTS.
Dual monitor output to 27" monitors on DP.
I have no issues other than the power button does not boot my Framework 13 11th gen i5. So I do have to open the lid to power my computer on, but I can immediately close it and it will work without after that.

In general those docking station power buttons only work with laptops of the same manufacturer.

1 Like
Name Model Number Vendors Contributing Users Notes
Anker 568 Anker: Anker 568 USB-C Docking Station
Amazon: B0BMXPPSG1
lbohn Tested with FL16, no dGPU; Windows 11
  • 100w PD - working
  • DisplayPort 2x - working†
  • HDMI - untested
  • USB-A - working
  • USB-C - working
  • Ethernet - untested
†Displays stable after Anker firmware upgrade to 1.3.9
1 Like

Certainly true. Only reason to mention it is, so someone does not get an incorrect expectation (if I said it works 100%, that could imply that the dock power button works).
Thank you for helping me be clearer in my comments (really, that is a thank you, I am always looking for improvement in my communication).

I would, without hesitation, recommend the Dell WD-19 K20A001. It is my daily dock. I am very happy with it. The fact that it works so well, saved me money as I already had it from a prior Dell computer. If you see one on eBay or can get a good price on one, get it. It works great.

I tried a Lenovo “ThinkPad Hybrid USB-C Dock with USB A” (40AF0135EU) successfully with the FW 16 (on Windows 10 and Ubuntu 22.04). Everything works. Just one gotcha: on Windows 10, it only worked in Slot 3, not in Slot 1,2,4. On Ubuntu I haven’t tried another slot than 3 yet (maybe because Slot 3 does not support PD and there is some error with PD negotiation?).

It’s a simple, older device, featuring 2 external Monitors max (3840 x 2160 @ 60 Hz), USB ports, Ethernet and Audio, no PD.
If your requirements aren’t too high, this thing works.

BTW: would be helpful to have a list like the one above for the FW 16 (or optionally extend the list with a field showing the type of device: FW 16 or 13).

2 Likes

Hi everyone, I had a quick look at this thread (the latest posts in particular) but couldn’t find anything conclusive, so I have to ask.

Has anyone been able to find a solid, workable docking station that can work with the Framework Laptop 16 with the added dGPU and with 2 displays? I am not too concerned about charging power because I don’t mind having the laptop plugged in to its charger simultaneously, so as not to rely solely on the docking station for power (I am well aware that it will be extremely difficult, if not downright impossible, to find the perfect docking station that can handle the FW L16 with 2 displays AND with the dGPU while at the same time being able to power it all).

Apologies if there was an “eureka!” post somewhere in this thread, answering my question precisely, that I missed…

In case of negative answer I am considering ditching the idea of a docking station altogether (except for smaller USB peripherals) and connecting the 2 displays directly onto the FW L16 (one of them can go at back, into the GPU module, while the other into an HDMI expansion bay I got). I’m guessing the only disadvantage of this setup would be having 2 unplug to extra cables when on the move, but this in my opinion vastly outweighs the cost/risk of using docking stations. There’s just too many factors at play and too many things that can go wrong …

Honestly, I almost didn’t get a dock/hub at all for these reasons. But I decided to give one a try because my laptop will be on a stand, and only having to plug in two things (the hub and power) to the laptop when I set it on the stand, plus the ability to just leave a monitor and peripherals plugged into the hub/dock was appealing. So decided to give one a shot. I replied in another thread, but I thought I’d put this here as a data point for the dock thread.

I picked up the Anker 556 USB 4 hub/dock. I went with it because it had the ability to provide the ports I needed/wanted without requiring power. It can be used as a totally passive (well, running purely off the laptop) hub. I planned to power the laptop directly off the 180W power adapter anyway, because most hubs/docks top out at 100W right now.

So far, I’ve only used it with my FW 16, 7840HS with 7700S GPU, running Windows 11. It works fine with no issues so far. I use it with just one monitor plugged into the HDMI port on the hub, a 4K, 60Hz display. However, I did test it with a second monitor plugged into DisplayPort as well, and both monitors worked, though the second monitor was a 1920x1200 display, for what that’s worth. I was able to have both external monitors and the laptop’s display running, no issues.

I haven’t tried USB PD pass-through, as I don’t need that functionality, and I haven’t tried the ethernet port. But so far, everything else works without issue.

1 Like

(Sorry BigT, I didn’t mean to make this a reply to you :sweat_smile: )

Just bought and set up a HP Thunderbolt Dock 120W G4 (sku 4J0A2AA) with my FW16 laptop dual-booting Arch Linux and Debian. I haven’t used it for more than an hour but everything seems to work right out of the box. I’ll update this with any issues I encounter.

I have a 1 gbps ethernet cable, a 1440p 144hz monitor with DisplayPort, and a 1080p 60hz monitor with HDMI, and several USB devices (most of which are connected to another usb hub on the monitor)

Update 1: I haven’t really confirmed this, but I’ve been having internet issues that I strongly suspect are caused by the dock. Discord calls randomly disconnect, the connection speed is 100 mbps instead of 1 gbps (I noticed this was the case once but it fixed itself when I replugged the cable. It might have been something else). I also thought my 144hz display was not being updated that fast, but I haven’t tested this.

Update 2: There was apparently a firmware update for the dock (distributed by LVFS/fwupdmgr) which I have now installed. We’ll see if that fixed anything.

1 Like

Thanks, this is helpful.

However the manufacturers of the docks aren’t helpful at all. the product page of the Anker Apex 12-in-1 (777) clearly states that it isn’t compatible with TB3/USB-C (probably Windows)

Are you running Linux?

Which FW laptop are you using?

I’ve been reading this thread (albeit very slowly - I’m up to Dec 2021 - lol), since I’ve ordered the FW13 Ryzen 7840U.

There is a lot of discussions around incompatibility (thanks USB SF, some standards!!!)

Let’s hold on for a bit!!! This is Framework we are talking about. Why can’t we just have a custom dock with the FW expansion cards?
image

These are almost certain to work, right?
(apologies if this has been discussed)

I had actually mentioned it too in some threads. So far, it drowned somewhere.

1 Like

Thanks which FW laptop was this on?

Thanks, this is helpful.

Do you get 2.5Gbps wired Ethernet, along with your dual display setup? Or separately?

Does it charge well?

I’m using 12th gen FW main board. Note that the 12th gen supports TB4 and the Anker port replicator also supports TB4. This system is win11.

I have used this Anker port replicator with an 11th gen FW main board even though the 11th gen is TB3. I’ve also used this Anker port replicator with usb-c laptops. These systems both are Ubuntu 22.04.

The Anker port replicator functions up to TB4 capabilities and supports lesser devices up to their maximums in my experience.

I hope this helps!

Thanks