USB DVD Drive not on UEFI BIOS Boot Menu

Laptop fine RAM disk etc installed, original Windows 10 Enterprise install went ok via booting from USB connected DVD.

Finding we don’t use Enterprise any longer I need to reinstall a different version of Windows but I cannot now get the Framework to boot from USB connected DVD drive as it did before.

(the old problem of how to remove a copy of Windows completely)

Originally starting from scratch with the SSD just installed I got the “usual” menu on screen on “hit any key to boot from …”

Now when I hit F12 (no menu on screen?) I get a “UEFI Boot Menu” but I only get the installed SSD as a boot option, nothing else is listed.

Even without a USB stick or in my case USB DVD drive attached I would expect to see a BIOS entry allowing me to add USB to the list of boot devices.

I am new to UEFI (too many years on the old style BIOS) so it may just be that I have not found the entry to add other boot device options.

Hopefully an answer to this will help others too

Regards and thanks for what is turning out to be quite a good laptop.

Make sure USB Boot is enabled in the BIOS.

Also try setting New Boot Device Priority away from Auto.


Note that although the default setting is to Email when there is a reply, I didn’t receive anytthing.


Did it help?

I’ll have @FrameworkBee look into the e-mail situation but I’m not sure if anything can be done from this end.

I did get the above response the “Did it…” in Email but not the original.
I fixed my original problem without use of the external drive and have not had the time to check why it’s not bootable, but I will and will report back.


I have not tried to boot from the USB attached DVD drive as yet, but people may be interested in the settings in the UEFI BIOS under “Boot”

In Windows you may wonder how to look at the UEFI BIOS, this appears to be unlike previous BIOS i.e. prior to UEFI where only in rare cases was the BIOS accessible from within Windows, “normally” you had to power off/on and hit a key, then alter BIOS, then save then boot into your o/s.

Typing “UEFI” at the Windows 10 (w10) start menu gets "Change advanced start-up options.

Options “Reset this PC” and “Advanced start-up” selecting the second…gets the same screen as holding Shift and hitting restart on a login screen.


Troubleshoot/Advanced Options/UEFI Firmware settings

This could be very handy is accessible remotely, although a restart is necessary so maybe not (BIG pity)

Now here is where it gets weird

Previously (to running access to UEFI) under “EFI Boot Order” I had three entries


B. Framework HDMI Expansion Card
C. Hitachi-LG data storage Inc portable super multi

Now after all I have done is accessed the UEFI BIOS again, I only have TWO entries…


B. Framework HDMI Expansion Card


More oddities now

Scroll down to “EFI Boot Order” and hit return

In case XX I had TWO entries

Asus DVD

(happy but only for a moment :frowning:

Now in case YY

I have ONE entry


So just by a second access to UEFI via Windows I have lost the entry for the external USB attached DVD drive.


There is only one other entry which may have some relevance in the UEFI “Boot” screen…

“New Boot Device Priority” (by default set to “Auto” ) = The order of the EFI boot list can be modified when the boot option is not in auto.


The options now are First, Last, Auto

As I now have only ONE boot(able) device listed First and Last or of academic interest only :slight_smile:

Ah of some interest, you will see (that you DON’T see) and selection options like “Hit F99” for BIOS etc. when the Framework starts.

Selecting the slow (not fast) boot option and increasing the delay from 0 to ten seconds allows you to see the various options when the PC starts. OK slows the incredibly fast boot, but at least (in tiny type) you see some info.

(Wonder if the “fast” boot stops WoL as it did on older BIOS PCs?)