USB Flash Installation Drive Not Being Recognized for Manjaro/Arch

System Information:

Processor: Intel i7-1165G7(12M Cache, up to 4.70 GHz)
WiFi: Intel Wi-Fi 6E AX210 No vPro
Storage: Hynix Gold P31
Memory: 32 GB (1 x 32GB) DDR4-3200
BIOS: InsydeH2O Version 3.07

I want to create a USB Flash Installation drive that will allow me to install Arch Linux on my Framework Laptop.

Every time I load my ROM to my USB via YUMI-UEFI or Rufus, the following message appears:

Default Boot Device Missing or Boot Failed.
Insert Recovery Media and Hit any key
Then Select ‘Boot Manager’ to choose a new Boot Device or to Boot Recovery Media

When I hit a key, I am sent to the Boot Manager menu, where I see the name of my USB stick under the “EFI Boot Devices” menu. When I press enter, a black screen with a “_” on the top right appear momentarily, then I am returned to the Boot Manager menu. If I press ESC, I am presented with the same “Default Boot Device Missing or Boot Failed” message show above.

This section outlines the troubleshooting I’ve done.

While I have been unable to create an Arch USB Flash Installation Drive, I have been able to get one working for Ubuntu, so I installed Ubuntu onto an SD card. From this installation, I can see my BIOS version (3.07) using sudo dmidecode -s bios-version. This is the version of the BIOS that came with my laptop when I received it, and according to Framework’s driver releases, it is the latest version. Also, based of this article on the Arch Linux wiki, it is possible to install Arch on the Framework laptop.

Following Arch’s Installation guide, I can see in the USB flash installation medium section that you should be able to make a USB Flash Drive Installer using win32diskmanager, USBwriter, and Rufus if your operating system is Windows. I tried with all of the above, and they all produced the result I outlined in the Problem section. I tried using YUMI-UEFI as well, but encountered the same problem.

When I was trying Rufus, I did try both non-DD Image mode with the MBR partition scheme and with DD Image Mode using the GPT partition scheme, as indicated on the wiki page.

I moved on to trying to install Manjaro Gnome edition, but the same problem persisted when I used YUMI-UEFI/Rufus to create the USB Flash Drive Installer.

I also stopped to try my Arch/Manjaro USB on my old desktop computer, and it shows up in the BIOS and runs just fine, but only on my old desktop. When I try the same drive on my USB

I have also tried using different USB sticks, creating the USB Flash Drive from different Windows computers and re-downloading the ISO. The problem has persisted despite this effort.

I’m running out of troubleshooting ideas, so if anyone has any ideas as to what may be causing my problems, I’d be open to suggestions.

Is Secure Boot off and USB Boot enabled?

1 Like

Boot order set to First or Last, not Auto?

@Water261 Secure Boot was enabled. When I disabled it, the USB Flash Drive was immediately recognized! Thank you!

For reference, in case anybody else comes across this:
Go to the security tab of the BIOS → Secure Boot → Enforce Secure Boot : Disabled
In the Boot tab, I set Quick & Quiet Boot to enabled, USB boot to enabled, Automatic Failover to enabled, and New Boot Device Priority to Last.

1 Like