Using Dell dock WD19TB - no display after boot

Hi all,
wonder if someone has similar issue.

When Booting my FW16 - and it is connected to the dock - which is in turn connected to a Benq DR3200U 4K calibrated display - everything works.

To reproduce:

  1. Grub won’t show up on the external screen. But boots automatically.
  2. Once booted, I can enter the decryption password to unlock the home partition.
  3. Sddm displays on the external screen fine, and shows login screen.
  4. I type in the password - and BAM - external screen turns black.

I have to unplug the W16 from the dock, wait 10 seconds, and 7 times out of 10 I mange to get the external screen working again.

What’s the best way to troubleshoot what’s going on here. Any advice?

Is this a regression?

  1. You’ll probably want to look at the kernel logs.
  2. While in the bad state look at the output for boltctl.

Also what kernel version are you on? There are some very recent changes that affect the bootup behavior for some TBT3 and USB4 devices.

1 Like

Hi Mario,
thx for the hints.
I’ll check the kernel logs next time.
Current boltctl output:

smurphy@jupiter:~$ boltctl 
 ● Dell WD19TB Thunderbolt Dock
   ├─ type:          peripheral
   ├─ name:          WD19TB Thunderbolt Dock
   ├─ vendor:        Dell
   ├─ uuid:          ca030000-0060-6c0e-835b-33144c64d821
   ├─ generation:    Thunderbolt 3
   ├─ status:        authorized
   │  ├─ domain:     7bba3804-e1f4-2aa2-ffff-ffffffffffff
   │  ├─ rx speed:   40 Gb/s = 2 lanes * 20 Gb/s
   │  ├─ tx speed:   40 Gb/s = 2 lanes * 20 Gb/s
   │  └─ authflags:  none
   ├─ authorized:    mer. 22 mai 2024 07:19:41
   ├─ connected:     mer. 22 mai 2024 07:19:41
   └─ stored:        mer. 13 mars 2024 09:34:23
      ├─ policy:     iommu
      └─ key:        no

I’ll try to access it remotely to see what is going on. I have a PiKVM here that is here just for that.

Kernel version is:

Linux 6.5.0-35-generic #35~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Tue May  7 09:00:52 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

Maybe I should upgrade the kernel?

Maybe I should upgrade the kernel?

Yeah it’s worth checking if this is still a bug occurring in 6.9.1. Here’s a mainline PPA build to try.
Index of /mainline/v6.9.1 (

Looked at the kernels. It is a good pointer, but it is a production machine, so I can’t just change it (encryption etc. active), and these kernels are not signed. Can’t boot as secure boot is enabled.
I have a workaround now (replug etc.). As soon as a new signed kernel is available, I’ll check it out. Thx for the pointer though.

Can you try a Ubuntu 24.04 live image perhaps? That’s got a signed 6.8 kernel at least. It’s missing the thing from 6.9 I was talking about that changes things at bootup, but it could be a good data point.

I can do that. Will report back.
UPDATE: So, Ubuntu 24.04 live boots - but it opens a expanded display (internal + external) while internal remains enabled. So when I close the lid and try to boot by powering the dock (bios setting), I only see the extended desktop with no panel. Have to open the screen to actually access to the rest.
Can’t get it to live boot only into the external screen.
Kernel seems to work so far.

I’ll troubleshoot a little more when I have time again - Middle next week.

Interesting. it almost sounds like a bug that the eDP isn’t being turned off by default when it’s booted closed.

Would really love if you can boot a mainline 6.9 kernel off an SD card or USB stick or something to see if this still exists in 6.9. It’s quite a surprising behavior.

Tried looking for a 6.9 kernel enable linux distribution, but didn’t find any.
You have something I could try?

Arch Linux based distros have it, as does Fedora rawhide. You. An find it for Ubuntu here:

But yeah this requires turn off secure boot since not signed. So if need be I would say install on a USB stick or something.

ok. Did disable force secure boot during lunchtime to boot dmesg-6.9.1-060901-generic
Unable to copy & paste. Forum software always shows me a 403…

I did paste my results here: Cutout Warning from DMESG. on my private site’s pastebin.

If you want the full dmesg, let me know.

I’m aware of this warning, but it should be harmless. We have a bug on drm/amd tracking it.

Most importantly did the lid behavior you described happen?

Yes. It still happens … :frowning:

Got it; I think it’s the same problem as this issue then.
Laptop screen enabled after booting with lid closed (#3349) · Issues · drm / amd · GitLab

It sounds generic somewhere in the GPU driver not specific to Phoenix.

I’ve reproduced and I think I have a fix. I’ve posted it to that bug. Can you please test it?

Is there a build somewhere, or do I have to get the source, apply the patch and compile it?
Havn´t done that in a while (15+ years) :slight_smile:

I tried to build it on a PPA for you but it failed for some non obvious reason. But it seems to build just fine locally.

I added the repo but don’t know which to install.

# apt-cache dump | grep 'linux-image' | grep '6\.9'

Any hint? Thx.

The build failed, I don’t know what’s wrong with it on the PPA.