Weird intermediate sleep state

I am currently experiencing a weird issue (one of the ones i mentioned here) regarding sleep.

I closed my laptop and put it in my bag when i left the house this morning. While I was out i heard the laptop make the kubuntu “low battery” noise in my bag, which told me that it hadn’t fully gone to sleep and was still on. I plugged it in and after playing around with opening and closing it (and not being sure if it was awake or asleep or just waking up since it takes about 10-15 seconds), i briefly see the login screen showing it had about 8% battery left when it was almost certainly at or near 100 before leaving the house.

Now my laptop is open and charging with a dark screen, a solid white power LED, no response at all from the keyboard and trackpad that i can tell (caps lock light doesn’t work), no response to having an external HDMI monitor plugged in, no response to a USB-A mouse being plugges in (it does not appear to be receiving any kind of power), but i can hear the fan spinning so i imagine it must be on or doing something.

I’m not sure if my attempts to open/close the lid to get it to show me a UI were what caused this, but i suspect its now stuck in some kind of intermediate sleep state where it seems like the keyboard/trackpad/screen are disabled by the firmware, but the laptop seems to be on. I know I can hold the power button to shut the laptop off and reboot it, but id like to see if i can preserve any chance i have of saving logs if possible so i can help diagnose/fix this issue.

OS: Kubuntu (21.10 i think)
BIOS: 3.07 i think

I’ve seen this happened to me. Didn’t bother enough to troubleshoot it.

Have you tried plugging in an external keyboard? Is the OS running in the background to give you USB input?

just tried this and im seeing no indication that an external USB-A keyboard even has power. I suspect that the ports are disabled (or in some low power state) along with the internal keyboard and (maybe) trackpad. Attempting to pressing the volume/mute buttons on the internal keyboard to try and get the device to make a sound has no affect either.

Given that my laptop takes a while to wake from sleep, I wonder if i was just impatient and tried closing the lid (to reopen it and re-trigger the wakeup process, thinking it was still asleep) while it was trying to wake up. Is it known whether there’s any kind of debounce/timeout on the lid sensor to prevent multiple rapid inputs from causing problems?

It might be related…but a well designed / built laptop should be able to get to whatever the current state is. i.e. If this does turn out to be the issue… I would expect Framework to close this gap.

honestly id be willing to (at least try to) make the contribution myself if i can get to a reproducible test case and/or get logs of what happened

Good man! I was only able to ‘run into’ it a handful of times…unintentionally.

What happened in your case? anything specific about what you were doing when this happened that could be useful?

To my recollection, there was nothing out of the ordinary. I closed down all the apps, closed the lid, came back after 8 hours the next morning…open the lid…and it was just stuck like yours. In my case, no data loss as I don’t typically leave sessions opened / running.

It sounds like your suspend process is hanging. Since the OS is responsible for establishing that, I would just recommend that you upgrade to 22.04. Or try to figure out what is causing the process to hang or error out.

I’m using Ubuntu 22.04 LTS and it is rock solid. Standby performance has been fantastic. I let the laptop sleep for 19+ hours from 80%. It used only 37% for nearly 20 hours. That is really good. My laptop was cold the whole time and in sleep mode the whole time.

quick search seems to bring up systemd - Kubuntu 20.04 Shutdown/Reboot Hangs At "Waiting for process: crond" - Unix & Linux Stack Exchange. Thanks for the new rabbit hole to investigate!

do you think its likely ill be able to get a shell into my current system without hard rebooting?

i don’t know how i didnt notice before but the side LED on the side where my charger is connected is blinking red or orange (cant really tell) with a 50% duty cycle (half the time its on, half the time its off).

edit: some research indicates that this is normal charging behavior. is this right?

The LEDs on the sides of the Mainboard should blink red when the Power Adapter is plugged in.

edit: unplugging and replugging in the power cord makes the LED change to solid white as the laptop is fully charged. so maybe that was nothing important

in BIOS 3.07 there is a bug where the power limit met led indication (blinking amber) happens when the battery is full, even without a charge limit. If it went back to solid white when the charger was replugged, this is expected behavior.

1 Like